Unresponsive Nucleus Plus Rev B

Roon Core Machine

Nucleus Plus machine Rev B with 2 TB internal drive storage

Networking Gear & Setup Details

Net gear A8500

Connected Audio Devices

Mac mini M1

Number of Tracks in Library

Description of Issue

The Nucleus Plus was working fine for about 5 months. TOday it stopped being findable on my network. I’ve powered off, unplugged, double checked the Ethernet cable with no recovery.

I saw it power off and on itself at least one time. Indicator light on the power button is on, and the green indicators on the Ethernet connector are flashing, but no device can be seen on my network.
In addition to the Mac Mini M1, I have been using an iPad Pro 12.9 and a MacBook Air. None of them can see the Nucleus Plus.

Please suggest what I should do next.

Hello Bruce and welcome to the community.

Do you have a monitor or TV you could use with the HDMI output from the Nucleus to see if there are error messages in the boot up display?

I do, and I just hooked up to HDMI A and did a hard power off, then power on. No signal appears to be present, and the device powered itself off and then back on one time. Tried the same maneuver connected to the HDMI B port, with exactly the same result.