Unstable connection to core (Win10)

Help, @support! My roon remotes keep dropping their connection to my Roon Server. It will connect, then drop, then connect again, then drop in a constant cycle. I’m not sure if it’s a problem with the server or with the router. Roon 1.3 ran just great with this same hardware and network infrastructure all last year. How do I troubleshoot this?

I’ve changed the Win10 network from Public to Private and turned off the Norton firewall, but the problem is still happening.

Here’s the core software:

  • Windows 10 Pro 64-bit (recent clean install)
  • Roon 1.4 64bit build 300
  • Norton Security Suite (turning firewall off doesn’t help)

Here’s the core hardware:

  • Core i7 2600k 3.4ghz (2nd gen)
  • 8GB RAM
  • 480GB SSD system drive
  • 1.3TB HDD file storage drive
  • 1Gbps Ethernet connection


  • ASUS RT-AC68U router (latest firmware)
  • 1Gbps to server
  • 2.4Ghz and/or 5Ghz to remotes


  • iPhone 8 Plus
  • Nexus 7 (2013)

Here’s a screen capture video of what happens when I try to manually re-connect in the remote app:

Thank you for the report and sharing your feedback with us @Andy_Spinks. The insight is appreciated and sorry to hear of the troubles.

Moving forward, during your troubleshooting of this behavior have you tried…

  • Reinstalling the application on the mentioned remote devices?

  • Rebooting not only your core machine but also any relevant networking hardware (i.e router, switches, etc)?

Additional tests…

TEST #1:

  1. Shut down your Core
  2. Open Roon on your Remote
    (Tip: If you are using a iphone, make sure you keep it awake)
  3. Roon should be on the “Searching For Core” screen
  4. Start up the Core

TEST #2:

  1. Start up your Core
  2. Open Roon on your Remote
    (Tip: If you are using a iphone, make sure you keep it awake)
  3. Kill the Roon app
    (Tip: If you are using Android please go to Settings > Apps > Roon > Force Stop)
  4. Restart Roon on on your Remote


Please uninstall it. Completely.
Reboot, try again for some while.
You can reinstall it later if you need to.

I tried a great number of things, including doing another clean install of Windows 10 (this time without Norton or any other software except Roon), resetting my router to factory settings, replacing & removing the switch in between my router and core, running the core on WiFi, etc., etc.

Some of these things seemed help, but the problem came back. Here is the change that seems (so far) to have finally resolved the problem: Turning off the thing in netplwiz which automatically logs in on startup. It seems that somehow this was gumming up the works and making lots of things (including Remote Desktop and sometimes even a hands-on unlocking of the desktop) act squirrelly. After re-checking the option in netplwiz to require a password, restarting, and logging in normally, the connection to the core has been stable for a few hours.

Assuming this does turn out to be the root problem, it creates another issue: Now every time Windows restarts (power failure, security updates, etc.), roon is inoperable until I get a chance to log in to the core. This creates many, many more chances for my wife to ask “Why did we pay $500 for something that doesn’t work consistently?”

@support, I’ll take your word for it when you say there are legitimate reasons Roon can’t be run as a service, but what can be done here? How do people with headless Windows cores deal with this issue?

Andy, something very odd going on here with your setup, because the auto-logon is necessary for a headless Windows Core.

You say that you have set up the auto-logon again, yet then you say: “Now every time Windows restarts (power failure, security updates, etc.), roon is inoperable until I get a chance to log in to the core.” But this is exactly the behaviour that is expected when auto-logon is NOT set up - Roon server will not start until the user logs in to Windows.

As I say, something seems to be odd about your configuration here. Note also the last paragraph in that KB article:

A word of warning: if you ever subsequently need to remotely connect to your headless PC using Microsoft’s Remote Desktop app, you will find that your connected devices and their Zones will disappear. Once you have finished using the remote session and closed Remote Desktop, simply reboot your PC, and Roon will find and display the devices and Zones once more, providing that you have auto-login set up.

I guess I worded that in a confusing way. I have re-enabled the password requirement, which disables auto-login.

Ah, OK, so the behaviour you are now seeing is as expected - the Core server won’t start until you log into Windows because you’ve disabled auto-login.

That leaves us with a puzzle, was the cause of your original issue the auto-login, or something else? Because auto-login is necessary for headless Windows systems running Core server, and I suspect there must be dozens, if not hundreds, of such systems out there in the Roon community.

Does the issue reappear if you re-enable auto-login?

Yep, it ran perfectly until I re-enabled auto-login and restarted. Then the problem came right back.

When using auto-login, I was also seeing issues with Remote Desktop, and based on the KB article that mentioned that Remote Desktop would cause Roon endpoints to disappear, I thought it might be a conflict between Roon and Remote Desktop. With auto-login enabled, I tried turning off Remote Desktop and using TightVNC to connect, but that didn’t help.

Turning off auto-login and restarting allows it to connect right away.


Did you consider trying the following:

This allows you to have password and automatically login as well.

Um, that’s what Andy did in the first place, which is what seemed to be causing the problem… I still think something else is behind the issue, but what, I have no idea…


There are two ways of achieving auto-logon in Windows:

  1. Empty password
  2. Having a password and telling Windows to automatically logon the user (the technique I’ve suggested).

The former may indeed have issues with the Remote Desktop.
This is why I’ve asked whether the second way has been attempted.

Could you please try to set the password and enable auto-logon?
Also, if all that has been attempted, could you please completely uninstall all 3rd party antivirus/firewall programs?
Disable built-in Windows Firewall as well?
And see if that helps?
Then you can of course re-enable things one-by-one and see what breaks it.

Netplwiz was the method I used for auto-login. It ran great with auto-login disabled for nearly a week, then I started to see some problems again—both roon core connection problems and Remote Desktop errors.

This morning I did another clean install of Windows, this time dropping back to Windows 7 ultimate. Instead of using my Microsoft ID to set it up, I just created a simple local admin user account, and I used Netplwiz to enable auto-login. I then proceeded to install drivers freshly downloaded from my motherboard manufacturer’s website, run a few of the kazillion updates Win7 needs these days, and turn on RDP so I could monitor progress from my laptop. When I tried to install Roon (full 64bit version: core, output, and control), Roon balked because my system didn’t have OpenGL 3.0–and recommended turning off RDP as a possible solution.

At this point, I had a bit of a “Eureka!” moment, thinking that maybe the issue is a conflict between Roon control, Remote Desktop, and my ancient embedded graphics processor. The machine I’m using for core was a desktop PC before I started transitioning it to a server only, so I had always just put the full version of Roon on it (including control). It occurred to me that everyone running headless, auto-login machines are probably running Roon Server (no control, no OpenGL required). I proceeded to point IE 8 to the Roon downloads page and install Roon Server only.

It has been working great so far today. A little slow, probably because those kazillion updates are still downloading and installing. Time will tell, but I hope just running Roon Server on a barebones Windows install will work. (The mystery still remains why turning on auto-login would instantly bring all these problems to the forefront, but if it’s solved, I’ll be happy.)

This is great!

Welp, here’s the latest chapter in this game of whack-a-mole:

My connection to the core ran perfectly all afternoon and evening yesterday. But when I got up this morning, no connection. Remote Desktop was unresponsive. I quickly figured out the sleep settings had kicked in, so I woke up the server PC and turned off the sleep setting. But I still could not connect to Roon core or Remote Desktop. Even after I rebooted the server PC. Sigh.

After my coffee kicked in, I started trying to think of anything I had changed that might be causing this problem to resurface. I had tried out numerous Roon endpoints over the last few days, but I happened to think of one that I had re-connected at some point yesterday: an old AirPort Express that I use as a Roon/AirPlay endpoint for an even older Bose radio in the bedroom. I unplugged the AirPort Express from power, and immediately, Roon remote connected and Remote Desktop started working again. Is this device the culprit all along? I still think the Roon control is too much for my old graphics card in the core, but maybe this device was interfering with network operations as well. Again, time will tell.

The combination of switching to Roon Server only and ditching the AirPort Express seems to have solved the problem. I even went back to Windows 10 Pro for the operating system and re-enabled auto-login. Wish me luck when I turn on OneDrive and resume backing up my music files!

Good luck!

Please also consider backing up to a NAS. Might be a better and faster option.

Only better if the house doesn’t burn down :stuck_out_tongue_winking_eye: