Unusable performance

Not sure if you have any firewalls active. But if you do turn them all off

Hi @Kenny_Watt,

Are the devices on the same subnet as the Core?

What is the model of the router you’re using?

Hi Dylan. I sent a reply to your last post but don’t see it on the thread. The devices share switched ports on an Asus AS68U router/switch. They are all on the same subnet as it happens. Other devices share the same network. For example, from my Naim devices (clients and the Uniti Core server) in can see, browse, navigate and stream from the Synology NAS with no apparent delays.

Roon doesn’t, it doesn’t scroll in a usable way, the interface freezes for 10s of seconds but there’s no evidence that is analysing/sorting in the background. It’s possible there’s some underlying problem here but everything else I browse or stream works just fine - including browsing/streaming from a Naim client across WiFi.

Kenny

So here’s a thing… I just opened Windows Media Player for the first time on that machine. It took about half an hour to scan all the album’s on the Synology NAS. Even while it was updating, I could scroll through and select albums. Once the library was complete it continued to update album artwork but I could still scroll, select and stream quickly.

The WMP is running on the same Sony PC as Roon but seems to have none of Roon’s problems. Not sure what else I can do to support my initial suspicion that your software is not performing. Even from a DLNA client on my phone, connecting over WiFi to the servers, I can scroll, select and stream music just fine.

Any thoughts?

After doing that with WMP, I just reopened Roon. It took a few minutes to start but appeared with no album art. When I scrolled the first page of albums, it stopped as it’s been doing. It’s now, very slowly, adding artwork to the page that’s visible. That’s taking minutes for just one page. It currently will not scroll.

Was that in some way relevant? It talks about instability not slow performance. Is there any specific advice on this that might help resolve the problems I’ve called out?

I really appreciate the responsiveness of the people on this thread but am not sure I’m any closer to resolving my problem with the product. Root cause analysis isn’t always easy but I think I’ve probably provided enough evidence to suggest that the problems I’m seeing are specific to the Roon installation on my computer. The only practical advice I’ve been offered is that the 32bit version may work better and that the instruction manual might help advise how I can install that over the 64bit version without having to reinstall the database. But that advice then became confused by advice that the client was the element that would benefit from the 32bit version. In tried that but it didn’t help. I haven’t tried it on the Roon server but will if I’m given a clear indication of why that’s likely to fix the problem I’ve reported.

Are there any other thoughts on why I’m getting this experience? Is it common for users to experience these sorts of problems?

Thanks for having a go, but I’ve explained that other music library/streaming applications and services work perfectly well with the stores I’m using. The single component demonstrating a problem ( a severe performance one) is Roon. My suspicion is that is just struggling with the volume of data involved. I can’t see that there are any settings in the interface that would help optimise performance. I’m getting very close to uninstalling it and requesting a refund. I’d much prefer not to as I like what it’s trying to do, it just doesn’t perform.

1 Like

As an example, I was just playing a track then surveyed another one from another album. It took fully 30 secs to respond and play the new track. Doing exactly the same thing with Windows Media Player running on the same computer with the very same NAS switches track instantly

Why not try with the music stored on a drive attached directly to the Roon Core system?

No ideas, but it is not likely volume of data. With about 113,000 tracks (mostly FLAC), my interface is very snappy. (On both Win 10 machine and SonicTransporter i5). Edit: not using NAS. Files in attached 4TB USB drives.

From the Roon CTO:

I’m still not clear on what your Roon setup is. Roon software is available in different packages for different combinations of functions.

Are you saying that on your Sony PC you have the Roon Server software package installed (i.e. the Roon component running the Core), and you have also installed the 64bit version of Roon on that same PC to act as the Roon Control (i.e. the Roon UI)? Or have you just got the full Roon software package (64bit) installed on that PC so that is acting as both the Core and Control components?

2 Likes

Roon is not other music library / streaming applications. Because of the interconnection within the database, it has very different demands. That’s why RoonLabs recommends a fairly recent x86 machine, and not a RaspBerry Pi which’d run other music library applications just fine as a server, and why people asked about SSDs. It’s also why you might be hitting an OpenGL bug.

It isn’t struggling with the volume of data. If you had half a million tracks, then maybe that’d be on the table.

There you go. You want to export the database, install the 32 bit, and reimport the database. Export / backup doesn’t have to be to a different drive if there’s enough room there.

I’m probably partially responsible for that, and I’m sorry I made things worse rather than better for you. The upside is that we now can assume that the problem isn’t the client machine, which could’ve been possible.

I very much understand your frustration, and I’m quite frankly amazed you stuck to Roon for this long. If that can be of any relief, the sluggishness you’re describing is emphatically not normal at all on the setup you’ve described.

Please take the time to describe your setup as extensively as possible, as @Geoff_Coupe has suggested. That’ll help everyone trying to help you. One thing that’d help at this point is having a specific model for your Sony all-in-one. Another is knowing what other software you’re running on that machine.

Seeing what you’ve described, I see a few things that could be a source of issues (in no particular order). Others will probably pick up on other, possibly more relevant stuff.

One is a completely saturated SSD, as @grossmsj put a finger on higher up. I know this sounds like basic stuff, but knowing if you’ve got a really full drive could help rule that out. You know that, we don’t.

Another is the intel bug @Geoff_Coupe mentioned. Installing either 32 bit or server might weed that out. I’d try those two in that order. Server doesn’t have to whip up a rich interface (so if the intel driver bug is what’s making your all-in-one spazz, that’s out), and is lighter on the system.

Yet another, because there’s less people using those than NASs, is that there’s some outlier issue with Naim’s SMB sharing and Roon in your particular setup. One way to test for that would be to temporarily take the Naim out of the equation (by removing the shared folder from your Roon core (within Roon, Settings - Storage - three vertical dots next to the folder, remove) and doing a library cleanup after that (library - library maintenance - clean up library, mark all three options). This is a much longer shot, and quite a bit more involved (because putting it back will mean rescanning that, and it’ll take time), so that’s what I’d try as a last resort.

1 Like

This does seem to be a key point. I’d bet that if all of your music files were resident in an external SSD attached directly to the Sony via USB, you wouldn’t be experiencing this lag problem.
I know it would be a hassle, but I’d take the formal NAS devices out of the loop.
Don’t give up on Roon just yet. Fascinating thread!

Thanks Xekomi, that’s a very thoughtful and helpful reply. I’ve probably provided most of this into along the way but I know that can get confused or lost, but happy to pull that together to help you understand what I’ve got. I think there’s a chance there have been two threads running as well, which certainly won’t help.

I’m using a Sony Tap 20 SVJ202A11M 20" All-In-One PC/Tablet - i5 3317U 1.7GHz/8GB/240GB SSD. It’s been recently rebuilt from scratch and the disk is new, so had very little on it. The machine has minimal applications loaded. A couple of browsers, Spotify and the standard Windows 10 stuff. I opened and set up WMP last night as as comparison but that hadn’t been started previously.

The device is connected to as small Cisco switch that in turn connects to an Asus AS68U internet router. Also connected to the Asus are a Synology 4 disk NAS and a Naim Uniti Core ripper/server. That’s basically it.

I’m new to Roon so just installed the 64bit core product. I assume that’s the bundled client/server you refer to.

I’ve been unable to get any remote clients to connect successfully but haven’t really investigated that. The clients do see the core by name and try to connect but repeatedly they fail and retry.

I did he trouble with the Naim initially, in getting it to see the NAS so I could back it up but once I worked out what that was it worked. That was a black/white situation, not a performance one as I’m seeing with Roon.

I have 3 Naim client/player devices. They worked perfectly out of the box. One of those connects to the same Cisco switch as the Sony PC, the others via WiFi. They browse, select and play music instantly. As do any other DLNA clients I use to browse and play music. I also stream video too a smart TV that’s also connected to that Cisco switch. That too works absolutely fine - no performance problems despite the far higher data rates involved.

Using Talk Manager on the Sony, it’s clear that the device is not stressed. CPU usage is ok (2-12% but 2 typical), RAM usage is moderate and steady. Almost all usage is Roon. There’s loads of free disk space. I think only about 64G used out of 256.

So I don’t think there’s anything very unusual in there. The biggest frustration I have is that everything else seems to work just fine.

Again, thanks for taking time on this…

1 Like

Apologies for a few typos… Predictive text on my phone

So you haven’t actually tried installing the 32bit Roon on this Sony PC as I suggested? I’m still betting on this being a graphics issue on your Sony PC, and the 32bit version of Roon is usually successful as a workaround for the issue.

Thanks for taking the time to describe your setup. I agree with you there’s nothing very unusual, apart from things not working properly, that is.

From what you’ve said, and assuming Roon 32-bit on the AIO doesn’t fix things, one red flag for me would be the Cisco. Roon tends to super-plus dislike managed switches, so if it’s a smart switch and acting as one, you might want to have a look at it, even if you’re not using VLANs.

I believe others here have experience setting Cisco switches with Roon, so maybe they can help you see if it’s there.

Here again, Roon’s transport protocol is not dlna. Different beast, different issues.

If you have a backup of the Naim’s music in a folder on your NAS, you might want to add it to Roon rather than go through the network to another device to get access to that. Less complexity is always good.

Roon won’t touch the data if that’s what you’re concerned about.

It’s generally not a great idea to use a NAS with Roon (they introduce undue complexity, and a single drive directly attached to the core has far less latency), but if that’s an issue, I’d bet there’s something weirder going on as well.

Yeah, long story short, you’ve essentially got three different blocks in a Roon setup - the server (Roon calls this the core), the remote (or controller), the client (roon calls this the endpoint).

You can converge things in multiple ways (say the desktop apps, that are all three at a time, or the mobile controller apps, that are both controllers and endpoints (since you want to be able to listen to music on your iDevice), or a ROCK device that serve as a core and an endpoint but not a controller). Obviously, isolating elements can help with troubleshooting when there’s a problem.

Thanks again Xekomi. Looks like my best bet is the 32bit software as Geoff suggests. It feels like a bit of a shot in the dark to be honest but I’ll give that a go. It would be good to understand exactly what’s different in the 64 and 32 bit versions to justify the effort but best plan is to try it I guess. I’d hoped maybe the Roon guys themselves might have jumped in with some info on that.

If it’s not capable of working with Cisco switches without a load of pissing about, I’m really not interested tbh. If that’s the problem I’ll uninstall it and request a refund. I think that would just be ridiculous.

I’m also not in favour of making further copies of my music. That just complicates the whole management/backup thing, which is precisely the train for me getting a multi drive NAS. As with that Cisco switch suggestion, if Roon isn’t capable of working seamlessly with a NAS, I’m really not interested. That’s too much work for a very marginal benefit.

Those appear to be the only specific recommendations I think I’ve been given (thanks all again). Apologies if I missed any others. On DNLA, I’m aware that Roon doesn’t use that, I was just pointing out that I use other ways of browsing and playing my music without any problems. If the 32bit version doesn’t improve things, I’ll just do that and save myself a few $100…

It’s because of the Intel HD drivers that don’t cooperate well with 64bit version.