Unwanted channel remapping

I am using Roon with multiple endpoints, including a NAD T758v3 receiver in a 5.2.1 setup. When I play multichannel SACDs or DVD-As on my disc player, they play in proper multi-channel goodness. But when I try to play multichannel rips through Roon, they play back in 2 channel only – not even as a proper downmix, just losing information. When I look at the signal path, I see:

How do I tell it not to alter the channel mapping from 5.1 to 2.0?

Thanks!

Are you connecting Roon to the receiver via the network or via HDMI?

My core connects to the receiver via Ethernet.

The NAD endpoint not the core.

I think it needs to be via HDMI or it won’t work the way you want it to. Network connected devices that were multichannel capable like the Oppo devices had the same issue.

1 Like

Are you saying that the core (a MacBook Pro) has to be connected to the receiver via HDMI for multi channel content to playback as multichannel? Is that a physical limitation? I’m running through gigabit switches and Cat 6 cabling, so I wouldn’t think it is a bandwidth issue.

I am currently running the core in a different location than the HT setup. It will be a real PITA to have to move the core into that room.

Like @Henry_McLeod, I’m pretty sure that the physical connection with a receiver needs to be made using HDMI in order to support Roon’s multichannel. Perhaps @support can comment here?

If you can’t/don’t want to move your current Core to your HT location, then a possible alternative is to add an endpoint (connected via ethernet to your Core) with an HDMI connection to your receiver.

Some folks have done this using a basic ROCK/NUC setup. This will make an endpoint capable of delivering multichannel using HDMI to your receiver.

Although this endpoint is in effect a complete Roon system with Core and Output functions, in this scenario, the Core is not being used, just the Output. You continue to use your MacBook Pro as your Core.

Of course, you could also migrate to having your Core on the ROCK/NUC system, and continue to use your MacBook Pro as a Roon Control device…

I had a similar issue with my Oppo. It seems that multichannel doesn’t work via Ethernet, at least for certain network players. I also didn’t want to move my Roon Core, so repurposed an old Mac Mini (linked to the core via Ethernet) and connected an HDMI cable to my Oppo - problem solved. If this isn’t practical, I think you could use a Raspberry Pi or similar, given that the processing load is fairly minimal.

I don’t think so. It was certainly the case a while back that multichannel via HDMI was not supported in the Linux distros commonly used with the RPi, and I haven’t seen any recent posts to say that the situation has changed. If it has, then I hope someone will post about it!

The issue was, for the distros that support HDMI out on Pi hardware, that the mapping couldn’t be done properly so channels were placed incorrectly. On Intel hardware this was not an issue hence the preference for low powered devices loaded with a dormant ROCK install.

1 Like

OK thanks for the update - I wasn’t aware of the Linux restriction. It seems that the best multi-channel endpoint options are either a ROCK install or something like an old Mac Mini. Mine works well as an endpoint, and also handles Plex media in a multichannel setup.

1 Like

I think there are network attached roon ready devices that do multichannel but they are specialist and expensive.

E.g. the Merging+Player - yours for around €13k… I’ll stick to my ROCK/NUC solution, thank you.

First, thanks for trying to help. I’ve now tried a couple of different approaches.

  1. I tried Airplay to my Apple TV, which connects to my receiver via HDMI. Still remaps to 2-channel.

  2. I tried connecting my MacBook Pro running Roon core directly to my T758 via HDMI. Still remaps to 2-channel.

I put many hours into figuring out how to get my multi-channel discs onto my HDD. It was all pointless if there isn’t a way to play multi-channel content from my Roon core.

Anyone have any ideas here? @support?

@John_Steinberg - For Multichannel output, you would need to use HDMI unless your device specifially supports it via another method (). Please ensure that you have edited Device Setup → Advanced for the zone and have selected a 5.1 channel layout:

I would also ensure that your Mac MIDI settings are configured to output 5.1:

Hope this helps!

Your problem is your endpoint. NAD gets it’s “Roon support” via the BluOS device attached to the back which uses a Wifi link in and a USB output to your receiver. The T758 has no idea about Roon. BluOS is a impaired implementation of RAAT and only supports limited sample rates and and 2CH. The RAAT protocol informs the Core that the endpoint is unable to handle MCH and so the Core down samples your MCH tracks to stereo. My guess is it won’t pass DSD or DXD 2CH either and the T758 probably can’t handle it if it could.

If you want to listen to your MCH collection with the NAD, I think there are two possible options. One is to buy or build a Roon endpoint that is capable of passing MCH. However, I would borrow an endpoint from a friend or dealer to test the T758 to make sure it can handle MCH PCM over USB before investing any more time or money. If that doesn’t work, you can get a MCH DAC to interface between the endpoint and the T758. Run analog out from the DAC to the 7.1 analog inputs on the NAD.

The problem is not with Roon. Here is what the output from my Core looks like feeding a 5.1 DSDx2 track to a Trinnov Altitude 16 which has it’s own RAAT software. The Trinnov accepts a max of 24/96, so you can see my Core has to down sample the track (RAAT informs it of the endpoint limits) but it maintains the 5.1 channels.

1 Like

First, thanks for helping me out here. I tried to manage the channel layout as shown in the “Multichannel” link you sent, but I don’t see any menu option for selecting any flavor of multichannel. I just see this:

Am I looking in the right place?

Also, I don’t see anyplace in my Mac’s MIDI settings to enable 5.1 output.

Finally, I tried connecting my Roon core (MBP) directly via HDMI directly to an HDMI input on the NAD receiver. Same result – remapping to 2-channel.

Interesting - Roon seems to think that only 2 channels are available. I suspect the solution to the puzzle is to connect your Roon Core directly via HDMI to your NAD, and then tell your Mac to set up multichannel over the HDMI connector (using the MIDI setup? - I’m not a Mac user, so don’t know the mysteries of Apple). Then you should see the full setup in Roon:

1 Like

OK, after a long struggle and lots of experimentation, I have finally found a way to play 5.1 content through my NAD HT receiver. As suggested earlier in this thread, it required moving my core (MBP) into the room so that I could connect it to the receiver via HDMI.

Here’s a remaining annoyance I hope someone can advise me about: I can’t figure out a way to listen to music without my big TV mirroring the MBP screen, and I can’t even get a screen saver or black screen to show while running Roon – I think the MBP treats Roon as active, and never goes into saver mode. If I try to change the video source my receiver looks at when it reads audio from the MBP HDMI source, it shuts down audio, too. And when I drive Roon from another remote device, the display on the core (and my TV never changes.

This is not gonna fly with the Significant Other. Anyone have any ideas for how to do something to make the TV display less useless and annoying?

Thanks in advance!

Update: When I put the NAD into exclusive mode in Roon, the core MBP screensaver came on!

1 Like