When two titles within the same album have similar names, and if there is a comma somewhere in the title, Roon interprets this comma as a separator for a Composition/Part and considers these two titles as belonging to the same Composition (the Composition title being the word(s) before the comma).

See the example on the screenshot below, for “The Soft Parade” by the Doors (the two original titles, i.e. written in the TITLE tag, are : “Whiskey, Mystics and Men [Version 1]” and “Whiskey, Mystics and Men [Version 2]”

I changed the Metadata Preference at both the album level (Composition/Part Grouping, Track’s Title) and the track level, but nothing changes.

Note that this is just one example, I have other albums for which the same problem appears.

Unless I’m missing something, I suppose this is a bug that should be corrected.


@Thierry_Meulemans Hi Therry, it seems like there may be two problems here:

  1. We are falsely “munging” the two tracks into a multi-part composition (this is happening in the Cloud).
  2. You are unable to correct.

I’ll see what we can do for (1), but for (2), please would you post me a screenshot of your tags and album metadata preference settings?

Hi Joel

Thanks for your reply.

Here are some screenshots showing the Metadata Preference for the Album level (Album Editor), as well as the File Tags for the 12th track of the album. The Metadata Preference windows doesn’t show any selection, I don’t know if it is normal. Actually, I selected the “Prefer file” option for Album title, Composition/Part Grouping, and Track’s Title. In the Metadata Preference for the Title level (Track Editor), “Prefer file” is selected for the track title as well.
But if I select “Prefer Roon” for all these items, the result is the same.
Note that there is no metadata in the Work, Composition, Part, and Work tags.

It also seems that, for the two “Whiskey etc.” tracks, Roon does not use the metadata from the Title tag. For example, for the second track, the title is “Whiskey, Mystics and Men [Version 2]”, but what Roon shows is “Mystics and Men [Version #2][#]”. I don’t know why, for these two tracks specifically, Roon doesn’t use the metadata from the file, while Roon uses these metadata for the other tracks… (if I change something in the Title tag for another track and click on Re-Scan Album in the Album Editor window, the changes I made appear in the Roon Tracks window). (note that, finally, the presence of a comma within the title has probably nothing to do with the problem, because when I delete the comma, nothing changes)

Thanks again,

Looks like a full stop can cause the same problem. @joel

Screenshots below are from CD3 and CD 4 of Sgt. Pepper Super Deluxe set.

@Thierry_Meulemans I don’t see any COMPOSITION or PART file tags. Switching to “Prefer File” for Composition/Part Grouping won’t do anything if those tags aren’t there.

@DuckSoup Ugh, thanks Mike. FWIW, I don’t think that this is a new problem; it’s just being exposed on these special editions with multiple versions of a track next to each other.

Hi Joel
It is normal that you don’t see any COMPOSITION or PART tag. I haven’t put anything in these tags for this album. I just mentioned the Composition/Part Grouping option (in the Metadata Preference) because, trying to solve my problem, I thought that maybe this option should be selected somehow. And I hade noticed that, whatever the selection for this option, it didn’t change anything.

So there are two things that I don’t understand:

  1. why does Roon indicate only the first word (“Whiskey”) of the title as COMPOSITION? I could understand if the composition title was “Whiskey, Mystics and Men”, with “Version 1” for PART 1 and “Version 2” for PART 2. But why only “Whiskey”? Because of the comma following the word “Whiskey”? It makes no sense.
    That being said, for me there should be no composition/parts there. Only two “normal” titles.

  2. The “Prefer File” option is selected for the title (in the Metadata Preference), so why doesn’t Roon read the metadata from the files for these two tracks? (Roon read the correct title metadata for all the other tracks of this album)


Hi Joel,

If I take the full stops out of the titles (using tag editor) and re-import then it doesn’t treat them as a composition - so it must be the full stop that’s causing this.



I tried the same thing as Mike: I deleted the album (“The Soft Parade”) from Roon, removed the comma from the titles (using Mp3tag), then reimported the album into Roon. But Roon still treat these two titles as a composition, and gives them its own titles (instead of using the title tag from the files, which are now, after removing the comma, “Whiskey Mystics and Men [Version 1 - Bonus]” and “Whiskey Mystics and Men [Version 2 - Bonus]”).
As you can see, these are not the titles used by Roon:


I believe that there is a difference between your two cases:

  1. It’s a “false positive” in our algorithm which is trying to group (mainly) multi-part classical works. It is due to the fact that two adjacent tracks, with identical composers, have an identical stem before the comma. In the world of popular music, this is actually quite rare, but this is something that I’ll need to take a look at, because it clearly is doing the wrong thing with those Doors tracks.

  2. It is important to note that, in your case, this grouping is happening in our metadata service in the Cloud and this cannot be overridden just by selecting “Prefer File” for Composition/Part Grouping. You also need to add distinguishing COMPOSITION and PART tags to your files for those two tracks to tell the Roon core to override the existing (and invisible to you) performance IDs.

Mike, in your case, I’m pretty sure that our metadata for your problem discs doesn’t have track-level composer information. This means that we don’t create the false grouping for the Sgt. Pepper tracks in the Cloud.

We run the same algorithm locally on your Roon core, so if you’ve added track-level composers (either in Roon or in your file tags) then the same (false) grouping will occur, based on a common track title stem prior to the full stop. However, in your case, there are no Cloud-originating performance IDs on the tracks, so by making the edits that you have in your track titles, you have been able to solve the problem.

I hope all of the above is clear; it’s not simple at all!

Thank you very much Joel for these explanations.
I did as you said: I added “Whiskey, Mystics and Men” in the Work tag, and “Version 1 vs 2 [Bonus]” in the Part tag, then selected “Prefer File” for the Composition/Part Grouping (in the Metadata Preference at the album level), and now the result is better.

I would prefer to have two different titles, but this is better than what I had before.
Thanks to your explanations, I understand that the problem is not simple, indeed. But it is ok: I know you’re working on it, and the most important thing is that it does not prevent us to do what is really important: listen to the music!
Thank you,

If you set the COMPOSITION tags to different values, e.g. the original track names, and set both parts to e.g. “1”, then you should achieve what you want.

Yes, it works! Now the titles are displayed as I wanted.
Thanks again!

1 Like

But now I have another question: would you say that we should always complete the COMPOSITION tag with the track title (and to add anything in the PART tag) if we want to be sure to always control the way Roon displays the track title? (I’m not talking here about classical music, for which there are specific reasons to use the COMPOSITION/PART tags)

And a further, related question:

Wiil the WORK tag accomplish the same thing as the COMPOSITION tag in this specific case?

I ask because I changed my COMPOSITION tags to WORK tags for popular songs that I did want to merge into a single work for shuffle/radio playback and it worked better for me.

@Jeff_Bellune Roon considers WORK and COMPOSITION tags as equivalent.

1 Like

Hi everyone,

This fix is now completed and has been rolled out to the Roon Metadata Service. If your metadata are coming solely from the metadata service (which is probably the case for “The Soft Parade”), then the fixed metadata will make their into your library within a week.

However, for compositions being “munged” locally on your system (which looks to be the case for the Sgt. Pepper), the fix will be included in the next Roon release.

Thanks for your patience.

1 Like

Hi Joel,

I’ve deleted the content of the COMPOSITION and PART tags, and I confirm that everything is ok now!

Thank you for the fix!


Thanks for confirming!

How does one find these composition and part tags to edit them? I don’t see them in Edit Track.

You can’t do that within Roon. You have to edit the file tags with an external tag editor (I use MP3TAG). In case you don’t have the COMPOSITION (WORK) and PART tags, you simply have to create them with your tag editor.