Unwanted sample rate conversion in iOS

Roon Core Machine

Lenovo Thinkcentre micro PC, 8GB RAM, i5 CPU
Debian 11, Roon 1.8 build 831

Networking Gear & Setup Details

UniFi Wi-Fi AP, HP Procurve switch

Connected Audio Devices

iPhone 11 Pro, iPad Pro (1st Gen)
Connected to headphones using Apple A1749 lightning DAC.

Number of Tracks in Library

2000 files, mainly using Tidal

Description of Issue

I’m experiencing an issue similar to the one described in this closed thread.

All 44.1kHz audio on my iPhone is being converted to 48kHz. Roon claims this is due to DSP settings, but I don’t have anything enabled in there and can’t see why the conversion is happening. I’m getting the same behaviour both for tidal streams an local FLAC files.

48kHz audio plays without conversation as expected.

I don’t get this issue when using the same lightning adapter on my iPad which runs the same version of Roon and is connected to the same core.

Both iPad and iPhone are on Roon 1.8 build 831
iPhone is on iOS 15.0.1
iPad is on iOS 15.0

I’ve tried restarting the phone and reinstalling the Roon app to no avail.

Any ideas? That terrifying green light is haunting my nightmares.

Hi @glob,

Unfortunately we’re at the mercy of Apple on this one.

When enabling the “local” zone in Roon on the iPhone it uses the standard iOS API to “probe” the supported formats.

When using the Apple Lightning to 3.5mm adapter on the iPhone the API returns support for only 16-bit / 48kHz and 24-bit / 48kHz.

I can’t explain the difference with the iPad and the iPhone. I can confirm that I’m seeing the same behavior on my iPhone.

That said, Roon’s sample rate conversion is very high quality, so while the green light is less-than-ideal I’d think that the sonic consequences are minimal.



Thanks for the response John. It’s a shame Apple don’t allow you a little more control over the hardware.
FWIW updated both the iPhone and iPad to iOS 15.0.2 so things were more consistent and still get the same results.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.