Update error - receive error during checking for update


I have Roon installed and due to update error, I can’t access it remotely, also metadata seems to not download properly due to the software being outdated.

Please advise.

Thank you.


In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Hi @Saeid_Babakhani,

Since experiencing this issue have you tried rebooting your Core?

If that doesn’t change anything, please provide the info suggested by Carl above and we’ll help get things working!


Core is installed on Intel i7 4930K, accessing library on Qnap 8 bay, library size is 2.3 Tb

it is connected via ethernet to the network. the pc has working internet and no problem.

Sound system is connected via usb to a lenovo i7 laptop (used as remote), connected to main core via wifi.

Both cores have same error “there was an error checking for an update”

Thank you.

Hi @Saeid_Babakhani,

Just to confirm, have you tried rebooting your Core? Any change after doing so?

If not, please use the directions found here and send us over a set of logs using a shared Dropbox link.