Update isn't working properly

Not working.
Win 10 64 bit. Core machine.
Things I tried: Initially, used the “restart to update” from the app.
When Roon restarts, it hangs and “not responding”.
Tried uninstalling, then reinstalling. Same thing.
Tried uninstalling, restarting computer then reinstalling. Still the same.

Is there a way of installing build 536 in the meanwhile (I’m new to Roon)?

Hi @xup,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Can you share a screenshot of what you’re seeing?

Hi @dylan,

Of course!
Sorry for the delay, was doing a workshop at work :slight_smile:
Also sorry for not knowing the format for reporting issue, supplied some info and have looked at the KB, but it’s quite extensive so didn’t read it all.

The issue:
Roon is not responding after installing build 537. Build 536 did work (although I do suspect it messed up something with my audio drivers, that I resolved by uninstalling and reinstalling my DAC - Chord Hugo 2).
This issue persists - I initially tried upgrading Roon from the app, but once that failed, I uninstalled and reinstalled Roon. That did not work, so I uninstalled, restarted my machine, then reinstalled.
I have yet to be able to use Roon since I tried upgrading to 537.

My setup:
OS: Win 10 Pro build 1909
Hardware: AMD Ryzen 7 3800X; 32GB RAM; motherboard: Asus Strix X570-E; video card: GTX 1080 Ti.
Network: wall (1Gb fiber) >(RJ45)> AirTies 4920 (modem/router) >(RJ45)> PC >(USB)> Chord Hugo 2 > Headphones
Music library: stored locally, on a HDD. About 10,000 tracks. No streaming.

Did not update other devices, as the Core update failed. Also, can’t check anything as those cannot connect to Core for obvious reasons.

I understand that it’s late on a Friday at this point, so a way to roll back to a previous version so that I can use Roon over the weekend would be great and we can then resolve this next week.

I managed to resolve the issue.
When I uninstalled it I was keeping the database. Reason being I just got Roon a few days ago, and didn’t have a backup (I was still updating my music).
I was going to make the backup when this happened.
So, I copied the files that are being kept after the uninstall, then uninstalled and removed the database.
Then I reinstalled and this time it did start.
So I started copying the files and checking what got corrupt.
I got tired after a bit, but did ended up just copying the core folder back in, and it did work by allowing me to avoid scanning my music files (and avoid having to re-do my manual edits).
I’m pretty sure the files that got corrupt were in the Roon\Database\Orbit folder.

Hi @dylan. I would love your input.
It seems that Roon doesn’t work properly on my machine with this update.
I keep getting the same issue.
After a while, could be a couple of day, could be one restart, the app doesn’t respond anymore and I need to uninstall and reinstall.
This happens pretty consistently and pretty quickly now (even when I try and restart the app to change to dark mode).

Any input would be much appreciated (or, again, a way to revert to the previous version, that ran fine on my machine from what I can tell).


Hello @xup, thanks for the additional information.

Use the directions found here and send us over a set of logs using this link.

Hi @nuwriy, thanks for the update.
Since my last update I’ve reinstalled then re-scanned my entire library, as I just couldn’t use Roon otherwise. Things have been stable since (1 day, but still, I’ve been able to start and quit Roon multiple times since then to test).
I have copied the entire Roon folder beforehand, so I am able to send you my logs (and I have now).
If there are other files from there that can help (like the Orbit or Core` folders or files from those), I’m happy to send those as well.

Let me know if there’s anything else I can help (I have created a couple proper backups now, so that I am able to properly restore my database).

I’m having one more issue with this version (had it with previous versions as well, but only joined 2 versions ago).
Sometimes, when I play music through my Hugo 2 (not system out, but actually the device, connected by USB to my Core), at some point during playback, it will start having trouble playing, slightly stopping/skipping (like a scratched CD), until it will stop all playback. Switching the Hugo 2 off/on will fix it temporarily.
The only solution is switching to ‘System Output’ mode, which will play through the same Hugo 2 without any issues. That doesn’t allow for native DSD and I do have some DSD content I’d rather play natively. I have mentioned this thing above somewhere, but I thought it was resolved and it wasn’t.

Hello @xup, since you can play to system output, the way you’re sending these tracks could be significant. Can you send me a screenshot of your signal path when this issue occurs?

Sure. I’ll try and reproduce. I’ll upload a screenshot as soon as I get it to happen again.

1 Like

I managed to reproduce the issue.
I won’t be surprised if it’s an issue with Chord drivers either.
Let me know if you want more information.
Do note that Roon “thinks” that the track is still playing (note the histogram by the track name, it also “plays” with no audio after).

Another update. It seems that now that I have reproduced the issue, I closed Roon and restarted it in order to resolve the issue, and my other issue (Roon not responding and can’t be opened) has returned :frowning:
I might have to uninstall and reinstall. At least this time I have a proper backup ready.

Hey @xup, sorry to hear this is still giving you issues. I got your information over to our team for further review. In the meantime, you had suspected some driver issues. Could you reinstall drivers for your DAC and let me know if the issue persists?

1 Like

I would also recommend trying WASAPI instead of ASIO and seeing if that helps. Let me know!

1 Like

I’ve removed and reinstalled the driver every time. If I don’t I cannot get Roon to work.
Every time this happens, I need to:

  1. Uninstall Roon and DB
  2. Uninstall Hugo 2 drivers
  3. Install Hugo 2 driver
  4. Install Roon
  5. Restore backup (or not)

So, I’ve done this at least 20 times (probably more) in the past week.

Will give WASAPI a shot shortly.

I’m trying WASAPI now. It doesn’t happen consistently - it can happen after 5 minutes or 24 hours for it to break (but never happened with “system output”).
Will report if it breaks as well. I’ve got that process fleshed out now :smiley:

Thanks for the help!
If you want me to add other loggers or something, let me know.

So far it’s been working well, and no “app crashes”. That said, I’d rather use ASIO for the native DSD. Any advice?

Hello @xup, I’m glad WASAPI is working for you! In regards to using ASIO for the native DSD, have you reached out to Chord about this? They should definitely be able to help here. Let me know what they say and if we can provide any assistance in the future!