Update Roon Bridge version in Linux manually

I receive an errors when I try to run the commands from the script

Roon Bridge armv8

$ curl -O http://download.roonlabs.com/builds/roonbridge-installer-linuxarmv8.sh

curl: (6) Could not resolve host: download.roonlabs.com

$ chmod +x roonbridge-installer-linuxarmv8.sh
$ sudo ./roonbridge-installer-linuxarmv8.sh

Do you want to install RoonBridge on this machine? [Y/n] y

Downloading RoonBridge_linuxarmv8.tar.bz2 to tmp/tmp.hBXOuWHZgD/RoonBridge_linuxarmv8.tar.bz2

curl: (6) Could not resolve host: roon-updates-stable.s3.amazonaws.com

I’m assuming you are running these commands from the endpoint you have connected to Ethernet2 on your NUC as described in this post.

If so and nothing has changed since your last post then my guess why the commands are failing is the one pointed out in that post, ROCK does not route traffic between Ethernet connections so your endpoint on Ethernet2 does not have Internet access which means no DNS access so host names cannot be resolved.


If it was as you say, I could not enter a single command at all since I would not have access to the endpoint from my local network via ssh. Of course, I set up my local network for the range and connected the endpoint directly to the router. The remaining components of my local network also got ip addresses from the same range using dhcp. Thus, I was able to access ssh from my desktop to the endpoint without having to change the static network settings of my endpoint.

OK. Problem solved. Endpoint (NanoPi) did not have access to the Internet with static attributes for some reason. The temporary installation of DHCP in the endpoint network settings made it possible to update the version of Roon Bridge to build 167. Thank you all.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.