Update to 1.5 323 missing artist on Various Compilation


@support Just updated to roon 1.5 323 on all devices

Core Linux 64 bit fedora
IOS app
Windows 10

I was playing a Metalheadz complication streaming from Tidal whilst I updated. Prior to updating each track correctly contained the Artists. After the update I just get Various Artist. This is for any control app, IOS or x2 windows 10 - same behavior. I’ve read all of the old posts about this, but as it was working prior to 1.5 323 and not directly after it would appear the update changed the behaviour.

Looking from Tidal I can see all track artists, so the metadata is there.

Any ideas? I was actually going through these old compilations looking for new crate digging based on the artists, can’t do that now :slight_smile:

Post update

Tidal - *eek runs and plugs in phone!



Hi, @Rob_O_Donnell, thanks for the report! I tried to replicate the situation you are describing here, and the result is not the same, I have artist’s name under each track, see here:

Is there any chance that you recall performing any changes to your Library/Import Settings?



Hi @ivan
No changes to the library that I can remember. Definitely no change in between the update and app restart.

What settings would you recommend I look at to resolve? Happy to look and try.

Thanks Rob

Thanks for your answer, @Rob_O_Donnell, that’s definitely a strange case.

When you press on three-dot-button which is placed on the same line as a track name, choose edit option and then press edit credits, do you see Primary Artist in this tab?

Also, have you tried removing this album from your Library and then adding it again? Note that if you delete this album in Roon, it will also be removed from your TIDAL account’s favorites and you will have to add it again. You can add it back to your TIDAL Library via TIDAL web-interface or via Roon.




no Artist in edit credits

Deleted and readded - sucess!! Checked through other local and tidal compilations and they all look fine, so was just this album which was playing on update. I should have checked the other albums and narrowed down the issue sorry.

Thanks for your help here @ivan , issues resolved :slight_smile:

Just FYI @Rob_O_Donnell, that looks like the album level credits screen that you just posted. You need to edit tracks to edit track-level credits.

Good to hear that, @Rob_O_Donnell!