Update to 1.7 => Mac client can't connect to core running on Rock

Core Machine (Operating system/System info/Roon build number)
ROCK 1.7 (build 183) on Intel NUC.
Mac Roon 1.7 Remote

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Macbook client on wifi. Rest is wired 1 Gb interfaces. Music lib on a NAS share.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
TAD D-1000 USB DAC (connected to Core)
exaSound e38 USB DAC multichannel (connected to exaSound Playpoint)

Description Of Issue
Hi @support,

I have this issue since upgrade of both Core and client software to 1.7:
After upgrading ROCK to 1.7 I’m not able to connect anymore.

If I start by selecting “a different core” the client sees the server (via find my roon core) and I can select it.

The login step takes a while (over a minute?) and then displays the option to unauthorize rock or buy more authorisations to install Core on the Mac instead. It does not connect to Rock as it would normally do.

I tried turning off the NAS to see if I could get a different result but it doesn’t help.

No idea if it would help but since it’s kind of like a standard in IT to ask: have you also restarted the NUC where ROCK runs on?

Absolutely. (Just the NUC though - not the client…)

Ah, OK. I suppose rebooting the client won’t help much (you never know). Roonlabs support will surely step in soon to bring some real help. :wink:

I would be impatient until someone with real knowledge comes round and would probably try this: making sure that there’s not another Core running somewhere somehow - like in your case the Mac grabbed the license so the NUC cannot claim it? Maybe, just maybe, if you’d stop both the Mac and the NUC, then first switch on the NUC and let it run a little (so it can log-in or whatever Roon does for license grabbing) and later switch the Mac back on?

Hi @Daniel_Enochsson,

Are you able to reach the ROCK Web UI? If so, can you share a screenshot?

Yes, it is available - in fact I already checked it. It didn’t tell me anything, but perhaps it can be of more use to you. It seems to consider itself up and running.

Hello @Daniel_Enochsson,

Thank you for sharing that screenshot. I does not tell us much, but I do have some further suggestions here:

  1. Can you please try reinstalling the Roon client on your Mac? You can do so by using the following instructions (on your Mac Client):
  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  1. If the issue still remains the same, can I please request that you note the exact local time + date you try to log in again and send me a manual copy of both your Nucleus logs and your Roon client logs by using these instructions? The best way to get them over to me would be via a shared Dropbox / Google Drive link.

Thank you.


I’ve done the parts that are possible to do (as far as I can tell):
To be clear, all actions were performed on my MacBook client.
Couldn’t make a manual backup since I can’t connect to the core.
There exists an automatic backup from before the upgrade to 1.7
There was no Nucleus log (at least not at ~username/Library/Roon/Logs)
I didn’t remove and reinstall the application - just move Roon directory and recreate it by launching Roon.

Logfile directory is here (just Roon.log file there):

Timestamp of my actions (In local time = UTC+1) after I renamed the Roon folder and restarted the application (+/- a few seconds):
First screen presented user acceptance and an “I agree” button.
10.45.45 Pressed “I agree”
10.46.02 Selected Connect to Rock
Shows directly Authorizations (see below)
10.47.25 Click back arrow and reach -> login with email. (Wasn’t there first time)
10.48.00 Type my account details and click Login. Display the “Logging in” icon and dim main area.
10.49.20 Timeout and show Authorizations dialogue.

Authorizations dialogue:

Just realised I ought to inform that my Roon Core on Rock is installed by myself on an Intel NUC from the minimum tech specification list, so it’s not your Nucleus product.

Have you tried clicking “unauthorize” next to ROCK?

No, I haven’t tried that. I consider it a last option since it’s gonna be even more days outage while first the new Mac core scans the library after importing the backup and then I need to transfer the license back to ROCK who will also scan the library again… It takes days before a full library scan is completed. (My music library is ~ 7 TB in size.)

Hi @Daniel_Enochsson,

When you have a chance I would try pressing the Unauthorize button and re-authorizing your ROCK Core (if this is where you intend to keep the Roon Core). Do let me know if you have any further issues.

Actually I decided yesterday to take this step rather wait for a conclusion and how to recover without a rescan. By unauthorizing ROCK it selected ROCK core automatically without a rescan. Also I didn’t have to authorize it again. Seems illogical but never mind. It works again and in the end that’s all that counts.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.