Update to Roon 1.8 Build 880 corrupts my Roon Core database

Another borked update here. Restoring from the most recent version failed so now it’s the binary slice through old backups route. Not how I planned to spend the weekend…

I’m sorry for your loss of your Roon Core database.

You should track the issue I raise in this ticket - Update to Roon 1.8 Build 880 corrupts my Roon Core database [See Staff Note - Roon Gathering Logs]

I have read the above with interest because when i updated, i got the pulsing Roon logo upon restart. I restarted the PC a couple of times… Waited 12 hrs… just a pulsing Roon logo.

Would any one be able to say if this is a clear signal of a corrupted database?
.
As a result:

  • I deinstalled Roon from the PC. When given the option to remove everything or keep databases and settings, choose to keep them.
  • I reinstalled Roon and it restarted fine and is back to v831.
  • I don’t have functionality on my ipad as a remote as it is at v880 and is not communicating with my core (v831)
  • The core is on a Win10 PC. It has a i5 CPU (g7), 16g RAM, and updated Windows10.

Do you recommend I role the dice and update and risk a RooNPocolypse or Roonagettton? Anyone with similar experience? Can you comment?

Grateful for some support for preventative management to the 880 update. I am not sure the update is worth it if it renders my managed database, which is carefully backed up (but only for the last month), useless.

If this does signal a corrupted database, I’d appreciate if ROON could provide a list of what would be lost in the new database? I have read about hearts lost, tags lost…

If you would provide a full list of what would be lost, i could take pictures of my saved radio stations, my genre management work, tagged playlists, hearted songs…etc. so as to make the adjustment less painful…

Apologies for cross-posting, but i am thinking this is the more appropriate thread for these support questions.

Same here, roon rock on nuc.

I updated to 880 yesterday morning. Things worked great for about five hours then I got the corrupted db error. My backups are only ten days back and it backs up every day at 1am. I restored for the oldest backup I had and figured it would fail after a while as well.

I woke up to find the database still running and one successful backup last night at 1am. I am wary to say that I have had a successful restore from backup.

Do you think a successful 880 backup would indicate I dodged the bullet?

Hello all,

Since the update, we’ve been keeping a close eye on the community threads to discover what are your thoughts on it and how you’ve experienced it. By far, the most painful issue we’ve seen is this one: database corruption.

We’re so sorry to see how impactful it is. We’ve read every single post and we’re listening. We would like to take a closer look at it.

If you have been affected by this issue and would be interested in helping, could you please fill out the following form?

This will allow us to better understand the problem.

Thank you.

6 Likes

Hi @noris
Does this include those of us who didn’t get the explicit error but who are nonetheless unable to connect to a restored backup?

Just sent an email …

@Alan_McMillan - Yes, if you see 0 artists / 0 tracks, please fill out the form as well, I have updated the form description to reflect this.

1 Like

Thanks @noris

Jumping in to add my :heavy_plus_sign:1 on fatal errors on MacBookPro Big Sur 11.6.1. Upgrade gets stuck in the same loop over and over:

  • Upgrade RoonServer to 880
  • Receive message in client that DB needs to be upgraded
  • Roon upgrades DB, client loads with new DB missing almost all cover art on home screen and in Album view
  • I click into a few albums, no cover art, click on the art image and the image appears, then it shows up on the home screen, rinse and repeat for every image
  • Click into an album, try to play a mid-album track, Roon attempts to play a track and ends up jumping down a few tracks in the album (acting like the first half of the album can’t be played)
  • Roon fails and throws up the “Corrupt DB, restore from backup”
  • Restore from any backup (I’ve tried multiple)
  • Start back at the top of the process and end up right back in the same place

This one is a big breaking change. As someone who’s day job is in product, this is bad; this is really, really bad. I 100% agree that suggesting we go from years of curating a DB to “just start over, and sorry, our bad” is unacceptable. There should be some mediated fix – Roon distributes a “DB Migration” tool that addresses this. There should be a hotfix for an “all stop” on migrating to 880 until this is fixed.

For me, I reverted back to running Server on my Synology (still available as part of my long-running challenges of migrating from the Synology to running Server on the MBP) and 880 seems to be stable post-DB upgrade on the Synology. So far, anyway…

2 Likes

#47

“I have updated the database, no success, I have reinstalled EVERYTHING, a complete reinstall on all devices, nothing helps !!!”

Boo! Same as others, after updating, I received the “There was an issue loading your database” message.

I’ve tried restoring old databases and still receive the error.

I reinstalled an older version of Roon, from a Macrium backup, and then I immediately did a database “cleanup.” Roon ran just fine. I restarted, Roon updated, and got the same error. Reinstalled the latest version of Roon as per the “Help Center” instructions and I still get the same error.

Again…BOO!

Am I wrong that there’s no way to:

  1. Install previous versions of the Server and clients (remotes)?
  2. Force all of the Roon tools to stick to that version?

IOW is there any way to say “DO NOT upgrade to 880 and stick with the current version?” I’m thinking something along the lines of apt-mark hold in the Linux/Debian world.

A post was split to a new topic: Audio devices erratic behavior after build 880s

I have tried everything to get Roon to play again after the update, spent hours on this, hacking away as an amature; changed folder to “old,” reloaded Roon, received “there was a problem loading the database” error message, etc., etc. However I cannot even log into my account. Well, I am logging in as I receive the email, “Did you just log into your account?” But my screen just rolls back to the same blank sign in page. When I try finding my Core on my Windows 10 PC the Roon app also just keeps looping to "Start your subscription… Does anyone know if these all the same problem with the latest 880 update?

I spoke too soon: 880 is unstable on my Synology 218+ as well. Details here: 880 Constant Server Reboot on Synology 218+

As a fairly new Roon customer, this is shocking. I’d like to see some post, preferably from the CEO, how Roon is taking this deadly seriously, how sorry they are, and how all stops are pulled to halt the migration and get us all back on a working version. Am enjoying my music-less vacation time (not).
-Alan

9 Likes

As a lifetime member for 2 years that has had a unstable music platform for that time, good luck with finding any empathy here.

It’s only when a problem happens to them, that they care, expect ridicule because it works for them.

Case in point, for 2 years I’ve had issues with Tidal through roon, I was ridiculed by the passionate fan base. Even though I’m hardwired and don’t use wifi.
Now in the newest update, roon has addressed this scenario as its one of their top bullet points- to make roon less demanding so that tidal and qubuz can work without issues.

But I’m the difficult one who in exchange for money have gotten my self a part time job trying to troubleshoot roon issues…ok

1 Like

I really think it’s time for Roon management to step up and release a statement on the mess they created in the last day, a roadmap for what they’ll do to fix this and how they are going to make sure this won’t happen again. And at least give the option to go back to a previous working version so we can listen to our music instead of tinkering with some beta software…

6 Likes