Update to Roon 1.8 Build 880 corrupts my Roon Core database

Thanks @noris

Jumping in to add my :heavy_plus_sign:1 on fatal errors on MacBookPro Big Sur 11.6.1. Upgrade gets stuck in the same loop over and over:

  • Upgrade RoonServer to 880
  • Receive message in client that DB needs to be upgraded
  • Roon upgrades DB, client loads with new DB missing almost all cover art on home screen and in Album view
  • I click into a few albums, no cover art, click on the art image and the image appears, then it shows up on the home screen, rinse and repeat for every image
  • Click into an album, try to play a mid-album track, Roon attempts to play a track and ends up jumping down a few tracks in the album (acting like the first half of the album can’t be played)
  • Roon fails and throws up the “Corrupt DB, restore from backup”
  • Restore from any backup (I’ve tried multiple)
  • Start back at the top of the process and end up right back in the same place

This one is a big breaking change. As someone who’s day job is in product, this is bad; this is really, really bad. I 100% agree that suggesting we go from years of curating a DB to “just start over, and sorry, our bad” is unacceptable. There should be some mediated fix – Roon distributes a “DB Migration” tool that addresses this. There should be a hotfix for an “all stop” on migrating to 880 until this is fixed.

For me, I reverted back to running Server on my Synology (still available as part of my long-running challenges of migrating from the Synology to running Server on the MBP) and 880 seems to be stable post-DB upgrade on the Synology. So far, anyway…

2 Likes

#47

“I have updated the database, no success, I have reinstalled EVERYTHING, a complete reinstall on all devices, nothing helps !!!”

Boo! Same as others, after updating, I received the “There was an issue loading your database” message.

I’ve tried restoring old databases and still receive the error.

I reinstalled an older version of Roon, from a Macrium backup, and then I immediately did a database “cleanup.” Roon ran just fine. I restarted, Roon updated, and got the same error. Reinstalled the latest version of Roon as per the “Help Center” instructions and I still get the same error.

Again…BOO!

Am I wrong that there’s no way to:

  1. Install previous versions of the Server and clients (remotes)?
  2. Force all of the Roon tools to stick to that version?

IOW is there any way to say “DO NOT upgrade to 880 and stick with the current version?” I’m thinking something along the lines of apt-mark hold in the Linux/Debian world.

A post was split to a new topic: Audio devices erratic behavior after build 880s

I have tried everything to get Roon to play again after the update, spent hours on this, hacking away as an amature; changed folder to “old,” reloaded Roon, received “there was a problem loading the database” error message, etc., etc. However I cannot even log into my account. Well, I am logging in as I receive the email, “Did you just log into your account?” But my screen just rolls back to the same blank sign in page. When I try finding my Core on my Windows 10 PC the Roon app also just keeps looping to "Start your subscription… Does anyone know if these all the same problem with the latest 880 update?

I spoke too soon: 880 is unstable on my Synology 218+ as well. Details here: 880 Constant Server Reboot on Synology 218+

As a fairly new Roon customer, this is shocking. I’d like to see some post, preferably from the CEO, how Roon is taking this deadly seriously, how sorry they are, and how all stops are pulled to halt the migration and get us all back on a working version. Am enjoying my music-less vacation time (not).
-Alan

9 Likes

As a lifetime member for 2 years that has had a unstable music platform for that time, good luck with finding any empathy here.

It’s only when a problem happens to them, that they care, expect ridicule because it works for them.

Case in point, for 2 years I’ve had issues with Tidal through roon, I was ridiculed by the passionate fan base. Even though I’m hardwired and don’t use wifi.
Now in the newest update, roon has addressed this scenario as its one of their top bullet points- to make roon less demanding so that tidal and qubuz can work without issues.

But I’m the difficult one who in exchange for money have gotten my self a part time job trying to troubleshoot roon issues…ok

1 Like

I really think it’s time for Roon management to step up and release a statement on the mess they created in the last day, a roadmap for what they’ll do to fix this and how they are going to make sure this won’t happen again. And at least give the option to go back to a previous working version so we can listen to our music instead of tinkering with some beta software…

6 Likes

Corporate arrogance is the downfall here. Lack of risk analysis, poor planning and internal roadmaps with unwanted features are taking priority over delighting the paying customer with a robust product. Big FAIL again RoonLabs.

9 Likes

One would expect a tool to check integrity of the database before the update actually starts. Even Microsoft does a better job at checking the condition of the system before an update. Go figure…

1 Like

And not to pile it on, but who releases major software updates the week before a worldwide holiday? I would love to know why this couldn’t hold until Jan, which would have given that much more time for QE/QA.

4 Likes

And no apology and excuse is it’s our hardware. It’s a joke

1 Like

This aspect of the ‘official’ responses to the reported problems I find disingenuous. Of course, hardware problems could in some cases be to blame. But there can be software problems, too. And the software library used for data persistence (LevelDB) has a reputation for having bugs that can cause data corruption. So no cause can be simply ruled out. Having read through many threads and posts it seems to me that those affected are users of any supported platform—yes, there are affected ROCK users, too. There are users with servers set up not so long ago. Others have been running on the same hardware for several years.

I myself am lucky not having been affected, despite very frequent power cuts and operating without UPS. Until now, my 18 months old Roon server has resisted corruption.

2 Likes

Just like to add my voice to Roon fails to work after update, running on nuc I5 with RoPieee and Google endpoints. Is there fix in the works?

Well … I tried backups… no luck there… there is a problem with your database despite going back more than a year. So starting fresh I now have no audio devices. Now what??

1 Like

Build 882 has just been released.
Try downloading it and see if it helps on your setup

2 Likes

Hi all, we just release Build 882 that fixes a few issues affecting some folks in this thread. Please read the release notes for more details!

5 Likes