Update weirdness and roon panic

I’ve been meaning to mention this for a while but other things were more pressing.

Since the update, when I choose an album and click on the first track, it automatically moves str8 to 2nd track. When I re-click 1st track it plays and no more weirdness.

ROON PANIC-when I turned on this morning my MBP immediately started whirring. I checked the Activity Monitor and ROON was using 98% of the CPU yet all I had done was open it. I closed it. Reopened and watched as it climbed up to almost 100% of CPU. I restarted. Nope. I closed down. Restarted. Nope. Did it again. For no reason I can think of it, it suddenly dropped to ROON 0.5% and CPU usage was down to well over 90% idle.

Have no idea why Roon was using that amount of energy. It never does. It hardly uses any normally. I always use HQP as my zone with Roon providing DSP only.

When playing music, if I am playing DSD files, it stays about 78% idle. If I am using HQP to upsample to DSD128, it never goes above 70% idle.

Although Roon is back to normal, I’d still like to know if there is a known reason for the behaviour this morning.

Oh and whatever happened to the investigation into those files that would not play? It’s been weeks since I heard anything.

kind regards

Hi @Knitman,

Is this happening with local content or streaming content? Does this happen for all endpoints?

What is the specific model of MBP you are using?

Were there any other applications running that normally aren’t during this time?

It’s also possible that there was an update or metadata update or something along those lines that was resulting in a bit more resource usage than normal. If you see this behavior occur again please let us know and we’d be happy to take a closer look! Please provide a time that the CPU usage was high and we can enable diagnostics.


Hi-both these problems still exist. Every time I want to listen to music.

Firstly, when choosing to play, either from my library or from Qobuz, I click the first track and it jumps to the second and starts to play that. I click on the first track again and it plays normally.

The most concerning problem is this: waking MBPro, opening Roon and Roon immediately starts to use a huge amount of the CPU and cores.(Both confirmed by the Activity Monitor) the fan comes on almost str8 away. The reading was over 300% and it never does that even when playing. Usually.

Today, the music started to stutter. I immediately looked at the Activity Monitor. HQPlayer was showing 130% which is about normal except for when I play DSD 128 files and then it is very low, like 10. BUT Roon was showing about 150% which is far from normal. I would normally be showing around 10 because HQP is doing the upsampling etc and all the Roon is doing is the EQ.

If I restart the machine, in both cases, Roon drops to it’s normal levels.

Neither of these problems existed before the latest update.

I hasten to add that I am still extremely happy with the sound and performance but these glitches are weird.

Altho I have Audirvana and JRiver Music Centre, sin ce buying Roon and HQP, I have not used them.

BTW I never have this problem with HQP. It is definitely only Roon that behaves in this manner. I can understand, sort of, how it might suddenly start to use an awful lot of power whilst playing but not when it just opened with nothing playing.

kindest regards

Hi @Knitman,

Thanks for providing those details!
Can you please let us know:

  1. Which version of Macbook Pro you have? (Model/Year)

  2. What type of device are you outputting through HQPlayer? (Model/Manufacturer)

  3. Does the issue occur when you bypass HQPlayer and have Roon play direct to the endpoint?

  4. Does toggling the WiFi off/on help with the high CPU usage? (We are looking into the high CPU usage issue and a few of our customers have mentioned that WiFi reboot helps)

1.The machine is a 2.4 GHz Quad-Core Intel Core i5 with 8 GB 2133 MHz LPDDR3. a 2019 with 4 Thunderbolt ports.

  1. Don’t understand the question.

  2. Don’t know as have not used Roon on it’s own . This question leads me to believe that the answer to question 2. is MicroRendu

  3. I use ethernet, not wifi.

The only way I have got Roon to behave is to restart the MBP, maybe twice.

sorry that post was meant to be a private message to someone else. FKs how I did that.

Hi @Knitman,

Thanks, this is the info I was looking for. If you try to bypass HQPlayer and play to the MicroRendu directly, does that work as expected? You should be able to enable the MicroRendu directly under Roon Settings -> Audio. With HQPlayer out of the mix, does the issue still reproduce?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.