Updated home network: no sound

Updated my home network, everything is working but no sound.
It all worked before, no changes except a switch with patchpanel added.

This is the chain from NUC to Amp:

Intel NUC > Port on Ubisoft switch > other Port from Ubisoft Switch > patchpanel > UTP wall socket > Pi4 with Allo Digione Signature running with Ropieee > ADI 2 FS DAC SPDIF IN > Line Out to Primaluna amp > Roon Rock visible in Roon on iPad

No changes in DAC
No changes in amp
No changes in Ropieee/PI
No changes in IPad /Roon
IPad as sound output works, Pi not

Roon on IPad works, NUC is connected, music is playing, but no sound.
When I selected other input on DAC to test sound from tv via speakers, it works.

Onze thing I can’t check:
I can’t reach http://ropieee or http://ropieee.local

So somewhere in the chain I’m doing something wrong.

It all worked before but not anymore.

I though the patchpanel > Ubisoft switch was the problem, but my IPad with Roon finds my NUC with Rock and it’s detected in Roon.

Any idea?
Big thanks!

Just some reflections:
If you select iPad as endpoint, does it produce sound?

Is it possible that you had defined fixed ip-adress on your Ropiee ( or other device) and that with the change in your network this is not addressable anymore?


Hi Dirk,

iPad with sound works.

Can’t check the Ropieee settings cause I can’t reach it… Not sure if I selected that setting.

can you reach the ropiee via IP address. you appear to be using the name and it may not be resolving. If the ropieee was left unplugged for a bit a new dhcp lease may have been given, if not statically set.

Can’t you connect the Ropiee on another port just to check if you can reach it then? Do notforget tp power off/on.

i assume you rebooted the Pi?

In settings → Audio if Roon sees the Ropieee device it will tell you it’s IP address. You can then access it via that IP.

For clarification… does Roon see the Ropieee endpoint? When you say “no sound” does Roon say it is playing? Does it continue playing or does it eventually stop and error?

Seems that is the problem.

Ropieee visible in Roon but no IP there.
Other port on switch or patchpanel not working.
Just can’t reach Ropieee, did a reboot on Pi (unplugging power cables).

What about the patch panel and switch? The signal goes into the patch panel and then into the switch, where I used different ports but no luck. Roon on IPad sees the NUC which is also connected to the switch.

Unless you miswired the panel, or disabled a port on the switch I’d think it is probably the ropieee.
Does the ropieee show up in your dhcp leases?
Is it seen as an attached device on the router?
Are you able to type ip a at the command line of the ropieee and get its address?
I would figure out where it is (IP) then throw data at it. Odds are none of your devices have cleared their dns cache and your ropieee is sitting somewhere else. Many people do not assign static leases.

Hm, used the same UTP cable to connect Pi with HAT to switch directly, and instantly Ropieee is found via Safari. Updated Ropieee and all is working fine.

Thanks for the help!

1 Like