Updated to Roon 1.8, Build 783

As usual, absolutely no issues. Updated Roon Nucleus and Dell XPS 15, Windows 10 laptop. Everything working well including Nucleus, Dell, iPhone 11 Pro Max, iPad Mini 4, 2 RPi4’s running RoPieeeXL, Oppo 203, Meridian Prime, AudioQuest Dragonfly Cobalt, Tidal, and Qobuz.

I’ve been using Roon and this setup for approximately 1 1/2 years with never an issue. My network is AT&T U-Verse 50/12 mbps with ethernet to Nucleus, Oppo, and one RPi4. WIFI to the other RPi4 with screen, Dell, iPhone, and iPad.

Thanks Roon.


Jim_F, how can what you say be? According to recent posts, EVERYBODY knows that 1.8 is an ABSOLUTE DISASTER and RIDDLED with BUGS. And these people have THOUSANDS OF HOURS of experience with such things.

You must be smoking something.

:slight_smile: [irony]


Just lucky, I guess. Or, good equipment and a rock solid network.


I’m with Jim…
Maybe I’m very lucky?
Never a problem with any update on any devices but my system and needs are relatively simple I guess.


I only use core functions of Roon and have no clue about Valence, Focus, tagging etc.etc. which makes my life easy. During the 1.8 update crisis I had the issue of disappearing endpoints which was solved on a priority basis. Most of the bugs that more involved users detected were and will be outside my usage pattern. During the 783 update I had an inconsistent update status message on the core, but that was it.

1 Like

I read the forum daily and still wonder why everyone commenting seems to get into such trouble

I have been using Roon for 4.5 years, via 2 different core PCs over that time. I use a bog std generic tower PC , i7, 16 g RAM, , 250 SSD, (local computer shop brand) the only oddity is 4 x HDD was that required an up spec MB for SATA ports

Both PC much the same spec, just a replacement , during that time I have had 2 routers , moved from ADSL to fibre etc etc

I have auto update on Windows 10 and take each one “fearlessly”

Every Roon upgrade “just worked “ as @Jim_F says I must be lucky

Maybe there’s something in the KISS principle after all

1 Like

Roon update always works for me no issues at all, maybe just maybe its a South African thing :slight_smile: :slight_smile:

1 Like