Upgrade to the latest Roon update - Roonserver is not starting [Hotfix released - if you are still impacted please work with Roon support to resolve]

Similarly, having updated, I can no longer connect to my core running on a QNAP NAS, on any device.

1 Like

Same problem Roon Server on NUC Roon server software not running and not restarting

I have the same, is it possible to download an older version?

Please roll back this update, possibility of the downloading the previous version is fine for us also.

How do you rollback roonos without reinstalling the OS

Hi, all!

Sorry for the issues you are having. There is a workaround for this problem that will get you back into a working state.

The steps are:

  1. Stop RoonServer process
  2. Go to your Database Location – instruction
  3. Go to Database/Registry/Core
  4. Remove the file called bits
  5. Start RoonServer.

Apologies for the trouble. We are already working on a fix.




Same here. Roon server not starting. M1 MacMini running Ventura 13.0.1

1 Like

@ivan - can confirm, removing the “bits” file worked.



Roon is broken for me as well. I’m running the core on an iMac and using an iPad. After the upgrade Ronn will not open. Unacceptable.

1 Like

Same problem:

Roon server, which was running fine before the latest update, completely crapped out after accepting to install the update.

The web interface is still available but under Roon Server Software is says NOT RUNNING.
If I refresh the windows it sometimes say it’s been Running for 1 second, but refresh again goes back to NOT RUNNING.

Clearly (yet another) update issue from Roon.

Did try to reinstall the Operating System from the web interface (Safari) it did reinstall presumably successfully but Roon Software still not running.


Yes removing the file named “bits” worked.

Sorry this “solution” is also not acceptable. I am not a software engineer and have no interest in editing files. Do better.

Sorry, @finin.mcfadden2011. In case you have no interest in editing files, may I kindly ask you to wait for the fix from our side, please? It’s coming soon.


1 Like

Wow…lots of us having this issue. Nice QA process, Roon! How did you let this happen? What new testing process will you be using to ensure it doesn’t happen again?

1 Like

Removal of ‘bits’ on Roon server running on Qnap NAS worked for iOS but not MAC. Still doesn’t start on Mac.

1 Like

Removal of “bits” bits did not work for me on MacBook…

Same problem here. Following above instructions to remove “bits” file got me on the road again (running ROCK on a NUC). DB needed an update on the way through, but all well now.

Please fellow Roonies. These things happen from time to time. A little frustrating I know. I wasn’t aware of the workaround that @ivan has mentioned and uninstalled Roon in its entirety and reinstalled. All back up and working.

Please be patient with the Roon Team. It’s tougher for them if they’re getting unwanted flack. Please stay civil and please remain patient.

Thank you


I was using roon and listening to music just fine this morning and I got a message there was a new roon update which I applied and ever since after it started up it cannot find the core any longer and I cannot use roon…very frustrating,what can I do?

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

As title says. Just played a few songs in Roon, then restarted it. It no longer starts. Restarted the PC, Roon still won’t start
Sometimes I can see the roon window being displayed quickly, but it dissapears immediately. Say in less than a second.
Roon process in task manager is also closed.

In my two-ish years of using Roon, i’ve never encountered anything like this before.
Found the logs, this is the error it gets :

–[ INNER EXCEPTION ]------------------------------------------------
Inner Exception Source: RoonBase
Inner Exception Type: System.Exception
Inner Exception Target Site: Bit.GetString
Inner Exception Message: bit roon.broker.test.partialbits3 is not a string
Inner Exception Data: none

–[ Inner Stack Trace ]------------
Sooloos.Bit.GetString(String default_value)
RoonBase.DLL, IL 66, N 181
Roon.Broker.Core.DLL, IL 0, N 186
Sooloos.Broker.State…ctor(BrokerConfig config, StorageManager storage)
Roon.Broker.Core.DLL, IL 1634, N 3973
Sooloos.Broker.Modules.Core.Create(BrokerConfig config, String platform)
Roon.Broker.Core.DLL, IL 125, N 224
Sooloos.Application.InitializeBackend(Task create_deps_task)
Roon.exe, IL 529, N 989
mscorlib.dll, IL 15, N 78
mscorlib.dll, IL 16, N 71

–[ OUTER EXCEPTION ]------------------------------------------------
Outer Exception Source: mscorlib
Outer Exception Type: System.AggregateException
Outer Exception Target Site: Task.ThrowIfExceptional
Outer Exception Message: One or more errors occurred.
Outer Exception Data: none

–[ Outer Stack Trace ]------------
System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
mscorlib.dll, IL 17, N 4593189
System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken)
mscorlib.dll, IL 67, N 13992992
Roon.exe, IL 527, N 1288
BrooEngine.DLL, IL 23, N 107
BrooEngine.DLL, IL 148, N 549
Sooloos.Application.Main(String[] argv)
Roon.exe, IL 1921, N 4451

Same here. Latest Windows 10 and now won’t restart.

Uninstalled (application only and kept setting and database). Still doesn’t launch.

Uninstalled all and now starts.

Some won’t want to loose their database and settings. Thankfully my setup is straightforward

Help Roon!