Upgrading to an external server

My Roon Core is currently on a Windows 10 Laptop and I want to migrate it to an external server

I am an audiophile but not very IT Savvy

As an end point I am using an Auralic Altair Pre-amp and also streaming via Quobuz. The Auralic has a hard wired connection to my router but is using Wi-Fi to access the files on my laptop

I understand that my options are

I really would appreciate any views/guidance you may have as what solution you would go for

I am using this https://www.atlastsolutions.com/fanless-8th-gen-nuc-core-i5-pc-8gb-ddr4-250gb-samsung-970-evo-plus-ssd-thunderbolt-3-turing-i5/ with ROON ROCK, with network cable direct connection to my DAC, additional cable connection to router (with additional USB network adapter). I’m not using any DSP, and have no issues at all (TIDAL and local files).

You could build a NUC, doable even if you are not tech savvy.
You could use any computer with the same specs as your Win 10 laptop. You didn’t mention whether you were having issues with it, so, I am assuming it has been working well for you.

I personally keep my server far away from my listening spaces, so any concern about fans or noise don’t exist.

Hi @Ken_Talbot,

Generally speaking ROCK/Nucleus is a great option for an external Roon Server. If you wish to purchase one, that’s a good choice or if you don’t mind a bit DIY, you can also build a ROCK server yourself.

Our ROCK: Getting Started provides an overview and our ROCK Install Guide outlines the steps to install ROCK on a NUC.

If you prefer to have it pre-built for you you can certainly go with a Nucleus or the pre-built one and then you don’t have to assemble the pieces.

Hi Noris

Thank you for your suggestion about doing it myself. I am not particularly IT Savvy but the instructions you have sent have made me decide to have a go

I have now bought all the kit

Reading the instructions I am a little confused by the last bit of the instructions in section 4

I understand it until I have downloaded the compressed ROCK image to my USB flash drive on my Windows laptop

I don’t understand the next part i.e. “Linux Command Line” - on what device do I need to uncompress it?

Is this Linux language?


Hi @Ken_Talbot,

In the ROCK Install Guide, you don’t have to follow the Linux Command Line, you can skip past that since you used a Windows PC to create the image. Once the drive has been flashed with Etcher, simply continue to steps #5 and below.

Thanks Noris - that makes a lot more sense

HI Noris

Thank you for encouraging me to create my own solution - I have done so

Now have a NUC8i3BEH with 8GB Ram etc as recommended

The mechanism to organise boot order is not as suggested in the support notes

It is all working fine and we can certainly hear a difference in music quality

However, I do not understand the issue of missing Codecs in the instructions

All FLAC tracks play perfectly (wherever their source) however, non FLAC files will not play because of missing CODECS

I have copied what I thought was the right ffmeg file - but the guidance notes are vague about what the suffix for this file needs to be

Could you please send me the exact file with the correct suffix?


ffmpeg has no extension. The file is just called ffmpeg. The file which is downloaded needs to be extracted twice to get to ffmpeg.

Hi @Ken_Talbot,

Glad to hear you’re up and running.

What exactly regarding the boot order was different for your setup? Can you let me know and we can take a look if we should update the docs?

You need to extract the ffmpeg file twice, I suggest using 7-zip on a Windows PC to do so, other un-archiving apps sometimes have difficulties extracting the codecs properly. At the end of the process, you should get one ffmpeg file with no extensions:

Be sure to reboot your ROCK from the Web UI once you add the Codecs too.

Hi Noris

In terms of boot order - in the boot set up screen you are presented with three tabs. In the first of these you chose Legacy

Next Tab is where you set the boot order but you can not move the order of the options but must tick boxes that it you tick correctly it will boot up in the order you need

Sorry but I can still not make CODECs work. If I download the file you attached it automatically assigns a png suffix. I have tried the file with the suffix and without. After the reboot the CODECs are still missing



Me again

I have just tried to save the file that I originally downloaded and it is all now working - I realise that I was selecting more than just the ffmeg file

Thank you very much for your help

Hi @Ken_Talbot,

Glad to hear you were able to get the ffmpeg issue resolved and thanks for sharing those additional ROCK setup details.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.