UPnP Bridge unable to find renderers

Running latest Roon and latest Ropieee on a RP3 with a HiFiBerryDac+. Ropiee appears in Roon and plays OK. Go to RopieeeXL-UPnP Bridge and hit scan and it spins and spins and never finds a renderer. UPnP Analyzer is able to scan and find the UPnP renderers without a problem.
Ropieee’s UPnP/DLNA works OK and UPnP Analyzer is able to find it.
Tried the Test update channel. Same problem.

Can you send me feedback?

Feedback? It doesn’t work… What more do you need to know?

… don’t be rude … the feedback is rich of informations that you maybe don’t/cannot understand but it can help Harry @spockfish to find the issue and the solution to the issue … without the feedback you’ll stay with your issue … forever.
Here, on rpi4, the upnp bridge works as it should therefore it could be a issue related to you installation/environment

1 Like

Just in case you were unaware of what @spockfish was actually asking for.
If you send the feedback from the software he can look at the logs and maybe see what is the problem.

Not being rude, just had no idea of what he as asking for.

And that’s what I thought might be the case here.
I don’t use RoPieee myself but @spockfish will be wanting the feedback that can be found under the feedback tab I believe.


Thank you for your reply. I have since found out that there is a “Send Feedback” button under the Advanced tab. Good to know. I sent you some feedback with identifier dc91b02e3b452d9d


Hi Matt,

You’re still on the beta. Can you switch to stable and try again?


I tried all 3 update channels with the same results. I am back on the stable channel now and it still does not find DLNA renderers on the LAN.

Can you send me feedback (with the latest stable version)?


ps: is it still scanning ‘indefinitely’? if so, go to RoPieee’s webpage from a clean tab (after 15 seconds or so) and send me feedback from there. In that case the feedback contains the ‘scanning moment’.

ba8136cbc1129de8 has been sent

This is still not the latest stable (2022.06.1).

OK, I updated it and tested it. The results are the same. It should find 4 renderers but it just spins and spins. Feedback sent 2d3c02cf1cc55512

Ok thanks @Matt_Miller

I see what’s going wrong, but I can’t explain why.
So give me some time to figure this out.

Are you willing to do some testing later on? It would require to switch back to beta.


Yes, I would be happy to test the feature as you make progress with it. I am in no hurry. Just let me know what I can do to help.


1 Like

Preparing to move to a new place so I tested RoPiee before packing it up. DLNA scan now finds the DLNA renderers. I selected one, configured, and rebooted. RoPieee showed up in Roon and I could play to it. Wonderful! I scanned for DLNA devices, selected a different one, configured, and rebooted. Roon still played to the originally configured DLNA renderer. I tried selecting different renderers, I even set it back to “None” and it always plays to the originally selected renderer. So close to working great!

Feedback provided: 2755f67cde663737