Upsample option limited to 96khz?

I have a DAC that is claimed to be compatible up to 192khz sample rates. When I was setting up my DSP options, it only gives me an option to go up to 96k? Is this a function of Roon recognizing something about my DAC or user error?

What DAC do you have?

TAD Evolution C2000

If that’s the “Max Sample Rate (PCM)” drop down in playback settings, you never see the max rate of your DAC in there (because limiting to the max rate makes no sense). If you set limiting to Disabled, then you’ll have the full rate, as shown in the sample rates at the top of the tab.

The specs for this dac make me think it’s a driver issue. The following is from the TAD site:

OS: Windows XP and later; Mac OS 10.5 and Later (44.1kHz, 48kHz, 88.2kHz, 96 kHz),

Windows 7/Windows Vista (compatible with a specialized driver),

Mac OS 10.6 and later (44.1kHz, 48kHz, 88.2kHz, 96 kHz, 176.4 kHz, 192kHz)

So depending on operating system, you may need to install a special driver to go higher than 96k.

1 Like

I am using ROCK, so it is Linux-based. I did not see the option to set limiting to disabled. Can you tell me where that option is found?

I was referring to the Device Setup Playback tab (marked 1. above). But it sounds like you may need specific drivers for the DAC, which may or may not be available on Linux. If 176.4kHz and 192kHz are in red (Bit-Perfect Format Support section (marked 2. above)) then the current ROCK driver doesn’t support those sample rates.

1 Like

The driver filename for windows (and the fact that macOS doesn’t need one) suggests it’s just the basic ‘windows doesn’t do usb audio without drivers’ thing.

Have you already tried another PC or software player with 192kHz content? And did you already check the playback chain? Maybe there is no problem.

It does appear to be limitations associated with the ROCK driver

Hi @Shayne_Tenace ----- Thank you for the report and sharing your feedback with us. Both are appreciated.

We usually see this type of behavior when the DAC is connecting via USB 1.1 instead of 2.0, which we definitely support. 2.0 that is. I also noticed, as @lorin has pointed out, that the TAD website does not make mention of Linux, just Windows and OSX. Have you tried contacting them about Linux support with their devices? We are also going to try to get our hand on one for testing.


ROCK uses Linux’s built-in USB Audio 2.0 support. Usually when devices fail to connect at USB 2.0 and fall back to USB 1.1 like this, it’s a sign that the manufacturer did not fully test them with Linux + work out any Linux-specific kinks.

We have seen issues like this with a minority of products (maybe 2-3 out of the 100+ we have in-house).

Unfortunately, we have never laid hands on this model–but as @eric mentioned we will try to get ahold of one and see what’s up or if we can provide TAD with any guidance.

1 Like