Upsampling and MQA

Hi I wonder if anyone has a solution for this.

I have Redbook, hires and MQA files in my library. I also have a Mytek Brooklyn DAC.

I upsample everything to DSD256, but prefer not to do this with MQA.

But currently with upsampling selected. Roon is doing the first unfold in the core and then doing the upsample. I would prefer a straight passthrough.

I was hoping that the MQA support in Roon would provide an MQA option in the custom upsampling options to not upsample MQA.

Am I missing something, or should this be a feature request?

In device setup you can set the MQA capabilities to decoder and renderer this will stop Roon doing the MQA decode/unfold, device setup is in settings, audio then select the cog icon by the endpoint name.


In general, if the device’s MQA Capabilities are set to “Decoder and Renderer” or “Renderer” (i.e. capable of rendering), then Roon will not perform any sample rate conversion if it has also performed the MQA first decode.

The question is why your Brooklyn apparently didn’t have the correct settings. Did you change them at all?

1 Like

I maybe should have said there is a microrendu in the chain too

Hello @Matthew_Clegg,

When using a Roon Ready bridge like the microRendu, you should set the microRendu zone to “Decoder and Renderer” to achieve the behavior you are looking for.


Ok, I will have a go when I get home and report back

That’s sorted it, cheers