Upsampling with Yamaha A-S801/Ropieee?

Just out of curiosity, I tried to give upsampling a shot with a NUC Rock (Ethernet) sending wirelessly to a Pi4 running Ropieee and out via USB to a Yamaha A-S801 which should do DSD 2x.

I can’t get it to work.

DSP Sample Rate Conversion is on.
DSD over PCM is selected
PCM max sample is set to 384/32
DSD is set to 128

I still get the normal signal chain and no sign of up conversion. I’m using both Qobuz and a local library on a SSD. Any ideas?

Hi, have you tried to send native DSD? That’s what the amp seems to support. Also, please send a screen capture of your signal path.

Hey @Marian, (apologies if I don’t exactly understand the question)

I have downloaded DSD tracks before and have been able to play them in DSD, as well as high res PCM. Is that what you mean?

Here’s a normal redbook attempt at upsampling

Thanks. There’s no up-sampling happening. Make sure you enable “Sample Rate Conversion” on the left side of the DSP settings.

@Marian I believe I have that checked and I’m not sure if I’m missing another setting elsewhere

Edit: I set master clock priority to 1 in an attempt to get this working.

Please send a capture of the rate conversion settings.

Is there something else I should be screen shotting other than the first image in my last post?

The right side of the DSP settings window. I tried up-conversion myself with my DAC and it works fine, I just want to compare. One thing you might want to try is to set “DSD playback strategy” to “Native” in device settings.

I don’t see a right side. The above is what my DSP screen looks like.

My available DSD strategies are over PCM, Convert to PCM and Initial dCs method

This is how it should look like:

Thanks! Maybe that’s not available on mobile. I’ll check it on my laptop in the morning. Maybe there are more settings that I’m just not seeing on mobile app.

1 Like

Yes, that’s not showing on mobile.

1 Like

You cannot use a phone for this.

You have to use a tablet or computer UI.


the computer UI had what i needed to get this working. thanks!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.