URGENT: I'm still getting nonstop "Tracks Not Available from Tidal" Errors! Please Help [Roon Investigating]

I looked at your logs and got an idea.
Can you try disabling ipv6 in the router settings?
It can’t hurt!

Tidal is global. Their licensing of music is per country. Generally you want a Tidal account “local” to your country but some people purposely circumvent this and subscribe to an out of country catalog.

Do you have any kind of content filtering or parental control configured on your Eir account? Sometimes this can cause issues with DNS and Roon can have issues resolving the file location.

I see four errors of this form. Note that the last line is _ADVANCE, that is, to the next track. So this would be a skip. But it doesn’t tell us why the error is occurring.

When did this behavior start? Does it sync up with any updates to the Roon Core or with the Bluesound firmware?

> 01/17 16:20:57 Trace: [MacPro Node 2i + Office Powernode 2i] [zoneplayer/raat] Endpoint Bluesound NODE 2i State Changed: Idle => Prepared
> 01/17 16:20:57 Trace: [MacPro Node 2i + Office Powernode 2i] [zoneplayer/raat] synced to endpoint Bluesound NODE 2i clock: realtime=538397122 rtt=0us offset=-953479602us delta=-953479602us
> 01/17 16:20:57 Trace: [MacPro Node 2i + Office Powernode 2i] [zoneplayer/raat] synced to endpoint Bluesound POWERNODE 2i clock: realtime=569658151 rtt=1000us offset=-953449341us delta=-953449341us
> 01/17 16:20:57 Trace: [Bluesound NODE 2i @] [raatclient] SENT [677]{"request":"stream","stream_id":82202119,"first_seq":-1,"nak_port":-1,"buffer_size":10,"ready_threshold":0.2}
> 01/17 16:20:57 Trace: [Bluesound POWERNODE 2i @] [raatclient] SENT [976]{"request":"stream","stream_id":82202119,"first_seq":-1,"nak_port":-1,"buffer_size":10,"ready_threshold":0.2}
> 01/17 16:20:57 Trace: [Bluesound NODE 2i @] [raatclient] GOT [677] {"status":"Buffering"}
> 01/17 16:20:57 Trace: [MacPro Node 2i + Office Powernode 2i] [zoneplayer/raat] Endpoint Bluesound NODE 2i State Changed: Prepared => Buffering
> 01/17 16:20:57 Trace: [Bluesound POWERNODE 2i @] [raatclient] GOT [976] {"status":"Buffering"}
> 01/17 16:20:57 Trace: [MacPro Node 2i + Office Powernode 2i] [zoneplayer/raat] Endpoint Bluesound POWERNODE 2i State Changed: Prepared => Buffering
> 01/17 16:20:57 Trace: [MacPro Node 2i + Office Powernode 2i] [zoneplayer/raat] [zoneplayer/raat] selected Bluesound NODE 2i as clock master
> 01/17 16:20:57 Debug: [raat/tcpaudiosource] connecting to
> 01/17 16:20:57 Warn: [zoneplayer/raat] Error during streaming: System.NotSupportedException: Could not register to wait for file descriptor 1388
>   at (wrapper managed-to-native) System.IOSelector.Add(intptr,System.IOSelectorJob)
>   at System.Net.Sockets.Socket.BeginSConnect (System.Net.Sockets.SocketAsyncResult sockares) [0x001d4] in <3d05db74c0154ea0ba79ffba6c4417f9>:0 
>   at System.Net.Sockets.Socket.BeginConnect (System.Net.EndPoint remoteEP, System.AsyncCallback callback, System.Object state) [0x0002b] in <3d05db74c0154ea0ba79ffba6c4417f9>:0 
>   at Sooloos.Broker.Transport.RaatTcpAudioSource._Spin () [0x000a0] in <057cb6e34ad34e2d900a3ea9f8d309f7>:0 
>   at Sooloos.Broker.Transport.RaatTcpAudioSource.SendFrames (System.Net.IPEndPoint ep, System.Int32 stream_id, System.Int64 streamsample, System.Double buffersize, Sooloos.Audio.StreamFormat format, System.Double gain, System.Double peak, System.Byte[] buf, System.Int32 nsamples) [0x00613] in <057cb6e34ad34e2d900a3ea9f8d309f7>:0 
>   at Sooloos.Broker.Transport.RaatZonePlayer+<>c__DisplayClass31_0.<_StartStream4>b__1 () [0x00577] in <057cb6e34ad34e2d900a3ea9f8d309f7>:0 
> 01/17 16:20:57 Warn: [zone MacPro Node 2i + Bluesound POWERNODE 2i] Track Stopped Due to Error
> 01/17 16:20:57 Info: [zone MacPro Node 2i + Bluesound POWERNODE 2i] OnPlayFeedback StoppedEndOfMediaUnnatural
> 01/17 16:20:57 Debug: [zone MacPro Node 2i + Bluesound POWERNODE 2i] _Advance

I tried that already based on other research I did on these forums. I did it for a full day and It didn’t work, same errors and it also seemed to affect the overall performance of my day-to-day internet tasks, as soon as I turned it back on… all was good. Please remember… iPV6 has been turned ON on my router for years now and I never had a single issue like this from ROON… this TIDAL issue is only about 2-3 weeks old.

This behavior started about 2-3 weeks ago when I posted a similar support post, but got no official ROON support to try and resolve it. Dunno about Bluesound updates… like all devices, software there have been a few… but if that was the case… surely more people would be having the same issues with ROON and writing about it here…?

I’m running Roon 1.8 Legacy Core… have been for months now… since it was released and had no issues. This is all recent.

Could it be a Bluesound update?

1 Like

All my Bluesound devices connect flawlessly with WiFi, I even have WiFi 6 which is super-fast and strong… two are Wi-Fi and one is ethernet. I have access to my Wi-Fi setup and my Bluesound Powernodes that are Wi-Fi connected each have speed and signal strengths of 400MB plus. One Powernode is literally about 12 feet away from my main router. Wi-Fi speeds in my office are 500MB+. I cannot get a direct ethernet connection to the other two devices… I was using Powerline Adapters… but was told the were bad also.

I wonder if the .NET underpinning of Roon is leaking file descriptors on the Mac. It looks like Visual Studio (another Microsoft product) just fixed an issue in December which was producing the same error message:


See also

1 Like

Are you running build 1151 of 1.8 Legacy?

And which version of MacOS?

1 Like

Yes Bill… I’m running 1151 of 1.8 Legacy and I’m on macOS Mojave.

Another kibitzer here.

I know about your Mac being on Ethernet, but what about your endpoints? Your problem could be the WiFi connection. I don’t mean your up/down speeds, that’s probably irrelevant. I mean from Core to endpoints.

You say you ran the way you are now for years. If you live in an apartment or even a neighborhood, some one else may be newly on your WiFi radio channel. I don’t mean someone hacked into your network. I mean that there are only so many channels and you might be sharing one of them with a neighbor.

As an experiment, can you connect an offending endpoint to Ethernet or change your WiFi channel?

(usually a WiFi problem causes dropouts and the like, but I believe in leaving no tern unstoned)

1 Like

Mojave 10.14.6? I’m not seeing any updates to Mojave since 2021, so an update is probably not the problem.

Isn’t Catalina the latest OS?

There’s a frankensystems problem here in general. For portability, Roon depends on .NET from Microsoft, and .NET on Macs only have limited support for legacy macOS versions. Though Microsoft’s doing better at that. Apple’s macOS in general is not all that friendly and accommodating to non-Apple frameworks, and seems to be getting progressively less so.

1 Like

macOS Mojave 10.14.6 is 100% correct Bill. I have a MacPro 12 Core (Mid 2010) with 1TB SSD, 128GB RAM and Sapphire Pulse RX580 Graphics Card. My MacPro is now officially unsupported by Apple for any future macOS updates… but I will be updating to macOS Monterey using Open Core Legacy Patcher in the next two weeks or so (macOS Ventura is the very latest operating system from Apple but a few apps are not fully compatible with it yet)… so maybe that might help my very strange situation also. Again… I have been using Roon for years with macOS Mojave and my exact same network setup, and there’s never been any issues. It’s all very strange and frustrating.


Hmmm, the .NET support pages say macOS support is only 10.15+, for both .NET 6 and .NET 7 – I don’t know which of those Roon is using. So Mojave (10.14) is officially out-of-scope.

I know it seems like that, but software keeps changing, and often on consumer operating systems like macOS and Windows, it happens behind your back. And what @xxx said: WiFi is a continually moving target.

Amazing insights Bill_Janssen… you really know your stuff… so if that’s the case… I will just have to hope that my soon to happen upgrade to macOS Monterey will resolve the issue, at least that way I should be able to go from Roon 1.8 to Roon 2.0 and that could all help also.

Thank you again for all your incredibly insightful comments… most of which was way over my head… lol… but I think bottom line… I have tried all I can here with my current MacPro OS and Network Settings, fingers crossed my macOS Monterey update does the trick., it’s either that or I will just have to get a new M2 MacPro when it finally gets launched this year.

Hang on Bill… I just had an idea… Bluesound also have a native App… it’s called the BluOS app and that also works with TIDAL and I have just now grouped all my Bluesound Devices like I have them in ROON and started playing the albums that had all the skipping tracks and all are playing perfectly and at full Master quality also. So this is all still working on my macOS Mojave 10.14.6 MacPro machine… so does this mean it’s ROON software only is the issue…? or that BluOS are still using old .NET Frameworks…? Either way… this gets me my grouped audio zones back and full resolution audio. Now… BluOS isn’t a patch on the user experience with Roon… but at least this all works, PERFECTLY.

Are you using any Roon DSP?

Are you grouping any of these zones and, if so, what Zones are you grouping?

I don’t know what BluOS uses. Good chance it’s not on .NET, I’d think.

I’m looking more closely now at the BluOS Controller App and to be fair… it’s pretty excellent… much snappier than ROON on iOS on my phone and 12.9" iPad Pro… unless ROON Tech Support can help me out… I fear I may have to leave my beloved Roon… I could be hearing things, but the music even sounds better out of the BluOS app and I have loads of sound quality controls on this app also.

It’s a shame @support isn’t active on this thread yet.

1 Like