URGENT: I'm still getting nonstop "Tracks Not Available from Tidal" Errors! Please Help :(

Are you are trying to run Roon on 2010 MacPro or a newer machine, if the older PC that might explain your issues. Have you thought about the new M2 mini?

It’s a MacPro 12 Core (2010) with 1TB SSD + 9TB Internal Storage + 128GB RAM + RX580 8GB GFX Card… every other app I have on my machine is working perfectly… actually, there’s a big performance boost under macOS Monterey compared to macOS Mojave. This is my main workstation… I do very demanding large format graphics and video work on this machine without issue. My only issue now is Roon 2.0 quitting. TIDAL works flawlessly, Spotify works flawlessly, BluOS Controller app works flawlessy.

I will be buying the new M2 MacPro when it finally gets released later this year… but for now I need a fix to the constant quitting… as initially the macOS Monterey upgrade seemed to do the trick… but now this nonstop quitting has set in.

On a separate issue (which I also posted about weeks back now)… I have macOS Ventura running on my MacBook Pro 2017 with 16GB RAM, and Roon 2.0 keeps quitting on me on that also… so seriously… I am literally at my whit’s end.

1 Like

That really sucks.

I’ve hooked up my 2017 MacBook Air to Ethernet now as it runs as my Roon 2.0 Core. The only issue that keeps returning here is that playing music to AirPlay devices will occasionally stop. Restart the Mac and the problem is gone for awhile. But it eventually returns. Sadly connecting it to Ethernet didn’t solve that issue, as I also had it when using wifi.

My 2020 M1 MacBook Pro, base model with 8 gb RAM and 256 gb SSD, runs Roon 2.0 without any issues. My iFi Zen DAC V2 is directly connected to it and plays everything like a boss.

My MacBook Air just got updated to Monterey 12.6.3 today. While my MacBook Pro is now running on Ventura 13.2.

1 Like

I just did another new macOS Monterey update this morning (9am Irishtime)… it was an incremental one from 12.6.2 to 12.6.3, but I did it in the hope that it might resolve matters. Absolutely no difference!!!

It’s with a heavy heart I have decided now to leave ROON… this is all just too stressful… weeks I have been at this… it won’t work on two different computers running two different versions of macOS… one is a high spec MacPro 5,1 12 Core (2010) running macOS Monterey 12.6.3, the other is a MacBook Pro 2017 running macOS Ventura 13.2 and neither of them can run ROON 2.0 without constantly quitting. I have had enough… it’s all toooooo stressful… Spotify app works flawlessly on both machines. TIDAL app works flawlessly on both machines, BluOS works flawlessly on both machines. All my performance graphic design (Adobe Creative Suite) and video editing apps (Final Cut Pro) all work flawlessly on both machines.

Also… not much interaction with official Roon Support, only that they are “looking into it”. Very sad how this has all worked out… but I need to move on. I gave it my best shot and it just wasn’t enough.

My new setup will be TIDAL + BluOS for Multi Device Grouping & Granular Volume Control.

Maybe I will come back when Roon 3.0 gets released.

Anthony

1 Like

Hi @Anthony_McCarthy,

I’m sorry to hear that your experience with these MacOS issues in Roon has finally met the limits of your patience. Your efforts have been heroic.

A workaround for most users encountering the ThreadpoolWorker crash you’ve most recently reported is to install RoonServer instead of Roon. The UI component appears to trigger or affect the context of the crash. You can then use a separate Remote to control Roon in the meantime. Rest assured the tech support team is taking all steps to escalate our investigation into the causes of that bug.

Please find RoonServer here on our downloads page, if you wanted to give it another chance: https://download.roonlabs.net/builds/RoonServer.dmg

We’re happy to answer any questions. Additionally, if you run Roon again one more time on your Core device in the meantime, it will trigger log reports to automatically upload to our server to investigate the most recent crash.

1 Like

But how does Roon Server work Connor Schake…? Does that mean I install it on my MacPro machine here running macOS Monterey and then I could use my iPhone or iPad to control the music content…? I have never used it… so I don’t know how it even works or the correct install steps… ?

I deleted the Roon 2.0 app Connor Schake. Will a fresh download help…?

The Roon download is really two parts, 1. a Graphical client and 2. the RoonServer part. When you install Roon fresh it installs both parts. You can however, just install RoonServer without the graphical client. In this case, the software will run with no graphical interface and you would connect to by running Roon on another computer, OR, Roon Remote on a tablet or phone. One thing to note, is that not all desktop options are available on the tablet and certainly not the phone interface.

Another thing that you can do, is install RoonServer, and then on the same machine install Roon, BUT, as a client only. This allows you to open up the graphic interface on that machine when you need to, but, not have to keep it running all the time if you just need the server running.

Hello again Rugby

I have Roon and Roon Server now both installed… Roon quits while it’s making a restore from backup, so never really gets to complete the process… it appears and starts to add the additional albums and tracks I have liked since the last backup 17th January… and it crashes… I don’t have another computer to run the core on… my MacBook Pro with masOS Ventura on it, also crashes with Roon 2.0 all the time.

So how would this work now on my MacPro…?

Update ROON just quit again… that lasted all of 5mins.

You have to be careful and install them in the correct sequence or you will actually have two servers running.

  1. From fresh
  2. Install RoonServer
  3. Install Roon, but, important: choose to connect to an existing server. Do not select “use this PC”.

I have uninstalled both now again Rugby… by deleting the apps and the /library files also. I have downloaded both again and they are inside my Applications folder.

So what do I next… which app do I open first…?

What do I select…?

So I now have ROON 2.0 GUI and ROON 2.0 Server on my MacPro… how does Roon Server work… as I’m sure pretty soon ROON 2.0 GUI will quit again… ?

This version of ROON seems to have far less albums that I normally have… I would usually have done a Restore from Backup when running a fresh install of Roon GUI. I use Roon for Tidal content only. Oohhhhh hang on… it’s still adding and syncing…

Now I’m constantly getting Waiting for Roon Core or Lost Connection errors…?

Roon has completed the setup with a lot less albums and tracks than a restore would have listed… but it finished and it hasn’t quit yet.

Update: I’m also now noticing that it’s slowly, very slowly adding all my TIDAL content but none of the Loves and Album review stars that would be there if I had done all this from a Restore from Backup process. That’s disappointing, as there is about 4 years-iissshhhh of loves and reviews and small interactions with album and track content… but… the app hasn’t quit yet (the longest it’s stayed stable in a few days)… it keeps Waiting to Connect to Core, but when it does it syncs more content.

What are the next steps to using Roon Server…?

Good news… is that I left my Roon GUI app open all last night and it did not quit, as when I got up in the morning, it was still open, but now I’m getting this “Waiting for your Roon Core” message every 5-10mins or so… :frowning:

Can someone help on this… because as soon one issue looks like it’s getting fixed, another new issue commences.

Is your new core still indexing your library?
Sometimes this can take a while ie. hours.

Edit. Sorry. I reread and see the setup has finished.

Morning Jeff… and would it be normal to be ““Waiting for your Roon Core” while that process was going…?”

My current albums and track totals don’t match the version I would have had if I had setup using a recent backup… which is strange for sure… but I don’t see any additional indexing going on.

I have to give up now… it’s been a long road… thanks again to everyone who tried to help me out. It’s just not meant to be.

I already cancelled my subscription yesterday… this was my one last ditched chance to try and get it all working. Thanks again to everyone for their more than generous offers of help and advice.

Anthony

1 Like

I’m not sure if the Waiting For Core message necessarily appears when the core is indexing.
It was just an idea I had before I realized indexing had finished.

I’m running Server as core on a (Windows) machine that also has the full version installed without issue.
I’m honestly not sure if this would help any but do you have another device you could use as a remote to get Server up and running before installing the GUI version?
Then you’d know that whatever the heck is going on here isn’t a consequence of having both versions of Roon running on the same machine.

Edit: Posted before I saw you’ve cancelled.

1 Like

It’s a shame that Roon doesn’t want to work in your place. Fortunately, the other options you’ve mentioned do work as they should.

Happy listening :slightly_smiling_face:

1 Like