USB failure on Nucleus Plus

USB ports seem to have failed. They don’t pick up my DAC or Disc Drive. All worked well burning 250 discs then suddenly the drive wouldn’t burn and my RME DAC won’t show up in Audio settings in Roon. Tried reboots. Tried hard power off. Nothing. The Nucleus is only a week old.

I’ve had similar issues with my NUC/ROCK with USB devices, ripper not working and OPPO 205 not showing up in settings Audio.

Power cycling with the USB devices connected did not resolve the issue.

For me, disconnecting the USB cables, power cycling the Nuc then reconnecting the cables is a workaround until they find/correct the problem.

Pull the power to the nucleus for a min or so then reconnect

Thank you Mr. Fix it. That did the trick.

1 Like

Thnx Mike. Solution was to pull the plug for a couple minutes.

Many modern and even older computer motherboards have power to the usb and lan ports even when powered down but the power is still connected.

1 Like

Yes. I had considered unplugging but didn’t for some reason. Thnx Wizard.

Will try that next time the situation comes up. Easier than what I’ve been doing.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.