USB interface Matrix Mini -i II Pro

Hi there,
I have got a question about the Matrix devices and the roon certified change from some months ago.
Short summary on setup:

  • Roon running on NUC with ROCK
  • 2 x RopieeeXL with Hifiberry DAC and 7inch display in different rooms just work perfect.
  • 1 x Chinese USTAR DAC with ES9038 chip set works nicely with USB on NUC with ALSA interface
  • 1 x Chinese noname DAC with WM8741 chip works nicely with USB on NUC with ALSA interface
  • 1 x Matrix Mini i II Pro. My most expensive DAC but that one does not work anymore.

Matrix Ustar System

Why does the Matrix not work anymore?
It is easily recognized by Roon, ALSA chosen but when I want to play an album it simply jumps from title to title immediately.
Is this because of the change with “Roon certified” or just a coincident.
If it is because of the certified change, why do two cheap chinese DAC’s work on USB connected to the NUC and the Matrix DAC does not although using the same interface?
If something additional is used within the interface, can’t Roon just at least still use it maybe with a basic set until Matrix is qualified and certified?
I don’t know where the problem is (Matrix or Roon) but I assume that quite some people are feeling frustrated especially if they only have this one device and not like myself, where I can easily switch for the time being to another DAC, although I really miss the Matrix…

Anyways I’d also like to thank Roon for the great system and Harry ten Berge for Ropieeeeeee… :slight_smile:

Hope to get some insight on the problem, or better a work around if the certification takes longer.
Thanks again, stay safe and have a great new year.

Just a coincidence, I think. Roon Ready applied to network enabled DACs and Roon seeing and using the network interface. Even for affected DACs, USB connection was not at issue.

Some additional information might be helpful for the support technician:

How your DAC is connected, or what is the audio chain? I think from your description it is, ROCK > USB > Matrix > AMP? Have you tried a different USB cable, just in case?

What kind of content is skipping? (Local or streamed? And does it work one way and not the other?)

Was it working before and was this a sudden issue? (I am assuming it was working before)

Does the issue happen if you use a Live Radio Station?

1 Like

Thanks Daniel for your reply.
yes, thought as well that USB should not be affected, but I can’t get it running anymore.

  • tested other cable -> not working
  • same cable other DAC -> working.
  • now tested Radio station based on your hint -> also just skipping, not working
  • tested at a friends Roon setup (also USB direct to NUC/ROCK) -> not working
  • all data is skipping, local (NAS), streamed and Radio station
  • had been working flawless for about a year
  • yes, ROCK->USB->Matrix->Amp

Maybe I should test using the USB from one of the Roopiee’s but I do not want to dismount the HifiBerry DAC HAT. Not sure if I need to or can just reconfigure the Roopieee by disabling the HAT and enabling the USB, guess it should work.
thanks again

Do you happen to have another PC running another OS, like Windows or MAC, that you could load Roon onto as a test, not loading any local music, and test like the Radio station and see if it skips. It certainly sounds like an interaction between ROCK and the Matix, but, another OS would help with additional data points.

No problemo! BTW, I am just another user like you giving you some options until Roon’s tech support engages.

Hi Daniel,
cool idea. Connected it to my Windows10 PC which runs the Roon GUI as well.
The Matrix DAC is directly detected in the “Audio” section and its supposed to use the WASAPI interface, but activating does not work :frowning_face:
I am asked for a name, give it “matrix” or “test” and confirming with ENTER Roon even crashes.
Activating the build in NVIDIA sound card works though.
mhh, maybe something wrong with the USB interface of the DAC?
All other inputs work.

That’s the nice thing on the community forum. Contribute with “your” knowledge and share idea’s.
thanks again and greatings from Germany

Ok, some further testing with Windows showed the following.
Had to wait until “activation” of the audio device had been finished. :flushed:
After that I could give it a name and switch to the device for listening.
BUT: still not working. On windows it is not skipping the titles of an album but showing the message
“Initialisation of audio device failed” (my translation from the German Windows message)
Have also checked if there is a new firmware for the device at Matrix website but seems there is nothing available.

tried to have it working via Mediaplayer from Windows.
Got the message, that a driver is required for windows.
Loaded that one, but also here DAC does not play.
Now Roon is not using the WASAPI driver but
With the message that the initialisation of the device failed.

Mhh seems the USB input is simply defective.

Any other ideas for testing?

It does sound like the unit has an issue. :frowning:

You might get in touch with Matrix and see if they have any ideas.

Leaving USB aside, can you use a different connection like Toslink and get it to work?

yep, further testing other inputs, which I should have done earlier, shows a generel defect.
The discussion about Matrix not being certified made me take the wrong conclusions.
Anyway I learned quite a few things about the Roon system.
Thanks again for your support
stay safe and all the best for 2021