USBridge not working as Roon Endpoint

@Alastair_Roberts (and @dylan) - I note that on the Arcam web site it says for the rPAC:

Simply connect the rPAC to your computer (Windows XP, 7 or Mac OSX - please note Linux is not supported by the rPAC)…

It’s starting to look as though the flavour of Linux on your Core machine is able to deal with the rPAC, but that DietPi Linux (used in the USBridge) cannot. I think you should ask Allo ( and possibly Dan Knight (@Dan_Knight the developer of DietPi) for advice.

I agree its looking like that. That would also explain why Airplay would also not work on the USBridge. But before I go out and buy a new DAC I’d like to confirm this is the issue. Surely something in the Roon RAAT logs, either on the USBridge or the Core, would confirm this. I’m happy to check myself, but don’t know where to start.

Hi @Alastair_Roberts
Your Dac is USB 1.1

connect the DAC on USB-HOST marked port.
Allo web GUI select Audio Device as usb-dac-1.1 , then reboot.

Then check the Audio.

I had a similar issue and you need to connect a screen to the pi and enter dietpi-config I believe. You are looking for the alsa menu and audio setup and you need to go into that and hit ‘m’ on both options. Mine was muted in dietpi out if the box, this unmutes the output. If you Google dietpi, Allo and mute, you’ll find more comprehensive instructions.

Sorry, meant sparky, not pi.

I tried to set audio device to usb-dac1.1 but it just keeps reverting to “none”. Sadly it looks like this DAC will not play nicely with Sparky/DietPi.

If you’ve never changed anything in the DietPi software, then you might not be saving your changes correctly.

The software is a little obscure that way.

I finally managed to get the software to take the configuration change (soundcard = usb 1.1).

Now Roon attempts to play each track for about 5 seconds, but the DAC never gets an audio signal.

For now I’ve given up with this DAC. I bought a Pro-ject S2 DAC (was planning to anyway), and this DAC appears to work perfectly with the USBridge.