USBridge Signature at DSD256 works RAAT but fails NAA (audio dropouts)

I went to put my USBridge Signature on the RME to start using it with HQP but ran into problems.Audio has various dropouts of 1-2 seconds. Not consistently but enough to make it not listenable.

Before switching to the USBridge Sig I was running NAA image on a Pi 4 without issue. There does not appear to be a Pi 3 NAA image anymore? For that reason I tried both RoPieeeXL and DietPi with similar results. spockfish confirmed that RoPieee is using the special Allo USB driver.

To eliminate as much as possible, I have setup RoPieeeXL and DSD256 upsampling in Roon. This works without issue. I then enable NAA on XL and use HQP which results in dropouts.

Any ideas or things to tweak or logs to look at to get this working?

Images of signal path…

Working with RAAT:

Not working with NAA:
Capture

There is an extra switch hop to go from Core to HQP to USBridge Sig compared to RAAT but this is the exact path which is working using a Pi 4.

Thank you for your help.

With HQP you are doing a pretty CPU intensive filter and modulator combo

But didn’t mention which CPU?

Change to ASDM7 modulator (not ECv2) and does it still happen? Much lower CPU loading

I haven’t plugged in my USBridge for a long time but I had no problem in DSD256. It even seems to me to be mounted in DSD512.
Compared to the Pi4, you haven’t changed anything?? Poly-sinc-gauss-xla is more cpu intensive than sinc-gauss-long.

I didn’t, saving those details for a different post :slight_smile: But here’s a hint…

Don’t believe this is related to HQP itself. To show that, here are two graphs. The first is HQP player towards USBridge Sig and the second playing towards a Pi4. Besides the hardware differences, USBridge Sig runs RoPieeeXL and the Pi4 runs latest NAA(uac2) image.

  • HQP → USBridge Signature
    cpuUBS

  • HQP → Pi 4
    cpuPi4

Same network cable, same power, same USB. This is frustrating because it should work. Might be time to get rid of the USBridge Sig if I can’t solve this.

I understand, it’s frustrating.
I haven’t used my Allo since I switched to ZenStream.
I had uploaded an image based on PicorePlayer with NAA added.
If you know a little linux (I’m not a pro) you can set up the image without too much difficulty.

The main part is in French, here (and a little further) :
http://forum-hifi.fr/thread-3691-post-565004.html#pid565004

It worked until DSD1024.
I think that the ethernet driver under Rooopie or its configuration is at fault.

Thanks for this, I may give it a try or hit the easy button on a Neo Stream.

I should be able to hack-up Picore to use a newer daemon. Good to get confirmation that is / was a working solution for you. Did you do anything else to Picore like install the Allo drivers?

Linn aQua?

No, PiCore is compatible with Pi3 and 4 and also with the USBridge hardware.
It is for me the most musical os on an RPI.
It’s a pity I couldn’t find anyone to update the ZenStream kernel… but if one day you switch to the Neo, I’d be interested in a little exploration (ssh).

OK, this took a whole day but I found something that works. Over 2 30 minute listening sessions no hiccups, no drops, no issues. I will reserve “sound quality” judgement when I’m not so tired but I will also continue listening and testing.

The solution? GentooPlayer

 
  RamSystem Mode 1
  Free memory: 149MB of total 964MB
 
  5.15.36-GentooPlayer-MIN-NOGRAPH-176400+
  ───────────────────────────────────────
  GentooPlayer   | 
  ───────────────────────────────────────
  v7.00-119      | Raspberry Pi 3B/3B+ (aarch64)

 Architecture |     aarch64
 Temp         |     49'c : 120'f | Optimal.
 Governor     |     performance

I have no idea what 176400 does as I cannot find any specifics as to the compile flags / config of this variant. The newer kernel versions don’t have a “176400” variant and nothing within that newer set worked although some were better than other distributions. RT kernels won’t play except for the occasional short burst of audio.

So, this is it for now. I was joking that if I paid myself for the time on this little project I’d be able to afford a Neo Stream.

Back to the testing… I mean listening.

Thanks @dabassgoesboomboom and @Stef_Dahl for the support and encouragement that this should work.

1 Like

The original USBridge Sig with CM3+ module does not seem to be able to run RT kernel at DSD256 on any version GentooPlayer I tried within the last 2 years.
The low latency CK kernel worked well at DSD256 though.
I have modified my USBridge Sig to use CM4 for a couple of months. With the CM4, I can use RT kernel up to DSD512 (as NAA) without any issue. This can be run at fixed CPU underclock speed of just 800MHz.
I have not tried DSD1024 to see if it works yet cause will need to downgrade my Holo Spring 3 firmware for DSD1024.

What adapter board are you using? Link would be great. I may do this.

Many drivers needed for RPi are not compatible with RT kernels causing various issues. Bad driver coding… But on minimal OS, lowlatency kernel is usually just fine.

RT kernels will have some extra CPU overhead. So the RT functionality comes with a cost.

But overall, RPi3 is not so great for NAA because it’s hardware design is cutting too many corners causing various issues such as USB package loss.

1 Like

Agreed which is another reason why, when you’ve spent almost $400 on one, its difficult to toss it in favor of a $45 Pi 4. All the marketing around LPS, low noise LDOs, etc is hard to ignore when you’ve already paid for it. This is why I was so eager to get it to work. Now that its working, does it sound better than the Pi 4 I was using with your NAA image? I’m not even going to comment on that now :slight_smile: (hint, not really, but give me a week to calm down from this adventure)

On side conversations about my issue a lot of people wanted me to ask your opinion so I’ll do that here.
@jussi_laako, Specific to HQP and NAA: What’s your opinion on streamers / digital transports which utilize linear power supplies, low noise LDOs, galvanic isolation between input stage (ethernet) and output stage (USB), “high precision” cocks, and all the other marketing to drive up the price of devices which, basically, mimic the functionality of a Pi 4?

You can use the RME ADI-2 DAC FS in reference to what that marketing does to “improve” such a DAC.

Thank you for your time as always!

I use this adaptor board (bought from other seller in Aliexpress). I removed the noisy DC to DC switching power stepup IC and provide clean 5VDC directly. It work out of the box with recent GentooPlayer Pi4 images.

You can try to find similar board where you can get. Don’t need to remove the switching power first to see if it works then try to modify later.

I share some of the work in other site in the link below . You can have some reference on many discussion there for the USBridge Signature.

I didn’t make the connection but, yes, your post over on “the other forum” is the one that let me know a CM4 upgrade was possible. Doing the mod is beyond my skill level but, surprising to some, I have friends who could do the work. Thanks for the links!

Set up and forget NAA USB endpoint, as recommended by @jussi_laako: UP gateway + USB stick with NAA image. Assuming your DAC has a good USB input, there’s no reason to mess around with USBridge or any other streamer.

3 Likes

For DSD256 application, I’m not sure what could be the reason we need to go from a very good USBridge Signature (even running with original CM3+ module) to any other standard low power minicomputer. Especially, when one has already got a USBridge Signature on his audio rack and it is working well.

Small computers can hobbled by design and parts that are limited in various ways, with bottlenecks and subtle incompatibilities with available drivers. @jussi_laako recommends a few hardware options because he has tested them and they work. I followed his recommendation because I’d rather listen to music than tinker with inadequate hardware.

It depends. Overall NAA has three points:

  • It provides means to separate big processing machine physically away from the listening space
  • NAA being a small low power device doing only simple data transfer task allows it to be acoustically and electronically quiet and easy to power in various ways
  • Ethernet provides practically unlimited reliable bandwidth with galvanic isolation (NAA works over WiFi as well)

Ethernet by standard provides galvanic isolation as long as you use unshielded U/UTP cables. If you want to go one step further, you can use standard optical ethernet for absolute isolation. It doesn’t need any special gadgets for isolation.

This is sometimes useful, depending whether the DAC in question has already galvanic isolation built-in, and how each component is set up (connected) overall. Note that there are isolators and there are “isolators”. For example I have verified that Intona isolators actually work. But there’s no systematic need for such.

These days with asynchronous USB, only place where high precision clock is needed is inside the DAC. If one uses S/PDIF or AES/EBU output to the DAC, then quality of the DDC clock may matter depending on quality of the receiving device’s PLL.

Even though it doesn’t have a galvanically isolated USB and it is also running out of switching PSU by default, it performs extremely well out of the box.

1 Like

Thank you. Very useful and appreciate the first person experience.

1 Like