Use of IPv6 by Roon core

I note that my Roon core uses IPv6 is some places, although to the best of my knowledge I have disabled v6 in my Ubuntu 16.04 LTS. Is this a problem to be avoided? If so, how do I change this in the Roon settings? Or do I delete the install and start again?

This is manifest when displaying the IP address of the core, and for example when viewing an album .pdf in a browser.

Thanks. Still searching for possible causes of network issues while I wait for a replacement wireless router as the next step in my journey towards stable Roon.


Hi @Nathan_Wilkes ---- Thank you for the report. Let me see if I can offer some clarification here.

Roon uses IPv4 BUT we allow IPv6, but do not depend on it. In other words, if IPV6 is being used we are not going to “break” in anyway.

From your report I see that you are currently waiting on an new router, is there an issue that you are having that you need assistance with?

We’re here to help, let me know :wink:

Hello @Eric,

Thanks for your note. If IPv6 isn’t being used (anymore), is there any way to ask Roon not to use IPv6 addresses? Or should I just delete the db and start again?

As to problems, I have continued to have issues connecting to a wireless endpoint (Raspberry PI / HiFiBerry running latest DietPi). I have replaced the main switch, and the router is the next step. ICMP packets are occasionally erratic, as much as 100ms or more, but usually in the single digits. Increasing the buffer size hasn’t seemed to help, and if anything made things worse. I have not found anything in logs.

Frustratingly, I can always stream to a Sonos Connect that sits next to the Raspberry Pi, but I want to move away from Sonos.

Hi @Nathan_Wilkes ---- Thank you for the follow up and sharing your observations with me. I have a meeting next week with members of our tech staff and will be sure to inquire about not using IPv6 for you. My gut feeling is that there is not way to disengage that, but I will confirm.

Moving forward, based on the information you have provided I am very curious to see what happens with the new router in place. Please keep me updated when you start testing?


Thanks @Eric. BTW, I have the same issue others have reported whereby a wireless Raspberry PI 3 (Diet Pi) / HiFiBerry occasionally simply disappears when attempting to play using Roon, within milliseconds, and requires a hard restart. I am finding it hard to believe that inadequate wireless is the problem, frankly, given that I can push data to / from with ease. I have seen suggestions that power might be the problem, but ethernet works flawlessly (I am using 2.5amp power). The new router will arive in the next 7-10 days, and then I’ll do another round of testing.

FYI, I tried a new install of Roon, but still IPv6 is displayed. I assume that this is an edge case of Ubuntu 16.04 and Apple Time Capsule, for otherwise other people would see this.

@eric, by way of update, I have now replaced the following:

  • switch
  • wireless router
  • Raspberry Pi 3 / HiFiBerry

I have reinstalled Roon on the NUC i5 a few times. Replacement Ethernet patch cables arrive Monday, “just in case”.

I am still experiencing baffling behaviour. My end goal is to be able to stream over wifi to a single endpoint in my kitchen (structured cabling not an option). Occasionally earlier today the error message was something like “trouble loading audio file”, but not consistently. Sometimes music plays for many minutes, even hours.

For example, this afternoon, I was able to crash the endpoint simply by launching Roon on iOS on and IPad Air 2 and iPhone 6 respectively. Is there any possibility of @support looking at my logs and determining if there is some other avenue of investigation for me to try? I want Roon to work (I have paid for a lifetime subscription), but I need help.

If I remember correctly, IPv6 has been implemented due to a requirement of the Apple iOS AppStore since 1st of June.
But you should not bother about it. It is shown but not relevant if you are using IPv4 networks.

Thanks; appreciated. It isn’t that big a deal to view IPv6 in the URL bar. I am definitely not routing it.

Thanks for the link, as I wasn’t aware of it.


Hi @Nathan_Wilkes ---- Thank you for sharing your observations with the new devices in place. We can certainly take a look at your logs to see if we can pinpoint what may be causing this behavior to occur.

Besides gathering some logs from you, I would like to consolidate some of your information in regard to the issue you are experiencing and what your current setup looks like, so when I pass my report over to our tech team they have a clear understanding of exactly what is going on. May I very kindly ask you for the following:

  1. A brief but accurate description of the issue(s) you are currently encountering. From my understanding of your feedback thus far you are unable to connect to a wireless endpoint (Raspberry PI / HiFiBerry running latest DietPi) in your kitchen, is this currently the main issue you are experiencing or are there other issues as well? I just want to be sure we are addressing things accordingly :wink:

  2. Please lay out the details of your current setup as seen here, also be sure to include your network configuration/topology in your description. Having a clear understanding of how your devices are communicating and the tools being used to make those connections possible will greatly aide in our evaluation of this behavior.

  3. Please follow the instructions found here and send us over a set of logs for analysis.


Thanks @Eric. I’ll send over the logs and screenshots shortly.


  • Server: Intel NUC6I5SYH running Ubuntu 16.04.2 LTS, running Roon 1.3 (build 223) stable 64bit
  • Admin from iPad Air 2, running Roon 1.3 (build 223) stable 64bit
  • Switch is Cisco SG110D-08 (replaced initial older plastic Cisco, which ran warm)
  • Music stored on Synology 415+ (required changing initial SMB config essentially to defaults)
  • Router is Synology RT2600ac, no IPv6, no traffic shaping. Replaced Time Capsule.
  • Control points: iPhone 6, iPad Air 2, MacBook, MacBookPro, Surface 3 Pro

Two Raspberry Pi 3 / HiFiBerry Digi Pro running DietPi v149 (Linux 4.4.50-v7+), one wired and one wireless, as end point, using 2.4 amp power. Output using S/PDIF (copper) to BelCanto DAC 2.7 and Bel Canto C5i respectively.


  • Multiple Sonos devices, including Connect attched to same BelCanto C5i in Kitchen


  • (core)
  • and .3 (NAS)
  • (wired endpoint)
  • (wireless endpoint)
  • (router)

Network topology
Core, NAS > Cisco switch > Synology router < Cisco switch < wired endpoint

For Kitchen location (wireless), I have tried:

  • Changing the CPU to performance rather than ondemand (and back)
  • Replaced hardware completely (new Pi, new HiFiBerry, new build)
  • Changed to external wireless adapter last night (and disabled internal)
  • Previously have tried altering the buffer size in Roon, but currently using defaults
  • Reported wireless connection 72Mbps “Good” for external adapter, 58Mbps for internal.
  • NB: replaced wireless router as well, as above.

Historic issues

  • Initial SMB config caused Roon to break. [Solved]
  • Original switch would overheat, causing no access to any devices [Solved via replacment]
  • Troubles with large albums either crashing or not displaying. [Solved via software update]


  • Every so often, the kitchen wireless endpoint drops out, occasionally triggered by launch of control device. Usually the endpoint will reappear in the Roon interface, allowing music to be started (manually) again.
  • Sometimes, music plays for hours.
  • No apparent other network issues, although ICMP demonstrates some volatility in response times.
  • Roon occasionally reports that the audio file is slow to load.

Current state of kitchen

  • Using external USB adapter.
  • Using replacement hardware
  • Roon default config for end point.
  • “ondemand” performance in DietPi.

Things to be done

  • Replace all ethernet cables.
  • Adjust endpoint buffer (require guidance on this)
  • Test UDP performance (?)
1 Like

After reading other forum posts about wireless performance, I wondered whether the problem might in fact be interference from the Sonos Connect sitting nearby. I have removed it, as well as other Sonos gear that isn’t absolutely required for the moment.

Preliminary results are encouraging (several hours and music is still playing).

1 Like

I have a few ideas of things you can try with your WiFi setup based on some of your observations, but can’t type that post out on my phone. Let me look back at some of my notes and get back to you on that. Probably tomorrow.

One thing that you might try is to turn off WiFi on the Pi in the kitchen and connect it to one of the Ethernet ports on the Sonos. Due to the way the Sonos mesh network works these ports will actually pass traffic to the rest of the network. If Sonos is working reliably then this might be a better way to get network to the Pi.

1 Like

Thanks @AMP for the suggestion, and apologies for the delay in responding. It is my understanding that the Sonos Ethernet ports are disabled when using wireless, but I tried it anyway (unsuccessfully).

But, it got me thinking more about other ways to solve my performance dilemma. I decided to acquire some Powerline devices (Wirecutter reviews), and lo and behold I was able to obtain a 150-200Mbps connection. Unfortunately my Bel Canto was unable to lock onto the HiFiBerry Digi pro signal after plugging in Ethernet, but a change to Toslink fixed that. If the system remains stable, I’ll write something up about my experiences.