Using any audio source with HQPlayer - Spotify, Amazon, Apple Music, YouTube Music, Deezer, Soundcloud

I didn’t know that, so the only way to have the output the same as the input with Apple Music, without a lot of hassle, is by using RME ADI-2.

In my experience, yes that is the case. Although I never had your Audiowise thing.

Assuming the SRC DX doesn’t create issues (I don’t know) then you can leave sample rate on PCM768kHz and leave auto rate family enabled.

Don’t buy new though. Look for a 2nd hand. It’s too much money to spend on new, just for optical & digital coax to USB converter.

Be careful not to buy “RME ADI-2” … that doesn’t even have USB at all, which would be a very big problem.

I am using “RME ADI-2 DAC FS”

And to go digital coax/optical out of iOS you need a converter.

I have one of these which works well:

And you need Apple’s USB adapter which I assume you already have.

1 Like

Cool thing about my RME, is when Apple supports hi-res over Airplay (hoping this year !!) then I just need to connect a streamer with optical/digi coax output straight to the RME.

And then no more cables between iOS and the RME. That’s the dream !

Hi again!

My RME ADI-2 pro has arrived. Now I need some help to get the chain working:

SPDif via AES/EBU → RME ADI-2 pro → USB → Raspi 4 with HQP OS → NAA → MacMini M1 with HQP Desktop → NAA → Allo USBridge Signature with RoopieeXL image → USB → DAC

The ADI-2 pro shows correct sync to AES input rate and bits. It shows correct sync on USB with the same rate (I don’t use any format conversion inside the ADI-2 pro). The ADI-2 pro meters are flickering on AES input. Clock is set to AES, not to INT. USB mode activated.

HQP Desktop on MacMini M1 shows the devices if output and input backend is set to NAA:

Output: roopieeexl xCORE USB Audio 2.0: USB Audio
Input: hqplayer ADI-2 pro (serial number): USB Audio

The DAC at the end of the chain synchronizes to HQP Desktop conversion settings (DSD 11.2896M).

Now the problems and questions:

a) no music can be heard. Maybe wrong input device choosen?
b) must I select audio:default/(bitrate)/2 from menu and press play in HQP Desktop?
c) how to use the automatic rate switching in HQP Desktop with the ADI-2 pro as input device?
d) how to setup the ADI-2 pro correct for AES input and USB output? This is a real complicated device with lots of settings!

Thanks for any help and hints!

Regards
Dirk

Have you updated your ADI-2 firmware? There’s been a few updates this year, so do that first.

And then did you see post #710 above , 2 weeks ago?

Without doing that, there is no way for HQPlayer to talk to your specific unit (for input)

You don’t have to select auto rate switching. It works like magic.

Ok, I’ll do the update first. Thanks

EDIT: update done.

Regarding post #711: do I edit the hqplayerd.xml on my Raspi HQP NAA OS or on my MacMini HQP desktop?

EDIT 2: if on Raspi NAA OS - ssh with root requires a password! Which one?

Do it on your RPi4 NAA OS.

Post #710 was for someone using an UP Squared as their HQPlayer main machine, so different to you.

Note I’ve mentioned before, either you or someone else I don’t remember - you can’t use your NAA input and output at the same time.

So I have an RPi4 dedicated to ADI-2 input.

Then another seperate NAA for just output.

On RPi4 :

nano /etc/networkaudiod/networkaudiod.xml

Then edit (there’s already a line there but need to change your DACXXXX serial number):

<input channel_offset=“4” channels=“2” device=“hw:CARD=DACXXXXX,DEV=0” format=“auto” name=“ADI-2 (S/PDIF)” pack_sdm=“1” period_time=“100” samplerate=“0” sync_element=“SPDIF Rate” sync_hctl=“1”/>

On input page you select ADI-2 (S/PDIF)

I renamed this as you saw in screenshot

Thanks, I’m already using different Raspis with NAA for input and output, so this problem does exist for me.

It’s now that I cannot connect with ssh root@xxx.xxx.xxx.xxx because I’m asked for a password.

You need to hookup to monitor and keyboard to RPi4. Only 1 time but required.

You have the microHDMI cable?

Ah, ok. No problem. Thanks, I’ll be back to report success or failure. :wink:

That’s all that’s required.

After that, it’s pure magic !

One problem could be ‘channel offset’ number.

I don’t have the Pro model. But try channel 4 and see what happens.

I think there’s something in the manual about the numbers. You can try or read the Pro manual

I edited the networkaudiod.xml on Raspi4 according to your hint.

DACxxxxxxxx (where xxxxxxxx is my serial number) is correct? Because the ADI-2 pro fs is not a RME DAC like you are using. I edited it with DACxxxxxxxx (my serial). Then reboot.

You say “On input page you select ADI-2 (S/PDIF)”. The input page of HQP embedded at my Raspi4 or at my HQP Desktop?

On HQP embedded/Raspi4 there is no option ADI-2 available:

On HQP desktop/MacMini I choose either ADI-2 Pro (AES) or ADI-2 Pro (SPDIF). Both settings lead to the error “#NAA input cINetEmgine::Connect(): initialize: cIALSAEngine::Initialize(): snd_pcm_open(): No such device”

Ok so I mentioned NAA OS on RPi4 but now see you are running HQP OS.

If you are running HQP OS on Pi, then you will need to follow the instruction in post #710

I only use RPi4 for NAA input. I don’t run HQP OS on it, I run NAA OS.

For your HQP Desktop to input RME via RPi4, the instructions I gave today is for that.

What does your Desktop show for inputs , on your settings page?

Are you running more than 1 NAA with stock image? Maybe you need to change NAA name for your RPi:

Sorry, that was my fault. I downloaded and flashed the wrong image. Now I flashed naa-4123-raspberrypi4.img

I did the editing in the XML, but the error while saving the input device in HQP desktop is still there:

I changed DACxxxxxxxx to Proxxxxxxxx and the snd_pcm_open() error is gone.

If I press play the error now is “Transport == NULL”

Are you sure I have to choose AES or SPDIF as input device in HQP desktop?

My chain is (to clear out):

AES → ADI-2 pro → USB → HQP NAA on Raspi

As requested earlier, can you share screenshot of what you see in list of inputs in HQP Desktop?

And did you change NAA name, since you mention you have multiple NAA’s. See post above.

I changed in /etc/hostname of HQP NAA image to adi2NAA.

Here my input devices list (eAES and eSPDIF was used by me in name-parameter to be sure to use the correct device):

1 Like

Ok, and nothing happening when you select eAES?

I have Desktop but don’t use it.

Let me open it to test RME + RPi4 input

I think you should be seeing your serial number if you did things correctly

Let me check my Desktop and report back

So here is my input (I renamed mine but I think it matches with your eAES):

Highlighted should be eAES for you

THen you select 44.1k for example (best to have music already playing, pick the current sample rate but not that critical in my experience)

ANd then hit the play button

I did it this way, changed to NAA IPv6 too (just to be sure). After saving preferences there is “NAA input network QoS functionality not available”. Ok, maybe just an information.

Then I choose audio:default/44100/2 and press play. Playing starts, DAC is synced, but results in fast and loud sound ticks (8-10 ticks per second) instead of the music. :sob: