Using any audio source with HQPlayer - Spotify, Amazon, Apple Music, YouTube Music, Deezer, Soundcloud

Likely yes, but with manual rate control, unless their ASIO driver supports rate slaving. Which is not usually the case. (it is optional feature in ASIO drivers)

Thanks

I use the interface driverless (class compliant) with Ubuntu atm. Sampling rates change without a need for drivers or ASIO.

I’m not against fixing sampling rate at 192khz. But I’m not interested using Windows in my system.

You still have the Linux kernel UAC ALSA driver in play. For digital inputs (S/PDIF and AES/EBU), sampling rate is determined by the source device. Not by the software using the audio interface through ALSA. At the moment ALSA expects application to set the sampling rate for the device, not vice versa. Same applies to CoreAudio on macOS and WASAPI on Windows. Only ASIO drivers on Windows support sample rate slaving properly, but even there, that is optional extra and many drivers don’t do that. This limitation also applies for the USB Audio Class standard. In addition, you may need to adjust USB device clock settings through ALSA when using such sources, so that the device is clock slaved to the source instead of using it’s internal clock.

However, for RME ADI-2 and RME HDSPe series, workaround for this has been implemented in the Linux driver and HQPlayer has special support for it to allow automatic rate change detection. (I did the ADI-2 USB support implementation and HDSPe implementation was there already before)

This means that with most devices, you need to match the sampling rates manually when they change. If your source is fixed rate like Spotify or old school CD spinner, it is not an issue though. Or something like ADC where you determine the rate.

3 Likes

For D to A output yes, but that’s not special.

Different story with the digital inputs if source material is changing sample rates.

At the moment I am beta casting direct from Amazon Music HD app on iPad, straight to WiiM Mini Streamer.

Different albums of different sample rates properly (bit perfectly) get fed into HQPlayer via an RME ADI-2

I can do the same with Apple Music Hires but that needs cables connected to the iPad.

No cables connected to my iPad casting Amazon Music HD at the moment.

Sounds cool.
I had an RME ADI 2 DAC fs, sold it a while back.
Using up to 8 channels these days… so the ADI isn’t helpful.

That WiiM mini measures quite well via toslink…

As I wrote earlier, I’m doing 8 channels (3-way DSP plus 2 subs) DSP crossover and room correction

You may have mistaken what I’m doing and what Jussi wrote. The ADI-2 is for input into HQPlayer, not output…

All my music listening is 2 channel source… so the ADI-2 is definitely enough for 2 channel sources. Not talking about ADI-2 for playback side anywhere here

The ADI-2 input feature is brilliant for 2 channel sources where you have sample rate changes and want bit perfect playback.

But there’s also people doing advanced stuff like @Chunhao_Lee feeding Dolby Atmos sources through HQPlayer. Over 8 channels into HQPlayer, from memory.

All that matters with a TOSlink source is bit perfect playback

Once you have bit perfect playback, the only measurement that’s important is the D to A

The WiiM’s optical output is bit perfect up to 24/192. There’s no other measurement required for the digital output side.

Hi guys
I tried my best to read this thread but at some point gave up trying to map my setup to the described scenarios.
I should have one of the simplest setups trying to stream bit perfect audio from my iPad Pro (last lightning port generation) to my Up Gateway Atom Mini PC USB3-port which is running Jussi’s Intel-NAA-bootimage.
HQPlayer Desktop 4 latest version is running on a Mac mini M1 in the network.
No issues streaming from Roon to HQPlayer in that scenario but now I want to try playing Apple Music from my iPad Pro.

I’ve adjusted the BIOS settings on my Up Gateway NAA to PCI etc as mentioned at the beginning of this thread.
What I couldn’t understand from this thread is how to specify the UAC input on HQPlayer Desktop (not embedded!) as I don’t know how to find and edit a hqplayerd.xml on the desktop version as it’s just a daemon, or is that input yet preconfigured on HQPlayer Desktop so I just need to select it like this?


When playing music on my iPad Pro while the NAA is powered on (and showing the usual DSD1024 on my connected Holo Audio Spring3 connected to the Up Gateway NAA indicating that the DAC connection is established) I cannot select any other target on IOS but my iPad or iPhone respectively Airplay destinations in the network,
Shouldn’t there be some unidentified device in the IOS drop down list which I need to select regardless of the HQPlayer Desktop config so the issue is yet laying on the UPGateway config side?
Thx for reading

First, I’d like to confirm that you have connected iPad to the Type-B micro-USB port on the UP Gateway, through Lightning-USB adapter dongle (Camera Connection Kit or similar). And not to the regular Type-A USB ports on the UP Gateway.

Second note is that you cannot use same NAA for both input and output at the moment. For such, I’d need to extend the current networkaudiod with such capabilities.

Otherwise, your settings look correct. You then need to first start playback from UAC2 source in HQPlayer. Only then HQPlayer will appear as a DAC on USB. When you stop, it will disappear again.

In order to start playback, you need to select the audio: source URI and press enter so that it gets loaded on the transport. Then you can press Play in HQPlayer - that will start processing audio from the UAC2 input to your output.

2 Likes

Thx for your reply!
Yes, I am using the cck.
You said NAA cannot work as both input and output.
What does it mean for the HQPlayer settings I’ve posted before?
Anything to be changed there?
Seems that HQPlayer is stuck in that config with turning circle symbol on Mac running the HQPlayer desktop.
I can only access the settings once I am turning off the DAC and HQPlayer is then aborting the search and saying "


NAA input adapter “naa” not found.
Once the DAC is on, I am getting that stuck turning circle also after selecting one of the proposed URIs from the dropdown…

Edit:
I managed to select an URI and hit play but still no different target visible on IOS device

You have same NAA, called “naa” defined for both input and output. This won’t work, so the input side will fail because the NAA is already busy with output. You can have multiple NAAs on the same network, but they need to have unique names.

Here it is not appearing on the transport track list below. So it is not working.

Please see here for an example:

the mentioned examples in the QuickStart guide refer to only either "Audio:default/samplerate/sequence number or files from local library.
Am I right assuming that I need to select one of the “Audio:default…” entries - though this will mean I will have a fixed sample rate and not a variable one?

If you say both input and output NAA cannot have the same name, do I then need to rename the NAA name for the input device in some hqplayerd.xml as I read before in this thread - thus I was asking how to edit that file on HQPlayer Desktop, or do you say that name is overwritten by the input URI mentioned before?

“default” points to the default input device selected in HQPlayer settings.

Yes, you will specify some startup rate, but it doesn’t mean that it would be fixed, it can still change.

hqplayerd.xml applies only to HQPlayer Embedded. NAA name comes from the NAA side. If you have multiple NAAs, you need to rename at least one of those, so that there’s no naming conflict. Two NAAs claiming to have the same name will lead to problems, because the devices behind each NAA are different.

ok, so the default device then is the “naa: USB Audio Class 2” device selected in the settings menu, right?
I only have one UP Gateway NAA connected through USB3 port to Apple cck and through USB2 to the DAC.
That is one NAA hardware device only and should work according to posts in this thread before, right?
still each entry in Input Device settings and Output Device settings is having the same “naa”-prefix.
So what can I do to make these different?

Btw I also have an IFI Zen Stream which I have just activated for the sake of testing and it’s connected to the SPDIF port of the DAC.
IN HQPlayer settings I have now selected the IFI DAC as backend, so that now input and output have different names.
Still I am getting a stuck turning circle symbol afterwards.
Will call it a day now.
Can test again next night.
Good night

Yes

It can be either input, or output. But not both. You need to use some other means to connect a DAC in this case.

That should be fine now.

OK, when trying to select the input? Would be good to check the log file.

If you did update networkaudiod would output sample rate have to match input?

Because of the thing you previously mentioned about two different clocking systems required for different in/output sample rates?

  1. I’d suggest to disconnect your Holo DAC from Up board physically and then USB connect to your Zen Stream. Use USB as your main connection on ZS.

  2. Boot your Up board using 420-x64ramfs version. This one is the most stable version for Up board and can do autorate. @jussi_laako I found the naa-422-x64 cannot autorate on Up board… Always hang when switching the sample rate.

  3. BIOS’ South Bridge setting should look like this:


    Do not use Auto or ACPI mode. Only PCI mode can be the UAC2 input.

  4. after selecting the sample rate, click somewhere in the yellow square area, you should see the playlist shown on main window. After that you can click the playlist or click play button to activate the Up board input (before you hit play the Up board won’t enter the device mode.)

2 Likes

thx for your suggestions.
I indeed got it running once with iPhone connected to USB 3 port of UP Gateway and Playback though IFI Zen Stream upsampling to the limit of 386khz but I got constant stuttering.
After trying to reduce sample rate I couldn’t get it working again.
I come to the point that I can enable the USB3 input so that I can select the “Unidentified device” on IOS but once I switch on my DAC and try to set it as playback source I am getting into the stuck turning circle in HQPlayer Desktop.
Might need to refresh the UP Gateway NAA stick with the proposed image version but not this evening anymore.
Somehow a pity this isn’T working as straightforward as I hoped it would

The naa420ramfs one should work.