Using Grouped Homepods + Outputting Roon to Bluetooth Zones

Core Machine (Operating system/System info/Roon build number)
Mac Mojave–latest version

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Mac laptop as core; Onkyo receiver; Apple homepods set up as stereo

Description Of Issue
Roon, both on the core and on my mobile devices, doesn’t pick up some of my bluetooth devices, my Onkyo receiver in particular. How do I get it to appear?
Also, I’m having trouble combining zones. One homepad is in one zone, the 2nd one is in a separate zone. When I try to combine them, they seem to get a signal for 1 or 2 seconds, then transmission stops. Ideally, I could transmit my music to them as the way I have it set up, which is using the 2 homepods in stereo. But if I can’t do that, I’d be ok with combining them as 2 different zones, if Roon would let me.

Hello @Sandra_Wenner,

For the Bluetooth connection to the Onkyo, you would need to use your Mac to Connect to it first and then set the output zone to the OSX’s “System Output” or “Built-in Output”.

As for the Homepods, you would need to group them using the iPhone Home App and you need to use iOS Airplay to stream to them. Once grouped, they should show up as a single zone in your iOS Roon App and once that zone is selected you should be able to have audio output to both.

Please let me know if that helps!

Thanks,
Noris

Just to build on this, my understanding is that you currently have a few options when playing to two Apple Homepod devices from Roon:

  1. Roon > iOS Device > Airplay 2.0 > Homepod Pair [Stereo]
  2. Roon > Single Homepod [Mono]
  3. Roon > Homepod Endpoint + Homepod Endpoint Grouped [Mono]

If you want, you can also use Option #1 and apply a Procedural EQ to play mono over a stereo Homepod pair.

Hi all. No matter what I do I can’t get Roon to use or see the HomePod stereo setup. And when I try to put both homepods in the same zone, the track barely starts and then it stops. Every single time. I guess I’m just way too stupid for this.

@Sandra_Wenner

I am able to stream to my stereo-paired HomePods, but not directly from Roon, because AirPlay 2 is not supported yet. As Michael stated above, you will want to have your iPhone/iPad/iPod touch set up as a Roon endpoint.

From there you will choose whichever iOS device you have chosen to stream to. Once Roon is playing on your iOS device of choice, you can then [send] the steam via the media card [screenshot], in Control Center, to your stereo-paired HomePods.

With this method you are not enabling the HomePods as endpoints in Roon. So, there is nothing to figure out with regard to zones or anything else for that matter.

I hope this helps and Roon releases AirPlay 2 support soon. :grinning:

Thank you!!! I finally got it. Thanks to everyone for being patient with this newbie! I really appreciate it.

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.