Using Nucleus and Roon app not loading on Win 10 desktop computer after updates

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus OS Ver 1,build 227; Roon Server OS Ver. 1.7, build 667. For access using Dell desktop computer running Windows 10 ver. 2004 Build 19041.630

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet, no wifi use, standard ATT broadband router. Can access Nucleus IP/System Status through browser no problem.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Running to PSAudio network bridge in Directstream DAC. also using USB direct from Nucleus to Direcstream

Description Of Issue
Roon app originally worked fine on this computer, played fine and Nucleus visible in Explorer. After computer updates Roon app brings up splash screen but will not load and delivers this message “Error: LoadLibrary failed with error 87: The parameter is incorrect” Also could not see the Roon Nucleus in Windows Explorer anymore. Re-established network connection with Explorer by changing network settings others recommended online but app still not loading and same error. Turning off video drivers for add on Radeon Pro WX-2100 in this Dell Precision 3630 helps by allowing access past splash screen and removing the incorrect parameter/load library failure, but program says “taking too long to find Nucleus core, check settings” and then no more. For comparison testing, I loaded the app on another Win 10 machine on the same network with similar setup (it has just basic Intel video) and Nucleus/Roon app work fine on it so it appears to be a specific machine issue. Problem is that it is not the machine I need it on! Thanks in advance for any help you can provide.

If you have recent windows updates on your remote maybe can detail more about the hardware and specifically the graphics drives. Sometimes windows updates drivers and there is some issue - sometimes getting the latest drivers form the graphics chip company rather than windows is best.

Sometimes the 32bit install of roon can help too

Hi @Craig_Wallin,

Can you try uninstalling and then reinstalling the graphics drivers from the manufacturer’s website? Once you’ve done this, if the crash still occurs, please use the directions found here and send us over a set of logs using a shared Dropbox link. Our team will take a closer look at what’s happening!

Thanks for the suggestions so far, I have uninstalled the Dell provided video drivers and installed the latest from Radeon but Roon app still crashes at splash screen as before. All else seems fine. Here is the dropbox link to the log files.

1 Like

Hi @Craig_Wallin,

Thanks for sending over those Nucleus logs! In this case though, we would kindly request you send the logs from the crashing PC as well.

There should be a Roon logs folder you can access using the same instructions sheet as before (or just paste this in Windows Explorer header to save some time: %localappdata%/Roon/Logs

Please send us the log set you see on the PC for review, thanks!

Thanks folks, here is the link to the appdata logs:

1 Like

Looks like this support issue has been dropped, not seeing any response for days now after your last info request. If we are done it would be nice if you let me know too.

Hi @Craig_Wallin,

Thanks again for sending the logs over and for your patience while we had a chance to review!

Looking over the logs, there’s unfortunately not much information contained in them, but you did leave one other clue earlier in the thread:

This error is often attributed to using RDP (Remote Desktop Protocol) or a GPU issue.
Are you by any chance using RDP on this machine? If not, I would try to:

  1. To update any Intel GPU drivers using the Intel tool:
  1. Try to manually specify the video card Roon is using:

Let me know if this helps!

I was havig the same error. I was getting the splash crash and the LibraryLoad fail 87 error. I uninstalled the core software and reinstalled and resetup everything and it worked fine. It only a took a few minutes.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.