Using Roon on a single computer as Control/Core/Output - playback breaks

I’m having some issues with using Roon on a single computer. I’m outputting everything to a DAC/Amp, but I’m getting some mild playback issues. Small “skips” or breaks in the music, even from music I have on my hard drive.

Anything I can do to fix this?

What kind of files do you play?
File format, bitrate, samplerate, compression …

And please give some more information about your setup (PC, DAC, …)

FLAC or Apple Lossless files.

Just a Laptop to a Schiit Stack out to speakers.

Funny you should write that @Boxing_Robes

I’ve been experiencing the same: millisecond breaks in the music both streamed from Tidal and local.

I rebooted my Rooncore ( Mac Mini) and it couldn’t find my LH Labs Geek Out 1000 DAC. So I rebooted the DAC which meant I momentarily disconnected it from the Mac Mini. No more glitches for over an hour.

This has never happened before with Roon. The only thing different is my greater usage of HQ Player to upsample to DSD and playing tracks of varying sample rate/bit depth this morning.

It’s been a few weeks since I rebooted the MacMini RoonCore. I hope this doesn’t mean I have to do it more frequently.

Hope this helps.


I’ve had to have fresh restarts on my laptop to get rid of the little breaks…but, at times, even with the restart, I’m getting them.

So, curious if its something I can do to free up some resources to get clean audio all of the time or…something else.

I’ve got a similarly simple setup - 2012 i7 MBP with 16GB ram. It’s my only Roon machine - Core and output from this machine, to a Mjolnir 2/ MB Gungnir stack. No issues with skips or breaks. My MBP seems to want to change the audio midi settings and periodically mutes my DAC, but otherwise Roon runs like a charm and really isn’t a resource hog at all. I use Tidal, lots of ALAC files, and a fairly large library of hi res FLAC, mostly 24/96, some 24/192. Not sure that’s really helpful, other than to say it is possible - you’ve re-started the laptop, maybe power cycle the DAC?

Hi @Boxing_Robes,

I’ve shifted the thread to Support where it can get some individual attention.
Can you provide details of your laptop and OS ?
Are you running any other software on the laptop when this occurs ?

Windows 10 w/ i7 processor w/ 8GB RAM

At most, I’m lightly browsing the internet…nothing otherwise resource heavy.

Are you using ASIO drivers. If yes, are they up-to-date? I have seen dropouts happen if the ASIO buffer is not large enough (this has happened mostly with HQ player). Have you tried setting ‘use max hardware buffer size’?

I’m using WASAPI output right now.

Let’s drop flags for @mike and @vova. They may be able to track this down. Shouldn’t be happening on an i7.

So, I gave the Schiit Stack a reset and last night, I didn’t seem to have any problems…I was even performing a few light installs on programs during playback. I’ll get back to you if there is any hiccups in the next few days.