Using the remote on iPad 2 mini is really frustrating. (Dropped connection)

My Windows 10 roon core.
Network: Computer -> switch -> WIFI router ´-> WAN
iPad mini 2 remote -> WIFI -> WIFI router

It can take ages to find the core.
Lots of retrying and lost connection
If it actually manages to connect it can loose connection early.
If I sleep my iPod it is pretty much a guaranteed disconnect with lots of failed retrys.
I’m probably forgetting stuff.

It’s really frustrating sometimes I feel like throwing my iPad into a wall before I realize the problem is not with my iPad.
Not sure how common the problem is. Neither roon core or roon remote is often updated as far as I can tell.
I can’t do very much in the iPod end but could probably run wireshark at the roon core. Not sure I would understand it. Should be able to capture TCP streams.

Just connected two computers one Mac and one Windows 10 as remotes (wired).

When disconnecting the wire and running my Mac mini with WIFI it instantly lost connection and it took ages for it to connect again. Then the connection was dropped and picked up a minute later. I told it to play a track and the application crashed to desktop. Started the app which took ages to connect. Failed to change song as it lost connection that fast.

I know more after writing this topic than before I started. It appears to be WIFI related to say the least.

Am I the only person experiencing this?
My roon core computer does not have WIFI is this important?
I don’t think me using a switch is a concern as it worked flawlessly. It just allows me to use shorter cables.

I’m not used to dealing with WIFI problems, my main concern is that it appears slow.
Computer -> internet:
Wired: 60Mbit/s
WIFI: 30Mbit/s
I’m pretty sure I run the factory default settings on the router.

This is unrelated to the main problem.
I just connected my computer to the internet using my iPhone but I only got 4-6Mbit/s, not enough to stream 1080p.

Best wishes and hoping to resolve this somehow.
Ulf Jälmbrant

What is the make / model of your Switch and Router. Is the switch managed or un-managed?

Technicolor TG799vn v2
15.3 version

Bulk standard router/adsl modem at my ISP.
Very customized to the ISPs need.

Simple 8port switch almost 15 years old 10/100Mbit/s.

Contacted my ISP for support and they installed latest firmware for router.
New firmware might have solved the problem.

1 Like

Could be red-herring but my iPad mini wifi has been performing badly a few times recently. I found Bluetooth enabled each time which I don’t use.
Turning off the Bluetooth resolved it.


Problem appears gone for now

Did you make changed to you system, shut down any programming!s or restart anything before the problems stopped (that you hadn’t tried previous to your first post)?


I upgraded my router software. Went to the ISP and they installed latest firmware. This appears to have solved the problem.

Hi Nick,

this has been the best tip I’ve got from this forum since months. I’ve always had some 1-2 seconds reconnection time when switching to the Roon App on my iPad Air. Just realised that I had Bluetooth on all the time with no need, my bad. Turning it off fixed the Roon window responsiveness. The issue is totally gone.

So simple and such a big impact - thanks a lot!



Hey… you’re welcome. I didn’t know if it was a real thing or not. Must some conflict with Bluetooth and wifi.

I must admit that it’s not totally gone, but better.

Bluetooth is not related to the main topic of this thread but happy that some people get improvements there.

My scenario was spending 2 minutes connecting and then getting disconnected within 2s starting the cycle again.
I’m currently looking at connection times mostly way below 1s.
No longer frustrating to use.

I had same problem here. I had a Ziggo router and an extra linksys wifi point. Both of them where giving IP adresses to devices in the my network, and that was cousing the problem. I disabled the linksys giving IP adresses to devices on the network, this is now only done by the Ziggo router, and there was no more lost connection on my Ipad. The Linksys is getting now an IP from the ziggo router.
Hope this was helpfull.