Using two hard drives is causing Roon not being able to connect to core

Not able to connect to Roon core…

Roon Core Machine

Nimitra Signature server

I got this list of specifications from the Fidelizer website. I believe this describes the standard version of the Nimitra server but I’m not sure.
Intel Celeron J1900 quad core 2.4GHz processor – Quad core, low power consumption but powerful enough with 2.4GHz turbo mode and 2MB L2 Cache
**mPCIe SSD for OS storage
DDR3L 4GB Memory
Windows 10

Networking Gear & Setup Details

Fiber optic internet connection
eero network
modem supplied by isp
ethernet connection to NimitraS server running Roon core
2 external hard drives connected to NimitraS server.

Connected Audio Devices

2 Roon endpoints

USB to exaSound e38 DAC - Adam Audio A5X powered speakers (computer room system)
Wireless to Platin hub (still not Roonready)
Chromecast to Buchardt Audio A500 dacs/amps/wireless active speakers (living room system)

Library Size

I don’t know how many tracks since I can’t get Roon to run at the moment.
I suspect around 50,000 tracks but not sure.

Description of Issue

I have 2 hard drives that need to connect to Roon:
HD1 (E:) - 244GB free of 3.63TB vectotech rapid ssd
HD2 (D:) - 3.68TB free of 9.09TB Western Digital My Book

Roon functions with just one of the two hard drives enabled - the vectotech rapid ssd (E:).
When I enable the WD My Book (D:), Roon functions while importing/analyzing the files but then fails and Roon is not able to connect to the core. The vast majority of my music is contained on the WD My Book hard drive.
The same issue occurred when I was using a hard drive array containing basically the same files as the WD My Book. I thought the problem could be caused by corruption of files contained on the array so I ran chkdsk on the array (chkdsk d: /x /f /r). That returned no errors but still, the problem persisted. Next, I enabled my backup set of files using the WD My Book hard drive… same problem. Roon is unable to connect to the Core when both hard drives are enabled.

Using two hard drives has never been a problem in the past so I’m at a loss to understand what is causing the issue now.

Thanks for your help,


Hey @Mike_Covher,

Thanks so much for getting in touch, sharing the issue you’re facing and adding the screenshots. We’d love to help sort this out.

Could you please confirm this is correct: separately, each of your storage locations work in Roon (so Rapid (E:) works in Roon and so does My Book (D:), but not both simultaneously?

What device are you using as a remote to connect to your Roon Core?

Hi Rebeka - Most of the time I use a PC for the Roon remote but I also use an android tablet, a laptop, and my android phone on occasion.
The developer of the Nimitra Signature server I’m using remoted in and worked his magic - now Roon functions with both hard drives. He mentioned that it would be useful for me to upgrade the server to a 64bit system. Is a 64bit system required or advisable to run the latest version of Roon?



Hi @Mike_Covher

For larger libraries we definitely recommend using the 64 bit version for best results.

Hi Dylan - Thanks for the info. What size library could best results be achieved using a 32bit Windows10 operating system. The reason I ask is I’m considering paring down the size of my library. I no longer have a multichannel capable system and many of my files are multichannel dsf format - massive compared to stereo pcm flac or wav files.

I hope to continue using my current 32bit music server. Will future versions of Roon continue to need more processing power to achieve best results?



Hi @Mike_Covher — Generally if you have under 100K tracks it should be okay. For the most part, the power needed is dependent on library size, so unless your library size is going to be increasing a lot there shouldn’t be a major change in the requirements in this area to my understanding.

1 Like