V1.2 Build 161 Mytek Brooklyn losing lock

Ever since upgrading to v161, periodically it will lose lock to my DAC. This only usually happens during a transition to a new song / album, and never during playback.

I was just able to replicate it just now by simply going to audio devices, and then clicking “settings” next to the DAC during playback. Usually this does no cause any disruptions but I saw the message “Transport - roon lost control of the audio device” It is now back after a few seconds.

This never used to occur, and I believe it’s related to this latest update.

Running it on Windows 7.

Brooklyn DAC is USB.

After this happens, it will self-heal after a few seconds, but then the DAC is confused and now no longer shows the bitrate on the front display, I just get “No Lock”. To resolve this, I need to disable and reneable the device in Roon. Works for several songs then does it again.

What also frustrates me is that when this happens, Roon jumps from theater mode (full screen album art) back to regular display mode and my system has no mouse / keyboard so I have to remote in and change it back to full screen. I mainly have a display connected to show the album / song playing. I had asked for this as a feature request when Roon first came out, was told it would be considered and then it went to the ether. Just want a way to force it to theater mode.

I’m having similar problems with a Mytek Stereo 192 and with a Concero HD. But I’m using windows 10.
Althou it may be related to the mytek as I have both connected and the same time, but only one being used at a time.
I noticed that when I play a genre it stops after 2 or 3 musics.

Hi @narkotic ----- Thank for the feedback and my apologies for the troubles here. I appreciate your insight and sharing your observations :+1:

In order to accurately evaluate this issue I’d like to get a better understanding of the gear you are working with. May I kindly ask you to please provide the following information:

  1. I see from your report you are currently running Windows 7 and making use of a Brooklyn DAC :sunglasses: Are you able to expand on this information for me and provide a detailed description of your setup, as seen here The more specific and detailed you can be, the better.

  2. Can you please describe your network configuration. I would like to get a sense of how your devices/equipment are communicating (wifi, ethernet cable, both)? Also, can you please confirm if any network hardware is being used in your current setup (router(s), repeaters, extenders, powerline adaptors, switches). If you are able to provide the make and model of any of these devices, that would be great information to have as well :sunglasses:

  3. Do you have any active firewalls or anti-virus applications currently?

  4. Have you had any Windows updates recently?


  1. Mac Mini bootcamped running Windows 7. Nothing spectacular, been using it w/ Roon since it came out.

  2. I’m a network engineer - so having a hard time understanding the genesis behind this question as it seems more of a local problem between roon core and the DAC (via USB). It’s hard wired to a gigabit switch then to a file server that is running server 2012.

I have a Mytek Brooklyn and Windows 7 running the 161 build and have no issues, but I do a Wyred recovery usb relocker from the PC to the DAC.
My music sits on a 12 bay Synology NAS and all gigabit connections (I’m a network engineer too)
I also have my old Matrix Mini-i Pro in the mix and I am yet to have any issues with either of them in the system. My PC is no a Mac though but a HP z800 (with twin Xeon CPU’s) running the core and then Roon bridge to the Matrix.

Is there anything specific you want me to try to see if I can replicate the issue too ? I mean what file (FLAC/DSD/MP3???) and so on?

No thanks…

I’d like to get some engagement from Roon support though, is there any logging that I can give to you when this happens? Seems to be the best way to track down an issue, before throwing in a ton of other things that may or may not be relevant (updates, LAN/WAN, firewall, etc…)

Hi @narkotic ---- Thank you for responding to my questions. Our developers require a complete understanding of a user’s setup when an issue occurs so we can test under identical circumstances should the need to arises.

I had a chance to meet with my developers today to discuss this issue and would like to ask you for the following:

  1. Can you please provide screen shots from your audio settings tab as seen in the examples below.

  1. You mentioned in your initial report:

“This only usually happens during a transition to a new song / album, and never during playback.”

Are you noticing any patterns here? Does this happen regardless of codec and sample rate?


Dear @Eric,

As I have a very similar problem, if you want I can do any tests you need, although I have a different DAC, but from the same company.
I’ve just tried to replicate the problem consistently, and I noticed that the problems happen everytime the samplerate changes, more frequently if going from higher sample rates to 44.1 or from 24bits to 16bits (but not exclusively).

I’m using a computer assembled by me, with a i7-6700k, 16GB DDR4 Corsair, Samsung 850 EVO SSD for OS and nVidia GTX970. My music is stored on a local Samsung HD.
OS is Windows 10 Pro with the latest updates.
Roon is 1.2 (161) 64bits.
I’m using a wired connection to my router.
DAC is a Mytek Stereo 192 DSD. Latest firmware (1.8.3) and latest driver (1.35.22).
I’ts odd that when I try to change the settings on the DAC it sometimes make a pop noise and show the “Manage Audio Device” button.
Below are the prints of my settings (I tried to play with the resync delay and buffer size/power of 2) with no success.

Hope this might help somehow.

Here are the screen shots as requested. Note - The resync delay of 2 seconds is something I recently tried as a remedy to no avail. I have also tried both buffer size options also to no avail.

And I concur with the above user, it does seem to happen more often when switching between 24 and 16 bit.

5 posts were split to a new topic: MyTek 192 DSD Losing Lock Switching Sample Rates