Various artists in 1.8

Upgraded to 1.8, looking nice!

I am facing an issue, which I believe is related to various artists.

I imported a folder. It now shows as 1 artist and 89 albums. When I click the artist, only 57 albums show up, which leaves me with 32 albums not being displayed.

I selected “show hidden albums”, so this is not the issue.

I believe that the 32 albums are all “various artists”. I don’t know how to filter for them. It seems that not all of them are compilations, so sorting for compilations doesn’t do the trick.

Any thoughts?

Filter for “Various Artists”.

Where? I had tried this, but no luck. In the album view, all albums are listed under artist A (the albumartist), but the artist view only shows 57 where artist A is listed as primary artist.

Feel free to post screenshots here that depict your issue. Apparently I and probably also others can’t understand/guess your problem from the description you gave so far.

Fair point and thanks for your help. Please see below. You will see that the primary artist is “various artists”, while the albumartist is “Cafe del Mar”. The album can only be found in the album view. I cannot find it under “cafe del mar” and cannot filter for “various artists”.

Why not? This is how one usually does it. Was the same in 1.7 AFAIK.

Filter for Various Artists and that’s what you get.

I think the difference is that your “various artists” are “albumartist”?

See below and note the difference to your screenshot. The album is that yours show as “various artists” in the album view. Mine shows as “cafe del mar”. Also, yours seem to have a hyperlink and gets you to the various artist. Mine has no hyperlink at “cafe del mar” and “cafe del mar” does not include this album in the artist view.


What do you want? “Cafe Del Mar” or “Various Artists”? Choose one and stick with it - make the necessary changes if needed. Add “Cafe Del Mar” to the primary artist links and get rid of the “Various Artists” if this is what you want.

The issue is that I cannot easily find a way to do that… I’d like to have all 89 albums affiliated to “Cafe del Mar”. To do so, I need to change the “primary artist” to “Cafe del Mar”. I can do this eaisly for the album, for which I have sent the screenshot.

The issue is that 32 of the 89 Cafe del Mar albums are matched by Roon to “various artists”. I don’t mind to manually change these 32. But I cannot find an easy way to find the 32. I could of course open and edit each of the 89, but that’s very cumbersome. So, I am looking for a way to find the 32.

If this was just for Cafe del Mar, I would not mind going through the 89 albums, but there may be many more “phantom albums” (i.e., albums that only exist in album view, but are not associated with any artist.

There is always a primary artist (“Various Artists” in your example).


I don’t know what this is, but it surely doesn’t look like the result of a filtered album browser (for reference look at my screenshot).

Have a look at my screenshot above. The issue is that I cannot filter for “various artist” in my case.

If both albumartist and primary artist are set to “various artists”, it works and I can filter by “various artists”. That’s what’s happening with you.

If albumartist is set to “XXX” and primary artist is set to “various artists”, the album disappears in nirvana and you cannot filter for it. That’s my setup.

Easy to replicate on your end. Take any of your albums and remove “various artists” from albumartist, but keep it as primary artist.

Yes it’s easy to replicate but it would have been much easier if you simply would have shown what you see when filtering.

Filter for “XXX” then. The album is not in Nirvana for me but can be found filed under XXX. It sure is possible to filter for it. That’s what I figured out by testing.

Let me find you more screenshots. If I filter for “XXX”, the album shows up, but together with 88 other albums

57 albums (primary artist and albumartist both “cafe del mar”) - these albums all show up under artist “cafe del mar”. All good with them

32 albums (primart artist “various artists” and albumartist “cafe del mar”) - these albums don’t show up when accessed from artist view. They cannot be filtered as “various artists”. They can be filtered as “cafe del mar”, but then they are together with the other 57 albums. So, I can never isolate the 32 albums for renaming and these albums are not accessible by selecting any artist. So, there is no way I can ever find these albums unless in the “all album view”

Let me send some more screenshots

That’s what I see in the “all album view” (I created a library only consisting of the 89 albums and nothing else)

And that’s what I see when selecting “Cafe del Mar” from the artist view (no other artist can be selected from this view). Also, no other albums than “main albums” exists when scrolling down.

The VA albums should have different (not XXX) track artists. The question is, can you single out the 57 “cafe del mar” albums using focus on artist? If so, then combine filter (88) and focus (57) and finally negate the focus (32).

Else, select all the 57 albums from the artist view and add a (temporary) tag to them. Then combine filte (cafe del mar) and focus (on the tag) and finally negate the focus.

Might look something like that but not equal.

Thanks for your help! I had played around settings. This could work per se. However, it won’t help me once I import my whole library with 100+ movies as I’d need to set these tags or hundreds of artists to then filter them out in album view. With this workflow, I could also just go manually go through the 89 artists.

There must be some way to filter, sort or search for “various artists” (primary artist)?

Set Album Artist to Prefer Roon - you should now perfectly be able to filter for “Various Artists”. Set back to Prefer File when you change the Primary Artist Links.

Thanks a lot, amazing work-around, this should do the trick. Appreciate your help!

Let me mark this as “solved”.

Having said this, I’d still consider this a work-around and still believe that’s an improvement needed in Roon. I have filed it already.

Kudos for your persistence, Blackjack.

1 Like