Veeping noise every time I am playing a song with Roon

Hello, :wave:,
I am new to ROON, but even though I love the software, I cannot get it running flawless, i.e. running without background “veep”.

My problem is: every time I start a song from my ROON (iTunes) library or with Tidal, I get a high veeping noise in the background. The beeping starts and finishes as long as the orange or green button next to the song titles are shown ( showing the source path). The beeping starts whatever signal way I choose.

My setup is:
Mac Mini 2014 (not yet headles), running as my ROON core ( software Roon server) with about 4000 music titles on iTunes stored directly on my Mac.
The MacMini is connected via USB, an audioquest jitter and dragon fly and an Evergreen audio cable with my Marantz AV 8802A. On my Marantz I have a 5.1 setup with ELAC loudspeakers.

As I am new to Roon, I have a pretty much standard ROON setup.

Any ideas how to get rid of this annoying veeping noise ?

Maybe this helps: I have first discovered the problem, when playing high resolution files ( my library has Qobuz highRes audio files ) looking at the path. I have included a picture, maybe that helps.

Thank you for your help.

October 19, 2018Preformatted text

Hi @Michael_M — Thanks for reaching out, and apologies for the difficulties here!

Can you confirm whether this behavior occurs with all endpoints? If you play directly to the Mac does the same noise happen?


Thanks Dylan for getting back.

However, I do not quite understand what you mean by playing “… directly to the Mac…”. What do you mean ?

Do you mean playing ROON directly from my MacMini via Airplay or other connections through my Marantz AV8802 ? Well, if I play through iTunes directly through AirPlay (choosing my Marantz AV8802) there is no veeping.

Is that what you meant ?

I can only say, that testing it over and over again, and if I play low quality files, then the veeping is not so loud. It gets louder the higher resolution I use…

Does that help ?

Here is what it looks like when a “normal file” is played…

In terms of ROON endpoints I use the following:

  1. a MacBookPro running ROON
  2. an iPhone running ROON

Those are the only two endpoints through which I steer the MacMini Core with Roon server.

The veeeeping noise occurs on both of them, i.e. it does not matter whether I use the iPhone or the MacBook Pro to start a song.

Is that what you meant by your question ?

Do you have any other music that is not AAC?


Hmm, good point. I am an Apple fan ever since my studies back in the 1990s and therefore I have collected for the last 15 to 20 years every song in my iTunes folder… which indeed holds all my music ! ( apart from the music bought from Qobuz in (HiRes or CD quality).

So yes, 95 Percent must be AAC…apart from my physical CD library.

Do you want me to test another format ? which one ? I would have to put it into my Mac, as I have only a super drive…

I also would have a Cocktail X40 which however is unfortunately not ROON ready…( I told them already that this is a real pity, but I guess they want people to buy new products) and I do not know how to get music from there into my MacMini.

To cut it short: I am willing - for test reasons - to convert my music into any other format through my MacBook Pro or buy a song in any other format for test reasons.

Let me know, which format.

A lot of people use Flac; WAV is also good.

It’s a shot in the dark. Probably won’t make a difference, but I mistrust AAC.

Try it, let us know.


Ok. I have checked my library and tested: FLAC ( see my post above), AAC, AAC+, MQA, Mp3…

All with the same result, however with FLAC the veeping noise is stronger, plus ROON / Dragonfly does these strange conversions ( see post above).

WAV is a windows file, I would not know how to get it into my Mac…hmm, any other ideas ?

WAV isn’t Windows, WMF is Windows.

Still, I guess the experiment wasn’t any help. Too bad.

BTW - when @Dylan says “play directly to the Mac”, I think he is asking can you hook your DAC up to USB port, rather than using endpoint.

By “endpoints” Dylan means audio endpoints - your MacBookPro and your iPhone are acting as Roon Remotes (Controls).

Is there some reason why you have connected your MacMini through a Dragonfly to your Marantz? I think you should be able to just connect the MacMini directly to the Marantz using an HDMI cable - and that would appear in Roon as an additional endpoint. Might be worth trying?

@dylanDylan CaudillRoon Labs: Support

I have thought about your point …“play directly to the Mac”.: do you mean I should control ROON our of my core MacMini ? This is not possible, as I have setup my MacMini with the software ROON server. This software does not allow me to control ROON out of my MacMini. I can launch at startup and then control with my iPhone and / or my MacBookPro.

I forgot to mention the OS: my MacMini is using Mac 10.13.6 High OS Sierra… and I just wanted to mention that it runs more than ROON, because the Icloud fills the Mac with all my other stuff which is in the cloud.

Maybe that causes the veeps ?

Hold on - I will want to try everything, but it is too much at once for me, so let me get this sorted:

  1. WAV - my mistake, sorry. Will try it later…

  2. “…hook your DAC up to USB port, rather than using endpoint…” I do not understand, maybe I am a too old user…:wink: Here is my setup:
    In my MacMini sticks the jitterbug, than the dragonfly, than the audiocable going into my Marantz AV 8802a…So the DAC is in the USB port , right ? Or should I put the jitterbug out ? Do not know what to do…

  3. Ok. My MacMini has only one HDMI cable and at the moment the port is connected to my TV, because I am not quite running it headless. I have tried to connect the MacMini via the HDMI cable directly to my Marantz AV8802A before the setup with my dragonfly, but I wasn’t able to play HighRes files / FLAC files. The reason for the setup with a DAC called Dragonfly is, that I want to hear ideally HiRES / FLAC files with my Marantz AV8802A…

Hey @Michael_M —- Apologies for the confusion here.

By playing directly to your Mac, I meant playing to the default output of the Mac / internal speakers of the Mac. You should be able to see this by going to Settings > Audio and enabling that zone.

This test will allow us to know if it’s always occurring or if it’s only happening when playing to specific devices.


@dylanDylan Caudill

Hi Dylan, with “…default output of the Mac / internal speakers of the Mac.”…you mean the default output of my MacMini ?

Its not strange. Your first example above you are playing a 24/192 file but the dragonfly is limited to 24/96 and Roon has to resample it down to the proper rate. You are seeing the resampling steps Roon is using.

@RugbyDaniel BeyerCommunity: Moderator

Ok. Thanks. But why does it convert from 24bit to 64bit and then back from 64bit to 24bit ?

@dylanDylan Caudill

Ok Dylan. Here is what my MacMini setup looks like. To cut it short: I think I tried to set it up as you said. No difference, the veeping noise is still there when I play ROON…!

You don’t need to try WAV, it was just a thought. @dylan’s the guy to troubleshoot this.

The reason it goes up to 64bit is because the sample rate conversion is best done at that resolution.

The analogy is like the old electronic calculators, the more decimal places there are, the more accurate the calculations would be.

Sample rate conversion is a mathematical process, the greater the bit depth, 64 in this case, the more accurate the conversion.

Roon does that 24-64-24 thing with my endpoint as well (Kef LS50W) it’s not unique to your Dragonfly.

Hope that makes sense.