Version 3.113 - Unable to Play Since Update

Hi. After updating to version 3.113 my endpoint has stopped playing.
I am using Raspberry Pi 4 Model B Rev 1.4 with a HifiBerry Digi+ Pro HAT.

Details as below;
Software Version: 3.113
Kernel Version: 5.4.83-5-SPCKFSH-v7l+
Board Temperature: 47.2℃ / 116.9℉
Board Serial ID: 100000005538e1c8
Board Type: Raspberry Pi 4 Model B Rev 1.4
USB FW Version: 000137ad

Any assistance gratefully accepted.


You’ve probably tried this already, but have you rebooted the RPi? Also, have you rebooted your router?

Yes. Tried rebooting the router, NUC ROCK and the Pi without success.
Both ROON and Spotify Connect appear to be playing but no sound emerges.
No other changes other than the Ropiee update. My other Pi is working fine elsewhere on my network on 3.113 but that has a HifiBerry DAC2 HD HAT.
Can’t swap them to check, due to different outputs.


My main ones working now but I updated yesterday afternoon and last night out of the blue playback stopped and wouldn’t resume. I tried on other Roon zones nada. I could search and do everything else in Roon but play. Looked like something killed RAAT completely. I am on ROCK to so this may be related to the recent Roon update as well? I had to reboot core to get it back to working .

Still no joy. Reinstalled the NUC ROCK Operating System (V1.0 build 227), restarted RSS (V1.8 build 795) and reinstalled CODECS, reset the database and settings, and rebooted router/NUC/Pi…


Just out of interest, what’s the endpoint that the Digi+ Pro is connected to? Are you able to send Feedback logs to @spockfish via the Ropieee interface?

Also, out of interest, did it stop working after the Ropieee update to 3.113 or after the Roon update to 1.8.795?

Connected to Dynaudio XEO 5 active speakers. Feedback log sent “Logs have been sent to RoPieee HQ with unique identifier 8359a9533ce06794”. To the best of my knowledge, it fell over after the RoPieee update.

It’s the no sound that’s puzzling me. @Simon_Arnold3 reported a stopping in playback, but your playback is working, just without volume (correct me if I’m wrong). Can you investigate the “Volume control” on the “Device setup” on the Zone in question? Is it set on “Device volume”, “Fixed volume” or “DSP volume”.

You can get to the “Device set up” via the “Audio” tab on “Settings” and then clicking on the cog of the Zone in question. Apologies if you already know this!


Assuming you already have rebooted your Core (which is really advised after a Roon update) I suggest you:

  1. disable all XL services
  2. disable wifi as I see there are WiFi issues being reported

Check again with just Roon.


Hi. Set to ‘Device Volume’

Hi. No still no sound. On the RoPiee XL section, for the Upnp/DLNA, Shairport-Sync, Librespot and Squeezelite tabs, adjacent to the ‘Audio Output’ drop-down box, when ‘HAT’ is selected, there is a grey box stating “hardware mixer not supported”.
I have sent updated Logs:9410ca9563090721

Have you disabled all XL services and wireless?

Yes - all disabled.

The logs show they are not. Please disable them (output to off), play audio over Roon and then provide feedback.

OK - all XL outputs to ‘Off’, wireless off. Still no sound. Updated logs; e2a71bbbb0cf5b29

Hmmm… I see some reports in the RAAT (Roon) log that are rather vague and I don’t remember seeing before.

A few things I can think of you could try:

  • make really sure the HAT is properly connected: maybe you should deattach and attach it again
  • make really sure that stuff like DSP in Roon is disabled


Removed the HAT, checked the pins and re-seated. DSP is disabled.
No change - no sound.
Is it possible to revert to the previous version?

No that’s not possible.

What should I do then?

Can you try the beta channel?