Very slow adding albums to library from Tidal

Roon Core Machine

Windows 10 Pro desktop PC, Intel Core i3-4130 CPU @ 3.40 GHZ, 8GM RAM

Networking Gear & Setup Details

Core is hardwired with Cat5e to Netgear R7000P router, via this switch

Number of Tracks in Library

40,785 tracks

Description of Issue

Frequently (though not always), when I cligk the + button to add an album from Tidal to my library, I get the spinning wheel for a very long time. Sometimes it finally finishes after several minutes, and sometimes it spins indefinitely.

Usually the “Added to library” popup message appears immediately, but if I click on it, it takes me to the album page and shows that the album has not been added (the + button is visible to add the album again).

This happens both on mobile and desktop. If I close the Roon app and come back to it later, sometimes the album has been added, sometimes the wheel is still spinning, sometimes it has stopped spinning but the album was not added.

Also, sometimes when the wheel is spinning, if I click on “Versions,” I’ll see that the Tidal version of the album has actually been in my library - but when I scroll back up to the current album view, the wheel is still spinning and when I click on the 3 dots, I don’t have any of the options I would have if the album had been added (e.g. no option to add to playlist, tag the album).

I have rebooted my core and the issue is still happening.

Here’s a screengrab video of what this looks like on mobile.

1 Like

Seeing similar thing with a Roon Rock NUC (Intel NUC Mini PC i5-7300U 3.5GHz 7th Gen) but with Qobuz. The NUC is hardwired and remote access via 5ghz dedicated WiFi.

It now takes what feels like ages but reality is probably 15-20 secs to add an album. If I then click on tags afterwards the list of tags is blank and a couple of seconds later they all appear.

Overall, the current version just feels quite laggy.

NUC = Build 1148
Mac = Build 1148
iPhone & iPad - Build 1148
Tracks in Library - 35k
Ubiquiti UDM Pro router & 16 port PoE & WiFi 6 AP.

Same symptoms with Qobuz.

I can load and favorite recordings with near instant response. Adding recordings to my library in Roon can vary from a few seconds up to several minutes.

Giving this a bump. Issue is still happening.

I have the same problem with adding albums from Qobuz - sometimes it takes minutes, sometimes won’t happen at all.