Very Slow SMB Speeds of Nucleus on a Mac [Solved - Managed Switch Port]

To maintain my library on an up-to-date Nucleus+ with an internal SSD, I often mount my Nucleus disk on my iMac Pro running the latest version of MacOS Mojave (smb://nucleusplus/Data). The Nucleus and my DAC are on a small local switch, which is connected to a larger switch, which in turn is connected to the iMac Pro (the connections are all 1 gbps, except for the 10 gbps to the iMac). There are no networking issues that I can see in my house, other than that the copying of files to the Nucleus is now very slow, maybe at about 6 mbps. I have a feeling, but am not sure about it, that the copying was significantly faster, at about 35 mbps, before the upgrade to the new macOS Mojave. Did anyone else experience this? How fast should be the file I/O from a Mac to a remotely mounted Nucleus disk

Ops, I meant MB/s, not mbps.

How fast is smb supposed to be?

Hello @Andrej_Sali,

Thanks for contacting support, I’d be happy to assist here. The speed of SMB will depend on your network throughput and how it is set up, based on this thread somewhere around 47mbps (or 6MB/s) seems to be expected:

Can you please post a screenshot or let me know the results of running the command
smbutil statshares -a in OSX terminal? It should list the SMB version being used and if SMB signing has been turned on. I saw this article which shows similar behavior where SMB speeds decreased because of a SMB signing change on Apple’s side and maybe this is what you are experiencing here.



Thanks a lot for responding.

I attach a snapshot of the output from the command you asked me to run (it does not look good, but don’t know what is going on). The Data disk is currently mounted, as shown by the icon in the upper right corner, and a Finder’s window showing the contents of the disk below the terminal window. I also attach a snapshot of the drive from the “Get Info” command. I have yet to read the article you linked to.

I mounted the drive by going to “nucleusplus” under Locations on the left side of a finder window, and selecting the Data folder.

Thank you,


Hello @Andrej_Sali,

Thank you for posting the screenshot of the terminal output. I have brought this case to QA and they have looked of the information you have posted, there are two possibilities going on here:

  1. The internal SSD is malfunctioning and has a performance bottleneck
  2. The Network is malfunctioning

To test for theory #1, we can run a benchmark test and create a 1GB file on your MacOS in terminal by running the following command:

dd if=/dev/zero of=Desktop/test_file.txt count=1024 bs=1048576

After creating this file, you can run a time command to see how long it takes to transfer this file from your OSX to the internal Nucleus disk. The commands are as follows:

time cp Desktop/test_file.txt /Volumes/data/Storage/
time cp Desktop/test_file.txt /Volumes/data/Storage/InternalStorage

More information on the time command can be found here

Please give this command try and post the screenshots from the terminal output as to see if the time value is within the expected range. You should be seeing 3 outputs per command from those commands,


Please post a screenshot of your findings when possible or if you have any questions regarding this test, just let me know and I can clarify.


Here’s the screen shot.

Since the behavior of both Nucleus SSD disks is similar, i guess there is either no problem or the problem is the same for both of them? In any case, I have not noticed any issues with the internal SSD disk I installed (and it worked fine when installed directly on a Mac initially).!

Thank you, Andrej

Hello @Andrej_Sali,

Thank you for posting that screenshot. QA has confirmed that this doesn’t seem like a drive issue. They have noticed that since it took 1 min 32 seconds to transfer the file over, the speed would then be 11Mb/s which is roughly 90Mbps.

This kind of speed would be one that you usually get from a 100Mb switch connection, so I am now wondering if the switch could be the cause of this speed? Can you please first bypass the small switch for both of your Nucleus and your Mac OSX and try connecting them directly into the the second switch and verify if running this test again yields a smaller time output? If the time is roughly the same, can you bypass both of the switches and temporarily connect your devices directly to the router to see what time is listed then?

If you have another machine around the house running OSX it may be worth checking to see what speeds are present when using the same kind of connection as to narrow down weather this issue affects only that specific OSX remote or other devices as well. Please let me know if you are able to perform the above test and your results when possible.



I think you saved me - many thanks! It turned out that for some reason the port on my Netgear managed switch worked at only 100 mbps. I have no idea why (rebooting Nucleus didn’t help). I moved the cable to another port on the same switch and it came back autonegotiated at 1000 mbps; for good measure, i also validated the connection with the utility built into the switch. Your speed test is now much faster, at 14 sec instead of a minute and a half (see attachment). I am assuming this is what it should be, and so I think the problem is solved.

Thank you very much, Andrej

Hello @Andrej_Sali,

Glad to hear that you were able to pinpoint the issue to the managed switch! The speed test is now showing much better results, indicating you’re up and running now with the full speed. I’m going to go ahead and mark this case as [Solved] , thanks again for contacting support and I wish you a pleasant listening experience :headphones:.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.