Vodafone Germany: No port forwarding for home accounts. DS Lite Tunnelled IPv4 address that doesn't do port forwarding. [NOT Resolved for Most Users; See Posts. Roon Investigating]

[Edit much later: In principle this can be moved to the -resolved room, but I don’t know if Roon staff wants to clean it up, so leaving it here]

The path to failure
I thought I had tried everything as per the troubleshooting protocol and following the Fritzbox help pages. First with UPnP enabled, then disabled and manual setup. I always got “Not Ready” on the Roon ARC tab in Settings.

This was the latest error status, then trying with UPnP again, with Independent Port Sharing enabled on the Fritzbox for the ROCK (IP x’ed out):

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 95.xx.xxx.xxx:55000, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“95.xx.xxx.xxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I also tried enabling the “exposed host” setting (more or less firewall off for this device, as far as the Fritzbox lets you), both trying this for IPv4 and IPv6, but no dice

Note it shows an IPv4 address

IPv4 problem?
If I haven’t missed anything, then the docs are always talking about port forwarding and so I am, maybe wrongly, assuming IPv4

I thought I had an external IPv4 address as far as I knew, which had not been standard with Vodafone consumer accounts for many years but had to be specifically requested - which I did long in the past, and at the time port forwarding worked just fine. But then I haven’t used forwarded ports for ages.

I thought my router status page told me that I had an IPv4 external address but now I wonder if I have misinterpreted it. It shows:


  • An IPv4 address is not given, says something about a DS-Lite tunnel
  • But there is a green light next to IPv4
  • It says “[Port sharing]: 1 port opened via UPnP ( TCP 55000 ).”

However, some searching on Vodafone forums turns out that they refused enabling IPv4 addresses for consumer accounts since at least 2019, and that people who ask about “FRITZ!Box is using a DS Lite tunnel, AFTR gateway” on their forum are refused with “we can’t enable IPv4 for you”. So I guess they must have turned it off for me as well and I didn’t notice. I don’t even know if I would remember if they had sent me a letter.

At the same time, though, www.whatismy.ip tells me
My Public IPv4 is: [95.xx.xxx.xxx]
and that is the IP in the Roon ARC error message.

I am guessing the DS-Lite tunnel might enable only the most basic IPv4 functionality that you might need for browsing and such, but not more “advanced” stuff like port forwarding?

Is this the problem? What to do? Can ARC work over IPV6?

1 Like

A post was merged into an existing topic: Virgin Media HUB 2.0 [notes for Ireland users]

Yep, thanks, I have meanwhile had the bright idea to google DS Lite. Vodafone write (Google translation from German):

DS Lite stands for Dual Stack Lite and is a tunnel technology. That means: Every customer has a public IPv6 prefix, i.e. several IPv6 addresses. In addition, up to 60 customers share a public IPv4 address. This means that every customer can use both IPv4 and IPv6 services. At the same time, the rare IPv4 addresses are saved.

Outgoing IPv4 packets are given a private IPv4 address in your router. This address is only used internally and cannot be reached from outside. The data packets are then forwarded to the public IPv4 network via an IPv6 tunnel. For this to work, every IPv4 packet gets a new IPv6 header – a kind of letterhead. Your Internet provider has a so-called carrier-grade NAT. NAT stands for Network Address Translation. The NAT then takes care of the translation back to IPv4. It unpacks the data packets and forwards them to the actual destination: the public IPv4 network.

And crucially:

Restricted use: Customers who have their own server in their home network to store files may not be able to access them as usual. With DS Lite it is not possible to access the Internet from outside if the server does not support IPv6. Extra tip: Make sure to set up the server with IPv6.

Hello @Suedkiez

have a FritzBox and the same problem as you.
The shown IP adress with whatsmyip is another than the one shown in FritzBox 7590 at portforwarding.
Some providers have shared ip adresses to save adresses.
i am not at vodafone but a small gernan provider, i contacted the provider and they look what they can do now

Yeah, some providers might still give you a real IPv4 address if you ask, but Vodafone don’t for consumer contracts (but apparently do for business contracts).

Get an 502 Error on my Core and just saw this thread.
I also have Vodafone and already heared about ds light.

Luckily i switch my provider on the 12th Sep, wich has dual stack.
i will report!

Hi @Alexander_Ritter,

Thanks for the report here, and we’ll be watching for your topic in the #early-access:port-forwarding-progress section once you’ve had a chance to test.

@Suedkiez, we’ll go ahead and move your summary above to the #early-access:port-forwarding-solved section. Thank you again for this detailed report.

1 Like

Location: Germany
ISP: Vodafone
Router: AVM FritzBox 7430
Phone: Google Pixel 4A 5G / Android Version 13

Everything runs perfectly fine. I am really impressed by ARC. Lots of potential. Only downsides for me are that ARC doesnt put out bit perfect and converts the audio stream to Androids internal 48kHz and the lack of DSP/EQ.

Looking forward to a 10 band parametric eq too be implemented. Even though these are minor issues these will keep me from using ARC after the testing is done.

1 Like

Wait a minute, how do you have an IPv4 address that can be port-forwarded?

I manually set up my route router to IPv4. Have the same IP since 12.04.2022. I had constant issues with their standard configuration so I changed it.

The cause for my question is that Vodafone Germany stopped providing real IPv4 addresses to home accounts in 2019. I had one as well and they took it away. Nowadays, they normally only provide “fake” IPV4 addresses that are shared with other users and cannot be port forwarded. Do you have a business account?

Nope. No business account. I simply disabled IPv6 support in my fritz box as well as the ds lite tunnel. Didn’t even know about Vodafone not providing real IPv4 adresses for non business accounts anymore.

This is surprising. Normally, at the very least you would have to call and ask them to enable an IPV4 address for you, and normally they say no. There are lots of threads on the Vodafone Germany forum.
May I ask which contract you have and how fast?

I don’t know the exact details but its internet only via good old copper cable. 100mbps up 40mbps down. 35,- eur p.m.

But maybe they enabled IPv4 without telling me after i constantly complained for a few months because I had weekly outages for a few hours which sucks if you work from home… had to call them almost weekly for a few months.

So nothing fancy :slight_smile: Very odd. Thanks. I guess I have to call them but I don’t have hope because they sent me a letter in 2019 telling me about ceasing to provide IPv4 addresses. At the time I didn’t need one so paid little attention …

1 Like

Fingers crossed!

Thanks, but I just searched through their forum once again and the recent threads all say clearly “no”.

Apparently they might have enabled v4 for customers affected by frequent outages, and they seem to be leaving existing ones in place for customers who have one from the past, but that’s purely goodwill and the contracts only promise DS-Lite.

That sucks. So with your DS-Lite configuration you can’t do any port forwarding at all?

Nope, except with external DynDNS solutions, apparently

Thats a real shame. Sorry mate. Might be worth switching to T-Online then?