Volume control MacOS with external USB DAC

Core Machine (Operating system/System info/Roon build number)
Roon Server on Syno DS 918+
MacBook (new) with Roon Remote

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Ethernet 1GB/s.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Cambridge Audio magic DAC by USB.

Description Of Issue
No volume Control, through Roon, only maximum volume.

It works fine from the macBook directly with vlc or quicktime.

Hello @familie_ehr,

You need to enable DSP Volume for the Cambridge DAC Magic zone.

A) Click on the volume widget icon located in the bottom right hand corner of the Roon app.

B) Click the “gears” icon in the Volume Widget.

C) Click the “Device Setup” button".

D) Change the “Volume Control” to “DSP Volume”.

E) Click the “Save” button.


Dear John,

so Done (same as previous) see screenshot 1

With play a title, no volume control is possible, (not „+“ ‚ „-„ Buttons, not slider, nor any control elements of the macbook)


Hello @familie_ehr,

It appears that something has gone wrong with the volume control in Roon. If you restart your computer, does the volume still show the large negative number in the volume widget?


I tried out:

(A) restart Mac with already attached DAC: same
(B) restart Mac without DAC attached later then launch roon.app: same
In both case I can see the high negativ number, without a change to change it.

(C.) Attach the DAC to a raspberry with roopie Image: it works fine.

  • Familie Ehr

Hello @familie_ehr,

Thank you for the report. I have filled a ticket with the QA team for further analysis. I will be sure to update you once they have had a chance to investigate this behavior.

In the meantime could you try:

A) Going to the “Device Setup” screen, clicking the “Load Defaults” button, and then clicking “Save”.
B) Reopen “Device Setup” and set the Volume Control to “DSP Volume” then clicking “Save”.


Sorry that the answer took so long. We were without the macbook in the holiday house.

I could try it now and it worked.

Thank you

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.