Volume defaults to 100 switching zones - massive risk to hearing

Roon Core Machine

RoonOnNAS Synology DS918+ Version 2.0 (Build 1143)

Connected Audio Devices

MacBook with USB DAC iBasso DC06
Sennheiser IE 600 In-Ear Headphones

Description of Issue

Recently I bought a pair of Sennheiser IE 600 as an alternative to my desktop audio setup with Streamer/DAC, Amplifier and Over-Ear Headphones. I used to use Roon with fixed volume only and change volume on the headphone amp instead.

With the new IE 600 I tend to listen directly from Roon on my MacBook with a connected iBasso DC06 USB-DAC and therefore have to control volume through Roon. The problem is, that whenever I connected the iBasso and select it as a zone the volume defaults to 100. This sound level is way too high for in-ears and could cause massive damage to the ears. I have set-up Volume Limits of 20 for this zone but still after I reconnect the device and select it as the zone the volume defaults back to 100.

I do not even want to think about the day I somehow forget to adjust the volume after switching a zone and getting blasted with 100 volume directly into my ear…

Is this expected behaviour for Roon? Why are volume levels not remembered for zones, and why are safety limits ignored? Or am I missing something like a setting in the app?

Thanks for your help.

Roon can’t control what the os is setting the volume to when you connect the DAC. Sounds like the os is setting it to 100 as soon as you connect the device and it has no memory of where it was last set. Roon will not change volume anything connected unless you do so via the app. Volume limits only stop a user in Roon from changing the volume above the set level, it doesn’t adjust a level that was originally set from outside of Roon that’s not its purpose. So if it’s above already it will show as being over the limit to start with. You likely need to use DSP volume here if possible rather then their flakey volume control. Had same issues with Dragonfly cobalt when I had one. On reset of Ropieee it will go to 100%.

Thanks. I think one of the problems is how Apple treats USB dongles on the various devices.

  • On my iPhone and when I connect the iBasso with the Lightning → USB-C cable Roon describes the output as USB-Output and volume is controled regularly with the device control. Volume setting is remembered.

  • On iPad Roon sees the iBasso simply as Headphone output but volume still per device control. Volume setting is remembered.

  • On Mac Roon recognizes the iBasso as an audio zone with its separate zone settings. Here I defined volume limits etc. But, after I reconnect the iBasso volume levels are reset to 100.

Weird that the same device is treated so differently from iPhone to iPad to Mac. But I do understand why Roon cannot control some of these things.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.