Volume Limits Overridden on start up to Hiby R5 DAP and Ropieee

@jamie chiming in here but I have found volume limits don’t work properly as I would expect them in.Roon I have flagged this before. It only works if the volume rises whilst it’s being run and not if the system audio or device audio has been accidentally set before starting Roon. I have had this happen a number of times on Ropieee and my DAP. Roon will start with whatever the device volumes is at time of booting up it doesn’t lower the volume to within the safety limits you have set. I have had issue lately with Ropieee setting my HifiBerry Amp HAT to max volume on reboot and Roon plays it as that even if I have volume limits set much lower. Same for my Android Hiby DAP which volume can get changed accidently quite easily and you don’t notice. Start Roon and it’s way over the safety limits. It would be good if Roon override the system set volume in cases like this. It does have exclusive use of the audio system so why does it not do this already? Seems to me its a big issue with Volume limits logic.

Also had this with Dragonfly Cobalt DAC on Linux in that every time it was connected or machine it was connected to set volume initially to 100% and ignored volume limits.

I just tested this on my Android tablet and can confirm that it works as expected. What are you trying to prove with your screenshot of the DAP? I can see that the volume is set on a volume over the comfort limit, this is not prohibited and can also be done in Roon itself - one just has to use the buttons as the slider wouldn’t allow for that change. So nothing for Roon to react upon. If you need safety limits, just set them and Roon should lower the volume to the max allowed (safety) limit if over that on start (what I just tested and worked). From your screenshot your upper safety limit is set to 100, is this not what you set it to?

I’m trying to show that volume limits don’t limit volume when Roon is started up. My images show me setting the DAP above what I have set for Roons volume limit as an example of what might accidentally happen. Start up Roon and it’s Instsntly over the limit it doesn’t attempt adjust it down you get deafening sound. Its done this countless times with Ropieee as well where it’s reset the volume to 100 on my amp hat on reboot. Roon has volume limits yet it plays out at 100. Considering it has exclusive access to these device and thus it can set the audio levels below the limits for safety. It’s very easy for a user to start it up without knowing the volume is set higher. It’s all fine and dandy when apps running and you accidentally move it higher that is not an issue but the other scenario which happens frequently does not. If you set a volume limit it needs to be a hard limit all the time.

Here is volume limit set at a hard 50 with comfort at 30. Puts the dap at 76 before starting Roon and this is what happens I get 76 volume and I’m deaf. It shows 50 as the upper limit but doesn’t alter it to be below.

Thank you for providing an example that actually demonstrates your point. Some questions though:

Does the volume immediately return to 50 (or 49) if you press the minus button once?
Does it return if you click the plus button too (not really expecting but hey, who knows without asking)?
Am I right that this example of yours is about the Bluetooth volume and not Androids built-in media volume?

It’s the DAPs volume Roon app is running on the DAP, no bluetooth. Same issue happens on Ropieee to. Not in at moment so can’t rest the volume to see if it goes down to 50 .

Back now. Tried it on my Naim Roon Ready system it’s the same. Also it’s remote can put the volume higher than Roons limits so it’s really pretty useless as someone could sit on the remote and bag my speakers are blown. In answer to your question no a touch of volume down does not lower it to the limit you have to get it all the way there yourself.

So your issues seems to be device dependent then. In my own test with my Android tablet and phone I was unable to reproduce your issue. Maybe (or obviously?) the volume control in your DAP works differently from (more) standard Android devices.

I wanted to test a little bit more. So I killed Roon from memory and rebooted my devices. I can now confirm and reproduce the behavior. I also doesn’t matter if lockscreen controls are on or off. While pressing the plus button doesn’t do anything (as expected) and pressing the minus button reduces the volume by one step per press, touching the slider moved the volume instantly down.

To me, this looks like Roon is initializing the volume controls from a saved state in its DB, assuming that the volume of the device hasn’t changed in the mean time. However, as the example shows, assumptions are unreliable.
I think, an added routine to zone initialization that sets the volume on the device might be able to remedy the issue. Of course, changing the volume outside of Roon via other means (like a device specific RC for example) might still allow to raise the volume over Roon’s safety limits.

Hey @Simon_Arnold3,

Thank you for getting back in touch with your observations regarding volume limits on your devices. Thanks to you as well @BlackJack for asking insightful questions and attempting to replicate.

I’m reaching out to our Hardware Expert about this and hope to have more details soon.

Hello again @Simon_Arnold3

This doesn’t appear to be a Roon problem, I’ll address why in a moment. What you’re experiencing is likely due to how UAC2 volume implementation is being handled on. the device itself.

A. Roon is does not change the volume of the device unless the user explicitly uses the volume slider or buttons.

B. The Roon volume limit prevents the Roon controls from setting the volume over a certain value, but it cannot prevent the device from changing its own volume.

C. You may be able to avoid this by using DSP volume instead of device volume. See last paragraph in this article and please give this a try:

What to stop Roon from setting the volume to within the limits when it’s started up exactly? These are all using RAAT not USB its the same on all Roon Ready Devices to… Roon has full control of these devices volume control on startup, device is doing nothing at this time so why on earth can’t Roon change the volume with the set limits.