Volume suddenly jumps to 100% on its own [Ticket In]

Thanks for your suggestion. Unfortunatly, I’m not getting the same MacroDroid “accessibility” screen shown in the YouTube tutorial. Do I actually need to buy the “professional” version of the app for this to work?

Hey @MBI,

No need to purchase any additional software for a workaround, you can always set volume limits in Roon for the time being.

As another thing to test on your end - if you disable “Enable Lock Screen Controls” under Setup in your settings, I’d be curious if you run into this issue again.

Overall, I have good news in that we were able to reproduce this issue on our end after all the help from the community. This will very much help with the turnaround of getting a solution built and released :+1:

I can’t yet speak on a specific timeline, but I will of course keep everyone in the loop as we make progress on it :pray:

1 Like

@MBI (and everybody else)

A pretty foolproof temporary “safety workaround”, let’s call it, is to simply set your Roon endpoint to “Fixed volume” and use the remote or (gasp) volume control knob on your preamp until Roon finds a fix. (When fixed volume is set, volume control doesn’t even appear in the Roon interface.)

If you are using DSP volume, just set the physical volume control on your device to something reasonable and then Roon can set a volume up to that point but obviously not above it. This also expands the slider (or contracts its range, depending on how you look at it) which makes the slider easier to set on an itty-bitty little phone screen. So it’s a good thing in any case.

The setting is per endpoint (Audio page in settings, scroll to the endpoint in question, click the gear icon, then choose “device setup”) so you can mix and match. At my house all the endpoints are either fixed or DSP already so I didn’t actually have to do anything.)


1 Like

Thanks for your workaround. However, I don’t have a preamp on my main system, which is only fed with AES digital signal. But there is a way to limit those monitors, which I’m about to do for safety reasons.

Thanks for the good news, Benjamin. Hope the solution is about to be found.

The first 2 times this happened to me the zone was set to fixed volume. So that may not be the best idea.

1 Like

I don’t understand. The “fixed volume” AFAIK is fixed at 100%. How can it go any higher? Am I missing something here?

I don’t know what to say. It was during the trial in 2019. I had the zone set to fixed and controlled the volume from my Denon receiver. Don’t recall what led to the event but at some point it went to full volume with no limiters in place. That actually happened twice but the second time I had a max volume restriction in place on the receiver.

Yipes. That doesn’t sound like the same bug to me. But it sounds scary nevertheless. If it hasn’t happened since, that part’s good. But it’s the kind of thing that leaves a nagging doubt in your mind.

Volume limiter doesn’t seem to show up in my Roon zone settings, what’s causing this please?

For me using Windows 10 laptop remote it is the speaker icon lower Right next to the zone selection on the playback control bar. Select the speaker Icon, then the gear wheel and finally the volume limits. Not sure where it is on other remote devices.

Thanks dear Mike_LC. Could be wrong, but making my way to the devices’ Audio settings list is something I believed had been achieved (see previous screenshot). It’s the volume limiter altogether that’s not showing among the settings.

Could be an active option forbiding the use the volume limiter, but that’s just a guess.

There’s a bunch of advanced settings too, among which I see “force max volume at playback start”. Decided it should be off for every device, even though the crazy “progressively increasing to maximum volume problem” may not originate from there as it’s a randomly occuring thing (or could it?).

I don’t see the volume limits from settings - audio - device setup. I can find it using the route mentioned above. Starting with the speaker icon, lower right next to the zone selection.

1 Like


A picture speaks a thousand words :pray:t3:


Very many thanks guys, solved!

The unsuccessful root I was trying to follow actually is still advised by the Roon help center (if Roon staff wants to rectify this, here’s the link again: https://help.roonlabs.com/portal/en/kb/articles/volume-limits)

Thanks again dear Lewis_Menzies1, PixelPopper and Mike_LC for having pointed this out and insisted despite my stuborness!


Only to confirm that turning the “force max volume at playback start” setting on or off unfortunatly doesn’t prevent the volume from going mad. It however reduced the signal close to silent in one of my zones. Had to turn it back on.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.

Hi. Is there any progress on this bug? I’ve had it nearly destroy my Sonos speakers a few times, making me reconsider using Roon at all.

Various reboots not effective, however, one reader suggested deselecting device volume in favor of fixed. Save, then reselect device volume & save. Slept on it. When I played a track this morning, all was good. Of the many things I tried, I believe that device/fixed volume trick seemed to be the charm.

1 Like