Waiting on Roon Core, Something’s not right, errors

Roon Core Machine

Roon Server on dedicated Apple Mini M1, 32 MB RAM.
Roon Remotes: MacBook Pro i9 remote, or older Mac desktop or iPhone 14.

Networking Gear & Setup Details

Core is connected directly to my router.

Connected Audio Devices

Number of Tracks in Library

About 120K tracks.
Mostly use Tidal.
Local media of about 500 CDs, on the Mini’s SSH.

Description of Issue

Increasing frequency of subject errors, with resultant stop in play of Tidal or local media.
Reboot of core helps but problem reappears.

I will move this to the support area where it will be seen by roon support.
Can you explain what “subject errors” means and give an example?

1 Like

Subject errors means look at the subject object line, and I get those errors. To b more clear, Roon starts playing, then I occasionally get a clock with a rotating bezel that also says, “Waiting on Roon Core”. Situation may resolve within a few seconds, but more likely times out and playback stops. In some cases I then get a “Something’s not right” error message, telling. me to check if Roon Core is operational or network connectivity is good…

Hello @Robert_Connors, I’d be grateful if you would complete the following template, making sure you describe your endpoints, and how these are connected to core and your network. Thanks.

Roon Core Machine

<!-- Include your operating system and machine info (Model, CPU, RAM) →
<!-- Write below this line →

Networking Gear & Setup Details

<!-- Your network gear (model of routers/switches) and if on WiFi/Ethernet, are you using YPN–>
<!-- Write below this line →

Connected Audio Devices

<!-- Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.) →
<!-- Write below this line →

Number of Tracks in Library

<!–Tell us how large your music library is, eg. “30,000 tracks” →
<!–Write below this line–>

Description of Issue

<!–Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated! →
<!–Write below this line–>

2 Likes

Hey @Robert_Connors,

Ben here with the support team, thanks for taking the time to write in.

As a first step, lets refresh your RAATserver database to see if that helps with your issue.

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Let me know if your issue persists after the above :+1: