Want to try ROCK, how stable is it?

I know, I troubleshooted that quite extensively. The only thing that made some sense was an SSD connector which is a bit strained with the case properly closed. So I left the case open which solved the database loading problem… but only for a couple of weeks. Then it came back…

so, since it’s a long bank holiday weekend and it’s raining here I spent some time on ebay and found this for only 120EUR.

Akasa Newton MC UCFF-/ Intel NUC5i3MYBE/Intel i3-5010U / 8GB DDR3-RAM /120GB-M.2-SSD (Kingston SM2280S3G2120G)

I thought that’s a good price since the case alone is about 100eur new. So I bought it and will install Rock as soon as it gets here from Germany.

That’s a really old NUC, and I believe I managed to get it supported, but it’s not one I would be looking to get.

Given that you’ve had issues in the past, unsure why you’d pick such hardware. I’m not saying it won’t work, it’s just asking for trouble.

1 Like

It’s on your recommended list, that’s why I would choose it… the list says “units that work very nicely as a Roon Core Server” maybe you want to update the list?


I do not have a Logitech remote so do not know a lot about them but see these threads:

Hope this helps.

1 Like

What an interesting exchange.

But it’s right down at the bottom, lol. Try and find a 7i3 or better, a 8i5 is probably at the sweet spot of cost vs. performance at the mo.

1 Like

Ok maybe this list needs an update to make clear that some devices will only sorta’ kinda’ work and we’re not even sure why they are on the list at all…

1 Like

A Honda Civic from 15 years ago was a great product and will get you to point A to B and every parking garage supports it, but if you are having problems today with your old car, you don’t go buy that 15 year old Honda.

My words are saying the NUC line works very nicely with Roon, but a “120EUR” investment into a 6-7 year old machine might result in getting what you paid for. I hope there wasn’t an SSD included in that – or a spinning drive. The spinning drive is against the suggested hardware, and an SSD that old is bound for failure.

All that said, I believe your real problem is with WiFi – unfortunately, you picked a NUC that we did support WiFi on… but if you use the WiFi on it, caveat emptor.

Give it a shot, it may work well… but it’s not the one I would have picked, especially in a fanless case.


for the milionth time, my Roon core is NOT connected via wifi. It is connected via ethernet cable.

Is it linked at 10-half, or better? A NUC should be able to link at gigabit speeds. Have you tried a different ethernet cable?

yes, it’s linked at 100FDX

Whoa… That 100FDX is a HUGE red flag.

If you are linked at 100FDX, either you are running ancient gear not capable of gigabit ethernet support, or the switch or the cable is damaged and can not negotiate to 1000FDX.


so is 1000FDX a requirement to run Roon?
and how would that affect the database loading, as this is the most important issue I have right now?
Later edit: I checked and it’s actually a 1Gb connection

I don’t work for Roon so answering this directly would be an opinion… so I’ll not answer… However… in saying that…

Almost all ethernet cabling since the early 2000 (really late 1990’s) has supported gigabit ethernet negotiation. For this reason, if you take a standard default switch and plug it into a standard default machine it should negotiate to gigabit. Anything late-2000 should negotiate to gigabit full duplex. You can use this bit of knowledge to identify cabling issues. The way 100mbit and 1000mbit get negotiated is very different and is almost always a cabling issue if the devices fall back to 100mbit. I think, more than the 100 mbit speeds, the lack of negotiation to gigabit was the concern here as that points directly at a faulty cable and sometimes faulty hardware issue. I do this for a living and I’m not immune to this. I’ve screwed-up cables or wall plates in the past (and even my current house I’m finding faulty terminations in the builder installed plates) and lack of gig negotiation was the easy clue to a cabling issue.

Thank you. I do have a bad cable that is complicated to replace (long, not interesting story) - that is why, first time I looked I thought that is the cable to my computer, but it is not. So that does not affect the Roon Core connection which is 1gb - at least if the Unifi controller can be trusted to report the connection correctly…

You’ve got me confused, is the bad cable involved or not? Is the 100FDX link involved or not?

Anyway, it sounds like you have an old NUC on the way, and that’s your next step to try out… hopefully things will all be good. If not, there are a lot of avenues for improvement here, ranging from cables to computers.

I have several devices in the same place, connected to the same switch, one of them is on 100FDX and I thought that was the roon core, turns out it wasn’t. the core is on 1gb.

I’ll try the old NUC to see what happens, if that doesn’t work I can put a better one in the same case.

Still I wish Roon stayed as stable as it was before 1.8…

An older NUC possibly wont support faster NVMe SSD’s either - so be careful to check - and also note that ROCK doesn’t support music on the boot drive so dont go getting a huge SSD to run ROCK as it really only needs like 64GB.

Some NUC’s only support one disk internally too so keep that in mind.

thanks, I did get that local music should be on another drive, luckily I don’t have much local music. I expect that this low-end NUC will suffer some experiments only to be replaced by a better one later on… that is unless Roon catches up and there are no more issues under windows. I don’t WANT a NUC/ROCK, at this moment is seems I HAVE to try one…