WASAPI audio device: Roon no longer sees Brooklyn DAC+ capabilities or plays music

Core Machine (Operating system/System info/Roon build number)

MacOS 10.15.6/2013 mac mini/Roon 1.7 (build 610)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear orbi mesh wifi network w/ Gbe fiber internet connection

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Mytek Brooklyn DAC+ connected via USB to NUC running Win 10 64 (latest build). Running Roon client.

Description Of Issue

For a month or so, I was happily playing music via the WASAPI Roon audio device. I installed latest Mytek 4.45 WASAPI driver. Roon saw the DAC+ and all its capabilities in device setup.

As of a week ago I no longer saw this device. I did see the ASIO device. After a windows reboot, I see the WASAPI device, but when going into device setup, I don’t see the Brooklyn DAC+ recognized, and don’t see MQA, DSD and other options… only a few simple options like exclusive, volume. When I try and play through this device, roon quickly lists all the songs on an album (in less than 1 sec) and no audio.

I’ve tried to uninstall and reinstall the Mytek WASAPI driver, uninstalled and reinstalled roon client, tried roon bridge… always I see this device with limited features that won’t play anything. I’ve also tried to hit the default button in device setup. I get the same limited set of features. Manually saying its a DAC+ doesn’t change anything.

How can I get Roon to ‘forget’ this device so it will re-recognize the Brooklyn DAC+? Other things to try?

BTW the ASIO device works, when it appears which isn’t always.

Hi @Toneman82,

Welcome to the forum!

Have you tried a different USB cable / port on the NUC yet? What happens if you try to plug the Mytek in directly to the Core, even if it uses a different driver, does it work as expected?

Core is in a different part of the house so I can’t try that. I have connected the DAC directly to a mac mini in the listening room and it works fine. Have tried different ports on NUC… the usual things.
I also saw a post here to rename the RAATServer directory (in the hidden windows app data) and let Roon recreate it and that didn’t help.
Maybe an issue with the Mytek driver? Are there some logs I can read to find out what Roon is seeing when asking the DAC for capabilities?

Hi @Toneman82,

Yes, it does sound like an issue with that driver, I would also start reaching out to Mytek support.

You can access Roon logs by using these instructions

Since this is not your Core, you can also try to perform a full reinstall of the Roon app on this remote:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location (under %localappdata% on the remote, not the Mac Core)
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.